	<!doctype html>
<html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js">
<head>
    <meta charset="UTF-8" /><script type="text/javascript">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</script>
    <meta name="viewport" content="width=device-width, initial-scale=1.0" />

    <link rel="preconnect" href="https://ksassets.timeincuk.net" crossorigin>
<link rel="preconnect" href="https://assets.ti-media.net" crossorigin>
<link rel="preconnect" href="https://www.google-analytics.com" crossorigin>
<link rel="preconnect" href="https://js-sec.indexww.com" crossorigin>
<link rel="preconnect" href="https://www.googletagservices.com" crossorigin>
<link rel="preconnect" href="https://widget.eagleapi.io" crossorigin>
<link rel="preconnect" href="https://mobiles.eagleapi.io" crossorigin>
<link rel="preconnect" href="https://fashion-widget.eagleapi.io" crossorigin>
<link rel="preconnect" href="https://public.eagleapi.io" crossorigin>
<link rel="preconnect" href="https://content.jwplatform.com" crossorigin>
<link rel="preconnect" href="https://jwpltx.com" crossorigin>
<link rel="preconnect" href="https://ssl.p.jwpcdn.com" crossorigin>
<link rel="preconnect" href="https://cdn.taboola.com" crossorigin>
<link rel="preconnect" href="https://trc.taboola.com" crossorigin>


    <title>Final Fantasy 8 Remastered Review | Trusted Reviews</title>
<link rel="preload" href="https://www.trustedreviews.com/wp-content/plugins/keystone-jwplayer/assets/css/main.css" as="style" onload="this.onload=null;this.rel='stylesheet'"><script async>!function(n){"use strict";n.loadCSS||(n.loadCSS=function(){});var o=loadCSS.relpreload={};if(o.support=function(){var e;try{e=n.document.createElement("link").relList.supports("preload")}catch(t){e=!1}return function(){return e}}(),o.bindMediaToggle=function(t){var e=t.media||"all";function a(){t.addEventListener?t.removeEventListener("load",a):t.attachEvent&&t.detachEvent("onload",a),t.setAttribute("onload",null),t.media=e}t.addEventListener?t.addEventListener("load",a):t.attachEvent&&t.attachEvent("onload",a),setTimeout(function(){t.rel="stylesheet",t.media="only x"}),setTimeout(a,3e3)},o.poly=function(){if(!o.support())for(var t=n.document.getElementsByTagName("link"),e=0;e<t.length;e++){var a=t[e];"preload"!==a.rel||"style"!==a.getAttribute("as")||a.getAttribute("data-loadcss")||(a.setAttribute("data-loadcss",!0),o.bindMediaToggle(a))}},!o.support()){o.poly();var t=n.setInterval(o.poly,500);n.addEventListener?n.addEventListener("load",function(){o.poly(),n.clearInterval(t)}):n.attachEvent&&n.attachEvent("onload",function(){o.poly(),n.clearInterval(t)})}"undefined"!=typeof exports?exports.loadCSS=loadCSS:n.loadCSS=loadCSS}("undefined"!=typeof global?global:this);</script><style>
@font-face {
	font-family: "keystone";
	font-weight: normal;
	font-style: normal;
	font-display: fallback;
	src:	url("//www.trustedreviews.com/wp-content/themes/simba-theme/assets/fonts/standard.woff2?v=1568371196") format("woff2"),
	url("//www.trustedreviews.com/wp-content/themes/simba-theme/assets/fonts/standard.woff?v=1568371196") format("woff");
}
.icon-spinner {
	background-image: url("//www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/spinner.gif");
}

</style><style>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</style><link rel="preload" href="https://www.trustedreviews.com/wp-content/themes/kiara-child-theme/assets/css/sites/post.min.css?1568371196" as="style" onload="this.onload=null;this.rel='stylesheet'">		<script type="text/javascript">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</script>
<meta name="description" content="If you’re looking for something to burn through while waiting for Final Fantasy 7 Remake, FF8 Remastered will sate your twitching nostalgia glands."/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="https://www.trustedreviews.com/reviews/final-fantasy-8-remastered" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Final Fantasy 8 Remastered Review | Trusted Reviews" />
<meta property="og:description" content="If you’re looking for something to burn through while waiting for Final Fantasy 7 Remake, FF8 Remastered will sate your twitching nostalgia glands." />
<meta property="og:url" content="https://www.trustedreviews.com/reviews/final-fantasy-8-remastered" />
<meta property="og:site_name" content="Trusted Reviews" />
<meta property="article:publisher" content="https://www.facebook.com/TrustedReviews/" />
<meta property="og:image" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-1024x576.jpg" />
<meta property="og:image" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05-1024x576.jpg" />
<meta property="og:image" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-1024x576.jpg" />
<meta property="og:image" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-1024x576.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="If you’re looking for something to burn through while waiting for Final Fantasy 7 Remake, FF8 Remastered will sate your twitching nostalgia glands." />
<meta name="twitter:title" content="Final Fantasy 8 Remastered Review | Trusted Reviews" />
<meta name="twitter:site" content="@trustedreviews" />
<meta name="twitter:image" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-1024x576.jpg" />
<meta name="twitter:creator" content="@Thomas_Newton" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//widget.eagleapi.io' />
<link rel="alternate" type="application/rss+xml" title="Trusted Reviews &raquo; Feed" href="https://www.trustedreviews.com/feed" />
<script type='text/javascript' src='https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/js/dist/jquery-3.3.1.min.js?ver=3.3.1'></script>
<link rel='https://api.w.org/' href='https://www.trustedreviews.com/wp-json/' />
<link rel="alternate" type="application/json+oembed" href="https://www.trustedreviews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.trustedreviews.com%2Freviews%2Ffinal-fantasy-8-remastered" />
<link rel="alternate" type="text/xml+oembed" href="https://www.trustedreviews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.trustedreviews.com%2Freviews%2Ffinal-fantasy-8-remastered&#038;format=xml" />
<meta name="eagle_website" content="trusted-reviews">
<meta name="eagle_env" content="production">
<meta name="eagle_version" content="2.25.26">
<meta name="eagle_uid" content="review-3936483">
<meta name="eagle_category" content="games">
<meta name="eagle_model" content="Final Fantasy 8 Remastered">
<meta name="eagle_brand" content="Square-Enix">
<meta name="eagle_price" content="{&quot;GBP&quot;:&quot;15.99&quot;}">
<meta name="eagle_page_type" content="review">
<meta name="eagle_content_id" content="3936483">
<meta name="eagle_page_date" content="1568383245">
<script type='application/ld+json'>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</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Article","headline":"Final Fantasy 8 Remastered","url":"https:\/\/www.trustedreviews.com\/reviews\/final-fantasy-8-remastered","thumbnailUrl":"https:\/\/ksassets.timeincuk.net\/wp\/uploads\/sites\/54\/2019\/09\/cropped-Vamers-Gaming-FF8R-tweet-revives-classic-meme-01.jpeg","image":"https:\/\/ksassets.timeincuk.net\/wp\/uploads\/sites\/54\/2019\/09\/cropped-Vamers-Gaming-FF8R-tweet-revives-classic-meme-01.jpeg","dateCreated":"2019-09-13T14:00:45+00:00","datePublished":"2019-09-13T14:00:45+00:00","dateModified":"2019-09-13T14:16:35+00:00","articleSection":"Review","creator":{"@type":"Person","name":"Thomas Newton"},"author":{"@type":"Person","name":"Thomas Newton"},"publisher":{"@type":"Organization","name":"Trusted Reviews","logo":{"@type":"http:\/\/schema.org\/ImageObject","url":"https:\/\/ksassets.timeincuk.net\/wp\/uploads\/sites\/54\/2018\/10\/tr-logo-large-1.png"}},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.trustedreviews.com\/reviews\/final-fantasy-8-remastered"},"keywords":["Square-Enix","Nintendo","PlayStation","Video Game","Xbox"]}</script>
<meta property="fb:pages" content="38275114220" />		<script type="text/javascript" charset="utf-8">
		(function(a,b,c,d){
		    var protocol = "https://";
		    a="assets.ti-media.net/js/e1512726446_2a23693/min/gtm/utils-min.js";
		    b=document;c='script';d=b.createElement(c);d.src=protocol+a;d.async=true;d.type='text/java'+c;
		    a=b.getElementsByTagName(c)[0];a.parentNode.insertBefore(d,a);
		 })();
		</script>
	      <!-- Google Tag Manager -->
      <script>(function ( w, d, s, l, i ) {
          w[ l ] = w[ l ] || [];
          w[ l ].push({
            'gtm.start' :
              new Date().getTime(), event : 'gtm.js'
          });
          var f = d.getElementsByTagName(s)[ 0 ],
            j = d.createElement(s), dl = l != 'dataLayer' ? '&l=' + l : '';
          j.async = true;
          j.src =
            'https://www.googletagmanager.com/gtm.js?id=' + i + dl;
          f.parentNode.insertBefore(j, f);
        })(window, document, 'script', 'dataLayer','GTM-PHQNFGV');</script>
      <!-- End Google Tag Manager -->
      <link rel="icon" href="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/cropped-trusted-reviews-icon-3-32x32.png" sizes="32x32" />
<link rel="icon" href="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/cropped-trusted-reviews-icon-3-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/cropped-trusted-reviews-icon-3-180x180.png" />
<meta name="msapplication-TileImage" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/cropped-trusted-reviews-icon-3-270x270.png" />
		<style type="text/css" id="wp-custom-css">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</style>
	    				</head>

<body class="core_review-template-default single single-core_review postid-3936483 has-adverts y2019 m09 d13 h16 final-fantasy-8-remastered standard slim-header">


<div class="parallax-wrapper parallax-wrapper--header"></div>

      <!-- Google Tag Manager (noscript) -->
      <noscript>
        <iframe
            src="https://www.googletagmanager.com/ns.html?id=GTM-PHQNFGV"
            height="0" width="0"
            style="display:none;visibility:hidden"></iframe>
      </noscript>
      <!-- End Google Tag Manager (noscript) -->
      
<div id="wrapper" class="hfeed">

	    
			<header id="header" role="banner" class="header s-container has-single-tier">

	<div class="header__inner">

					<div itemscope itemtype="http://schema.org/Organization" class="logo header-slot header-slot-">
    <a itemprop="url" href="/" title="Trusted Reviews" name="Trusted Reviews">
    	<span class="hide">Link to home</span>
	<picture>
		<source media="(min-width: 728px)" srcset="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/08/trusted-reviews-logo-white.png" >
		<source media="(max-width: 727px)" srcset="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/08/trusted-reviews-logo-white.png" >
		<img src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/08/trusted-reviews-logo-white.png" alt="hero profile" itemprop="logo" aria-hidden="true" data-pin-nopin="true">
	</picture>
    </a>
</div>
		
	</div>

		<nav>
	<ul class="navigation hide-overflow-items" data-nav="closed">
					<li class="has-subnav">
				<a href="https://www.trustedreviews.com/" class= " "   title="Home Page"   name="See our new homepage">
									See our new homepage
								</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="/reviews"     name="All Reviews">All Reviews</a>
															</li>
													<li >
								<a href="/category/news"     name="All News">All News</a>
															</li>
													<li >
								<a href="/category/opinion"     name="All Opinions">All Opinions</a>
															</li>
													<li >
								<a href="/category/deals"     name="All Deals">All Deals</a>
															</li>
													<li >
								<a href="/latest-articles"     name="100 Latest Articles">100 Latest Articles</a>
															</li>
													<li >
								<a href="http://comps.trustedreviews.com"     name="Win">Win</a>
															</li>
											</ul>
							</li>
					<li class="has-subnav">
				<a href="/reviews" class= " "    name="Reviews">
									Reviews
								</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="/reviews/tvs-audio"     name="TV and Audio Reviews">TV and Audio Reviews</a>
															</li>
													<li >
								<a href="/reviews/digital-cameras"     name="Camera Reviews">Camera Reviews</a>
															</li>
													<li >
								<a href="/reviews/computing"     name="Computing Reviews">Computing Reviews</a>
															</li>
													<li >
								<a href="/reviews/mobile"     name="Mobile Reviews">Mobile Reviews</a>
															</li>
													<li >
								<a href="/reviews/home-appliances"     name="Home Appliance Reviews">Home Appliance Reviews</a>
															</li>
													<li >
								<a href="/reviews/gaming"     name="Gaming Reviews">Gaming Reviews</a>
															</li>
											</ul>
							</li>
					<li >
				<a href="https://www.trustedreviews.com/category/best" class= " "    name="Best Lists">
									Best Lists
								</a>
							</li>
					<li class="has-subnav">
				<a href="https://www.trustedreviews.com/mobile" class= " "    name="Mobile">
									Mobile
								</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="https://www.trustedreviews.com/type/gps-sat-nav"     name="GPS and Sat Nav">GPS and Sat Nav</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/mobile-apps"     name="Mobile App">Mobile App</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/mobile-phone-accessories"     name="Mobile Phone Accessory">Mobile Phone Accessory</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/mobile-phones"     name="Mobile Phone">Mobile Phone</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/tablets"     name="Tablet">Tablet</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/wearables-fitness"     name="Wearables and Fitness">Wearables and Fitness</a>
															</li>
											</ul>
							</li>
					<li class="has-subnav">
				<a href="https://www.trustedreviews.com/computing" class= " "    name="Computing">
									Computing
								</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="https://www.trustedreviews.com/type/desktop-pcs"     name="Desktop PC">Desktop PC</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/internet"     name="Internet, VPNs and Web Software">Internet, VPNs and Web Software</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/laptops"     name="Laptop">Laptop</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/monitors"     name="Monitor">Monitor</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/pc-components"     name="PC Component">PC Component</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/peripherals"     name="Peripheral">Peripheral</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/printers"     name="Printer">Printer</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/routers-networking"     name="Routers and Networking">Routers and Networking</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/software"     name="Software">Software</a>
															</li>
											</ul>
							</li>
					<li class="has-subnav">
				<a href="https://www.trustedreviews.com/home-appliances" class= " "    name="Home Tech">
									Home Tech
								</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="https://www.trustedreviews.com/type/blender"     name="Blender">Blender</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/coffee-machines"     name="Coffee Machine">Coffee Machine</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/cooker"     name="Cooker">Cooker</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/dishwashers"     name="Dishwasher">Dishwasher</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/fans"     name="Fan">Fan</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/freezers"     name="Freezer">Freezer</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/fridges"     name="Fridge">Fridge</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/fridge-freezers"     name="Fridge Freezer">Fridge Freezer</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/garden-tools"     name="Garden Tool">Garden Tool</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/iron"     name="Iron">Iron</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/kettles"     name="Kettle">Kettle</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/kitchen-gadgets"     name="Kitchen Gadget">Kitchen Gadget</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/microwave"     name="Microwave">Microwave</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/mixers"     name="Mixer">Mixer</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/ovens"     name="Oven">Oven</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/personal-care"     name="Personal Care">Personal Care</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/smart-home"     name="Smart Home">Smart Home</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/steam-cleaners"     name="Steam Cleaner">Steam Cleaner</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/toasters"     name="Toaster">Toaster</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/tumble-dryers"     name="Tumble Dryer">Tumble Dryer</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/vacuum-cleaners"     name="Vacuum Cleaner">Vacuum Cleaner</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/washer-dryers"     name="Washer Dryer">Washer Dryer</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/washing-machines"     name="Washing Machine">Washing Machine</a>
															</li>
											</ul>
							</li>
					<li class="has-subnav">
				<a href="https://www.trustedreviews.com/tvs-audio" class= " "    name="TV / Audio">
									TV / Audio
								</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="https://www.trustedreviews.com/type/blu-ray-players"     name="Blu-ray Player">Blu-ray Player</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/dvrs-and-media-players"     name="DVRs and Media Player">DVRs and Media Player</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/gadgets"     name="Gadgets">Gadgets</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/headphones"     name="Headphones">Headphones</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/hi-fi-wireless-audio"     name="Hi-Fi and Wireless Audio">Hi-Fi and Wireless Audio</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/portable-audio"     name="Portable Audio">Portable Audio</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/projectors"     name="Projector">Projector</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/sound-bars"     name="Sound Bar">Sound Bar</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/surround-sound-systems"     name="Surround Sound System">Surround Sound System</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/tvs"     name="TV">TV</a>
															</li>
											</ul>
							</li>
					<li class="has-subnav">
				<a href="https://www.trustedreviews.com/cameras" class= " "    name="Cameras">
									Cameras
								</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="https://www.trustedreviews.com/type/camcorders"     name="Camcorder">Camcorder</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/camera-accessories"     name="Camera Accessory">Camera Accessory</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/camera-lenses"     name="Camera Lens">Camera Lens</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/digital-cameras"     name="Camera">Camera</a>
															</li>
											</ul>
							</li>
					<li class="has-subnav">
				<a href="https://www.trustedreviews.com/gaming" class= " "    name="Games">
									Games
								</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="https://www.trustedreviews.com/type/games"     name="Video Game">Video Game</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/games-accessories"     name="Video Game Accessory">Video Game Accessory</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/nintendo"     name="Nintendo">Nintendo</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/pc"     name="PC Gaming">PC Gaming</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/playstation"     name="PlayStation">PlayStation</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/toys"     name="Toy">Toy</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/vr"     name="VR">VR</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/xbox"     name="Xbox">Xbox</a>
															</li>
											</ul>
							</li>
					<li >
				<a href="https://discountcodes.trustedreviews.com" class= " "    name="Discount Codes">
									Discount Codes
								</a>
							</li>
		
		
					<li class="has-subnav header-slot-right nav-follow">
				<span class="submenu-toggle icon-arrow-down"></span>
				<a href="javascript:void(0);" name="Follow us on social media">Follow</a>
				<ul class="nav-social">
											<li><a href="https://www.facebook.com/pages/TrustedReviews/38275114220?ref=ts" target="_blank" rel="noopener" name="Follow us on Facebook">Facebook</a></li>
											<li><a href="https://twitter.com/trustedreviews" target="_blank" rel="noopener" name="Follow us on Twitter">Twitter</a></li>
											<li><a href="https://www.youtube.com/user/TrustedReviews" target="_blank" rel="noopener" name="Follow us on YouTube">YouTube</a></li>
											<li><a href="https://www.trustedreviews.com/rss-feeds" target="_blank" rel="noopener" name="Follow us on Follow Trusted Reviews via RSS">Follow Trusted Reviews via RSS</a></li>
									</ul>
			</li>
		
		<li class="menu-more has-subnav">
			<a href="javascript:void(0)" name="See more menu items">More <span class="icon-plus"></span></a>
			<ul></ul>
		</li>
	</ul>

	<a href="javascript:void(0)" class="search-site icon-search" name="Search the site"><span class="hide">Search</span></a>

	<a href="#" class="menu-icon-link hidden-md hidden-lg" name="Toggle the site menu">
		<span class="menu-toggle icon-menu"><span class="hide">Menu</span></span>
	</a>

	<form role="search" method="get" class="search-form form-inline s-container" action="/">
		<div class="input-group">
			<input type="search" value="" name="s" class="input-sm search-field form-control" placeholder="Search">
							<button type="submit" class="btn btn--sm" name="search">Search</button>
						<div class="message-wrapper">
				<label for="s" class="message message--type">Type to search</label>
				<label for="s" class="message message--search hide">Press enter or click on the search icon</label>
			</div>
		</div>
	</form>
</nav>

</header>	


	<div id="content" role="main" class="container-fluid" itemscope itemtype="http://schema.org/Product" itemid="#structured-product"
>
													<div class="trending">
	<div class="trending__inner">
		<div class="trending-list__outer">
			<ul class="trending-list__inner">
				<li>Trending:</li>
									<li><a href="https://www.trustedreviews.com/news/android-q-features-2-3674497"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3935931"     name="Android 10">Android 10</a></li>
									<li><a href="https://www.trustedreviews.com/tag/iphone-11"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3931060"     name="iPhone 11">iPhone 11</a></li>
									<li><a href="/news/iphone-11-pro-release-date-price-specs-3936937"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3628349"     name="iPhone 11 Pro">iPhone 11 Pro</a></li>
									<li><a href="https://www.trustedreviews.com/news/pixel-4-release-date-price-specs-3856456"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3641029"     name="Pixel 4">Pixel 4</a></li>
									<li><a href="https://www.trustedreviews.com/best/best-iphone-3501342"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3628352"     name="Best iPhone">Best iPhone</a></li>
									<li><a href="https://www.trustedreviews.com/news/ps5-release-date-news-specs-price-2993694"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3922840"     name="PS5">PS5</a></li>
									<li><a href="https://www.trustedreviews.com/best/best-free-vpn-3692123"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3936304"     name="Best free VPN">Best free VPN</a></li>
							</ul>
		</div>
		<div class="trending__fade trending__fade--before"></div>
		<div class="trending__fade trending__fade--after"></div>
	</div>
</div>					
		
	<style>

		.has-adverts {
			margin-top: 0px !important;
		}

	</style>

	

					<nav class="breadcrumb s-container"  role="navigation">
	<div class="s-container__inner">
		<ul xmlns:v="http://rdf.data-vocabulary.org/#">
							<li typeof="v:Breadcrumb">
					<a href="https://www.trustedreviews.com" rel="v:url" property="v:title" name="Home">Home</a>
				</li>
							<li typeof="v:Breadcrumb">
					<a href="https://www.trustedreviews.com/reviews" rel="v:url" property="v:title" name="Reviews">Reviews</a>
				</li>
							<li typeof="v:Breadcrumb">
					<a href="https://www.trustedreviews.com/reviews/gaming" rel="v:url" property="v:title" name="Gaming">Gaming</a>
				</li>
							<li typeof="v:Breadcrumb">
					<a href="https://www.trustedreviews.com/reviews/games" rel="v:url" property="v:title" name="Video Games">Video Games</a>
				</li>
							<li typeof="v:Breadcrumb">
					<a href="https://www.trustedreviews.com/reviews/games/square-enix" rel="v:url" property="v:title" name="Square-Enix">Square-Enix</a>
				</li>
					</ul>
	</div>
</nav>	
				<meta itemprop="name" content="Final Fantasy 8 Remastered">
	
			<meta itemprop="manufacturer" content="Square-Enix">
		<article
			class="post-3936483 core_review type-core_review status-publish hentry brands-square-enix product_type-nintendo product_type-playstation product_type-games product_type-xbox post"
			role="article"
			itemprop="review"
			itemscope itemtype="http://schema.org/Review"
	>
							<meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.trustedreviews.com/reviews/final-fantasy-8-remastered" content="" />
			<div itemprop="publisher" itemscope itemtype="http://schema.org/Organization">
	<meta itemprop="name" content="Trusted Reviews" />
	<div itemprop="logo" itemscope itemtype="http://schema.org/ImageObject">
		<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/08/trusted-reviews-logo-white.png" />
	</div>
</div>		

					
		
		<div class="post-main">

				<header class="post-header post-header--article">
		<h1 class="title-primary" itemprop="headline">
												Final Fantasy 8 Remastered Review
									</h1>

									<div class="review__intro">Final Fantasy 8 Remastered is exactly what it says on the tin – a remastered version of Square Enix's celebrated JRPG now available for PS4, Xbox One, PC and Switch. </div>
					
					<div class="post-author">
    <small class="post-author-info">
                    
            <span itemprop="author" itemscope itemtype="http://schema.org/Person">
                <a class="post-author__name url fn n" href="https://www.trustedreviews.com/author/thomasnewton" name="A post from Thomas Newton">
                    <span class="author vcard" itemprop="name">Thomas Newton</span>
                </a>
                                    <a rel="me noopener" href="https://twitter.com/Thomas_Newton" target="_blank" class="post-author__icon--twitter" name="Visit the authors Twitter" onClick="kiara.onTwitterIconClick(`Thomas Newton`)">
                        <svg xmlns="http://www.w3.org/2000/svg" width="10" height="10" viewBox="0 0 512.002 512.002" style="enable-background:new 0 0 512.002 512.002;" xml:space="preserve">
                            <path d="M500.398,94.784c-8.043,3.567-16.313,6.578-24.763,9.023c10.004-11.314,17.631-24.626,22.287-39.193 c1.044-3.265-0.038-6.839-2.722-8.975c-2.681-2.137-6.405-2.393-9.356-0.644c-17.945,10.643-37.305,18.292-57.605,22.764 c-20.449-19.981-48.222-31.353-76.934-31.353c-60.606,0-109.913,49.306-109.913,109.91c0,4.773,0.302,9.52,0.9,14.201 c-75.206-6.603-145.124-43.568-193.136-102.463c-1.711-2.099-4.347-3.231-7.046-3.014c-2.7,0.211-5.127,1.734-6.491,4.075 c-9.738,16.709-14.886,35.82-14.886,55.265c0,26.484,9.455,51.611,26.158,71.246c-5.079-1.759-10.007-3.957-14.711-6.568 c-2.525-1.406-5.607-1.384-8.116,0.054c-2.51,1.439-4.084,4.084-4.151,6.976c-0.012,0.487-0.012,0.974-0.012,1.468 c0,39.531,21.276,75.122,53.805,94.52c-2.795-0.279-5.587-0.684-8.362-1.214c-2.861-0.547-5.802,0.456-7.731,2.638 c-1.932,2.18-2.572,5.219-1.681,7.994c12.04,37.591,43.039,65.24,80.514,73.67c-31.082,19.468-66.626,29.665-103.939,29.665 c-7.786,0-15.616-0.457-23.279-1.364c-3.807-0.453-7.447,1.795-8.744,5.416c-1.297,3.622,0.078,7.66,3.316,9.736 c47.935,30.735,103.361,46.98,160.284,46.98c111.903,0,181.907-52.769,220.926-97.037c48.657-55.199,76.562-128.261,76.562-200.451 c0-3.016-0.046-6.061-0.139-9.097c19.197-14.463,35.724-31.967,49.173-52.085c2.043-3.055,1.822-7.094-0.545-9.906 C507.7,94.204,503.76,93.294,500.398,94.784z"/>
                        </svg>
                        <span class="visuallyhidden">Contact via Twitter</span>
                    </a>
                                <span class="vertical-bar">&vert;</span>
            </span>

        
        
                            <span>
                                <time datetime="2019-09-13T14:16:35+01:00">September 13, 2019 2:16 pm BST</time>
            </span>
                <meta itemprop="datePublished" content="2019-09-13T14:00:45+01:00"/>        <meta itemprop="dateModified" content="2019-09-13T14:16:35+01:00"/>    </small>
</div>		
		<div class="review__icons">
		
								<div class="review-rating--score">
		
		
		
		
					<div class="score-stars score-stars--large"
											itemprop="reviewRating" itemscope itemtype="http://schema.org/Rating"
								>
												<span
						class="star icon-star-full "
						data-rating="20"
					></span>
																								<span
						class="star icon-star-full "
						data-rating="40"
					></span>
																								<span
						class="star icon-star-full "
						data-rating="60"
					></span>
																								<span
						class="star icon-star-full "
						data-rating="80"
					></span>
																																<span
						class="star icon-star-empty "
						data-rating="100"
					></span>
									
					<meta itemprop="bestRating" content="5">
			<meta itemprop="worstRating" content="0">
							<meta itemprop="ratingValue" content="4">
						</div>

		</div>
			
			
				<div class="social-share">

										
																														<ul class="pw-widget hidden-xs">
															<li>
									<a
										href="https://www.facebook.com/sharer/sharer.php?u=https://www.trustedreviews.com/reviews/final-fantasy-8-remastered"
										target="_blank"
										 rel="noopener" 										class="share-button "
										data-url="https://www.trustedreviews.com/reviews/final-fantasy-8-remastered"
										name="Share this page on facebook"
									>
																					<svg xmlns="http://www.w3.org/2000/svg" width="13" height="25" viewBox="88.428 12.828 107.543 207.085"><path d="M158.232 219.912v-94.461h31.707l4.747-36.813h-36.454V65.134c0-10.658 2.96-17.922 18.245-17.922l19.494-.009V14.278c-3.373-.447-14.944-1.449-28.406-1.449-28.106 0-47.348 17.155-47.348 48.661v27.149H88.428v36.813h31.788v94.461l38.016-.001z" fill="#3c5a9a"/></svg>
																			</a>
								</li>
															<li>
									<a
										href="https://twitter.com/intent/tweet?url=https://www.trustedreviews.com/reviews/final-fantasy-8-remastered&text=Final Fantasy 8 Remastered Review"
										target="_blank"
										 rel="noopener" 										class="share-button "
										data-url="https://www.trustedreviews.com/reviews/final-fantasy-8-remastered"
										name="Share this page on twitter"
									>
																					<svg xmlns="http://www.w3.org/2000/svg" width="25" height="25" viewBox="0 0 512.002 512.002" style="enable-background:new 0 0 512.002 512.002;" xml:space="preserve"><path style="fill:#73A1FB;" d="M500.398,94.784c-8.043,3.567-16.313,6.578-24.763,9.023c10.004-11.314,17.631-24.626,22.287-39.193 c1.044-3.265-0.038-6.839-2.722-8.975c-2.681-2.137-6.405-2.393-9.356-0.644c-17.945,10.643-37.305,18.292-57.605,22.764 c-20.449-19.981-48.222-31.353-76.934-31.353c-60.606,0-109.913,49.306-109.913,109.91c0,4.773,0.302,9.52,0.9,14.201 c-75.206-6.603-145.124-43.568-193.136-102.463c-1.711-2.099-4.347-3.231-7.046-3.014c-2.7,0.211-5.127,1.734-6.491,4.075 c-9.738,16.709-14.886,35.82-14.886,55.265c0,26.484,9.455,51.611,26.158,71.246c-5.079-1.759-10.007-3.957-14.711-6.568 c-2.525-1.406-5.607-1.384-8.116,0.054c-2.51,1.439-4.084,4.084-4.151,6.976c-0.012,0.487-0.012,0.974-0.012,1.468 c0,39.531,21.276,75.122,53.805,94.52c-2.795-0.279-5.587-0.684-8.362-1.214c-2.861-0.547-5.802,0.456-7.731,2.638 c-1.932,2.18-2.572,5.219-1.681,7.994c12.04,37.591,43.039,65.24,80.514,73.67c-31.082,19.468-66.626,29.665-103.939,29.665 c-7.786,0-15.616-0.457-23.279-1.364c-3.807-0.453-7.447,1.795-8.744,5.416c-1.297,3.622,0.078,7.66,3.316,9.736 c47.935,30.735,103.361,46.98,160.284,46.98c111.903,0,181.907-52.769,220.926-97.037c48.657-55.199,76.562-128.261,76.562-200.451 c0-3.016-0.046-6.061-0.139-9.097c19.197-14.463,35.724-31.967,49.173-52.085c2.043-3.055,1.822-7.094-0.545-9.906 C507.7,94.204,503.76,93.294,500.398,94.784z"/></svg>
																			</a>
								</li>
															<li>
									<a
										href="http://pinterest.com/pin/create/button/?url=https://www.trustedreviews.com/reviews/final-fantasy-8-remastered&description=Final Fantasy 8 Remastered Review"
										target="_blank"
										 rel="noopener" 										class="share-button "
										data-url="https://www.trustedreviews.com/reviews/final-fantasy-8-remastered"
										name="Share this page on pinterest"
									>
																					<svg xmlns="http://www.w3.org/2000/svg" width="25" height="25" viewBox="0 0 512.883 512.883" style="enable-background:new 0 0 512.883 512.883;" xml:space="preserve"> <path style="fill:#CB1F24;" d="M256.441,0c-141.241,0-256,114.759-256,256c0,105.048,62.676,195.09,153.6,234.814 c-0.883-17.655,0-39.724,4.414-59.145c5.297-21.186,32.662-139.476,32.662-139.476s-7.945-16.772-7.945-40.607 c0-37.959,22.069-66.207,49.434-66.207c22.952,0,34.428,17.655,34.428,38.841c0,22.952-15.007,58.262-22.952,90.924 c-6.179,27.366,13.241,49.434,40.607,49.434c48.552,0,81.214-62.676,81.214-135.945c0-56.497-37.959-97.986-106.814-97.986 c-77.683,0-126.234,58.262-126.234,122.703c0,22.069,6.179,37.959,16.772,50.317c4.414,5.297,5.297,7.945,3.531,14.124 c-0.883,4.414-4.414,15.89-5.297,20.303c-1.766,6.179-7.062,8.828-13.241,6.179c-36.193-15.007-52.083-53.848-52.083-97.986 c0-72.386,60.91-159.779,182.731-159.779c97.986,0,162.428,70.621,162.428,146.538c0,100.634-55.614,175.669-137.71,175.669 c-27.366,0-53.848-15.007-62.676-31.779c0,0-15.007,59.145-17.655,70.621c-5.297,19.421-15.89,39.724-25.6,54.731 c22.952,7.062,47.669,10.593,72.386,10.593c141.241,0,256-114.759,256-256S397.683,0,256.441,0"/></svg>
																			</a>
								</li>
																				</ul>
																														<ul class="pw-widget hidden-sm hidden-md hidden-lg">
															<li>
									<a
										href="https://www.facebook.com/sharer/sharer.php?u=https://www.trustedreviews.com/reviews/final-fantasy-8-remastered"
										target="_blank"
										 rel="noopener" 										class="share-button "
										data-url="https://www.trustedreviews.com/reviews/final-fantasy-8-remastered"
										name="Share this page on facebook"
									>
																					<svg xmlns="http://www.w3.org/2000/svg" width="13" height="25" viewBox="88.428 12.828 107.543 207.085"><path d="M158.232 219.912v-94.461h31.707l4.747-36.813h-36.454V65.134c0-10.658 2.96-17.922 18.245-17.922l19.494-.009V14.278c-3.373-.447-14.944-1.449-28.406-1.449-28.106 0-47.348 17.155-47.348 48.661v27.149H88.428v36.813h31.788v94.461l38.016-.001z" fill="#3c5a9a"/></svg>
																			</a>
								</li>
															<li>
									<a
										href="https://twitter.com/intent/tweet?url=https://www.trustedreviews.com/reviews/final-fantasy-8-remastered&text=Final Fantasy 8 Remastered Review"
										target="_blank"
										 rel="noopener" 										class="share-button "
										data-url="https://www.trustedreviews.com/reviews/final-fantasy-8-remastered"
										name="Share this page on twitter"
									>
																					<svg xmlns="http://www.w3.org/2000/svg" width="25" height="25" viewBox="0 0 512.002 512.002" style="enable-background:new 0 0 512.002 512.002;" xml:space="preserve"><path style="fill:#73A1FB;" d="M500.398,94.784c-8.043,3.567-16.313,6.578-24.763,9.023c10.004-11.314,17.631-24.626,22.287-39.193 c1.044-3.265-0.038-6.839-2.722-8.975c-2.681-2.137-6.405-2.393-9.356-0.644c-17.945,10.643-37.305,18.292-57.605,22.764 c-20.449-19.981-48.222-31.353-76.934-31.353c-60.606,0-109.913,49.306-109.913,109.91c0,4.773,0.302,9.52,0.9,14.201 c-75.206-6.603-145.124-43.568-193.136-102.463c-1.711-2.099-4.347-3.231-7.046-3.014c-2.7,0.211-5.127,1.734-6.491,4.075 c-9.738,16.709-14.886,35.82-14.886,55.265c0,26.484,9.455,51.611,26.158,71.246c-5.079-1.759-10.007-3.957-14.711-6.568 c-2.525-1.406-5.607-1.384-8.116,0.054c-2.51,1.439-4.084,4.084-4.151,6.976c-0.012,0.487-0.012,0.974-0.012,1.468 c0,39.531,21.276,75.122,53.805,94.52c-2.795-0.279-5.587-0.684-8.362-1.214c-2.861-0.547-5.802,0.456-7.731,2.638 c-1.932,2.18-2.572,5.219-1.681,7.994c12.04,37.591,43.039,65.24,80.514,73.67c-31.082,19.468-66.626,29.665-103.939,29.665 c-7.786,0-15.616-0.457-23.279-1.364c-3.807-0.453-7.447,1.795-8.744,5.416c-1.297,3.622,0.078,7.66,3.316,9.736 c47.935,30.735,103.361,46.98,160.284,46.98c111.903,0,181.907-52.769,220.926-97.037c48.657-55.199,76.562-128.261,76.562-200.451 c0-3.016-0.046-6.061-0.139-9.097c19.197-14.463,35.724-31.967,49.173-52.085c2.043-3.055,1.822-7.094-0.545-9.906 C507.7,94.204,503.76,93.294,500.398,94.784z"/></svg>
																			</a>
								</li>
															<li>
									<a
										href="http://pinterest.com/pin/create/button/?url=https://www.trustedreviews.com/reviews/final-fantasy-8-remastered&description=Final Fantasy 8 Remastered Review"
										target="_blank"
										 rel="noopener" 										class="share-button "
										data-url="https://www.trustedreviews.com/reviews/final-fantasy-8-remastered"
										name="Share this page on pinterest"
									>
																					<svg xmlns="http://www.w3.org/2000/svg" width="25" height="25" viewBox="0 0 512.883 512.883" style="enable-background:new 0 0 512.883 512.883;" xml:space="preserve"> <path style="fill:#CB1F24;" d="M256.441,0c-141.241,0-256,114.759-256,256c0,105.048,62.676,195.09,153.6,234.814 c-0.883-17.655,0-39.724,4.414-59.145c5.297-21.186,32.662-139.476,32.662-139.476s-7.945-16.772-7.945-40.607 c0-37.959,22.069-66.207,49.434-66.207c22.952,0,34.428,17.655,34.428,38.841c0,22.952-15.007,58.262-22.952,90.924 c-6.179,27.366,13.241,49.434,40.607,49.434c48.552,0,81.214-62.676,81.214-135.945c0-56.497-37.959-97.986-106.814-97.986 c-77.683,0-126.234,58.262-126.234,122.703c0,22.069,6.179,37.959,16.772,50.317c4.414,5.297,5.297,7.945,3.531,14.124 c-0.883,4.414-4.414,15.89-5.297,20.303c-1.766,6.179-7.062,8.828-13.241,6.179c-36.193-15.007-52.083-53.848-52.083-97.986 c0-72.386,60.91-159.779,182.731-159.779c97.986,0,162.428,70.621,162.428,146.538c0,100.634-55.614,175.669-137.71,175.669 c-27.366,0-53.848-15.007-62.676-31.779c0,0-15.007,59.145-17.655,70.621c-5.297,19.421-15.89,39.724-25.6,54.731 c22.952,7.062,47.669,10.593,72.386,10.593c141.241,0,256-114.759,256-256S397.683,0,256.441,0"/></svg>
																			</a>
								</li>
																				</ul>
					
				</div>

			
			
		</div>

	</header>

			
			<div class="post-main__inner">

								
	<div class="multimedia-gallery multimedia-gallery--small">
		<div class="post__award">
	
	
	</div>		<div class="multimedia-gallery__images ggnoads">
			<div class="multimedia-gallery__background"></div>

			<ul class="multimedia-gallery__list">
									<li class="multimedia-gallery__item multimedia-gallery__item--active image-crop image-crop--">
													<div id="attachment_3938406"
     class="featured-image"
     itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
>
	<figure class="image ">
		<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-01-920x518.jpg"
     data-id="3938406"
     data-sizes="auto"
     class="image-md lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="920"
	 height="518"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-01-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-01-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-01-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-01-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-01-920x518.jpg">
<meta itemprop="width" content="920">
<meta itemprop="height" content="518">	</figure>
	</div>
											</li>
									<li class="multimedia-gallery__item image-crop image-crop--">
													<div id="attachment_3936497"
     class="featured-image wp-caption"
     itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
>
	<figure class="image ">
		<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-920x518.jpg"
     data-id="3936497"
     data-sizes="auto"
     class="image-md lazyload blur-up"
     alt="Final Fantasy 8 Remastered"
     width="920"
	 height="518"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-1220x686.jpg 1220w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-1620x911.jpg 1620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-1920x1080.jpg 1920w,
	"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-920x518.jpg">
<meta itemprop="width" content="920">
<meta itemprop="height" content="518">	</figure>
			<figcaption class="wp-caption-text">
			FF8 Remastered's 4:3 aspect ratio is a little distracting, especially in Switch handheld mode
					</figcaption>
	</div>
											</li>
									<li class="multimedia-gallery__item image-crop image-crop--">
													<div id="attachment_3938409"
     class="featured-image"
     itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
>
	<figure class="image ">
		<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-03-920x518.jpg"
     data-id="3938409"
     data-sizes="auto"
     class="image-md lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="920"
	 height="518"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-03-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-03-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-03-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-03-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-03-920x518.jpg">
<meta itemprop="width" content="920">
<meta itemprop="height" content="518">	</figure>
	</div>
											</li>
									<li class="multimedia-gallery__item image-crop image-crop--">
													<div id="attachment_3938408"
     class="featured-image"
     itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
>
	<figure class="image ">
		<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-02-920x518.jpg"
     data-id="3938408"
     data-sizes="auto"
     class="image-md lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="920"
	 height="518"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-02-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-02-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-02-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-02-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-02-920x518.jpg">
<meta itemprop="width" content="920">
<meta itemprop="height" content="518">	</figure>
	</div>
											</li>
									<li class="multimedia-gallery__item image-crop image-crop--">
													<div id="attachment_3936499"
     class="featured-image wp-caption"
     itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
>
	<figure class="image ">
		<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-920x518.jpg"
     data-id="3936499"
     data-sizes="auto"
     class="image-md lazyload blur-up"
     alt="Final Fantasy 8 Remastered"
     width="920"
	 height="518"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-1220x686.jpg 1220w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-1620x911.jpg 1620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-1920x1080.jpg 1920w,
	"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-920x518.jpg">
<meta itemprop="width" content="920">
<meta itemprop="height" content="518">	</figure>
			<figcaption class="wp-caption-text">
			Triple Triad remains an absurdly addictive distraction in the world of FF8
					</figcaption>
	</div>
											</li>
									<li class="multimedia-gallery__item image-crop image-crop--">
													<div id="attachment_3938410"
     class="featured-image"
     itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
>
	<figure class="image ">
		<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-04-920x518.jpg"
     data-id="3938410"
     data-sizes="auto"
     class="image-md lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="920"
	 height="518"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-04-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-04-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-04-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-04-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-04-920x518.jpg">
<meta itemprop="width" content="920">
<meta itemprop="height" content="518">	</figure>
	</div>
											</li>
									<li class="multimedia-gallery__item image-crop image-crop--">
													<div id="attachment_3936501"
     class="featured-image"
     itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
>
	<figure class="image ">
		<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_c47df5f692b0783b177fb6fe9c0cf69ac13ca056-920x518.jpg"
     data-id="3936501"
     data-sizes="auto"
     class="image-md lazyload blur-up"
     alt="Final Fantasy 8 Remastered"
     width="920"
	 height="518"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_c47df5f692b0783b177fb6fe9c0cf69ac13ca056-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_c47df5f692b0783b177fb6fe9c0cf69ac13ca056-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_c47df5f692b0783b177fb6fe9c0cf69ac13ca056-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_c47df5f692b0783b177fb6fe9c0cf69ac13ca056-1220x686.jpg 1220w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_c47df5f692b0783b177fb6fe9c0cf69ac13ca056-1620x911.jpg 1620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_c47df5f692b0783b177fb6fe9c0cf69ac13ca056-1920x1080.jpg 1920w,
	"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_c47df5f692b0783b177fb6fe9c0cf69ac13ca056-920x518.jpg">
<meta itemprop="width" content="920">
<meta itemprop="height" content="518">	</figure>
	</div>
											</li>
									<li class="multimedia-gallery__item image-crop image-crop--">
													<div id="attachment_3938407"
     class="featured-image"
     itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
>
	<figure class="image ">
		<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-12-920x518.jpg"
     data-id="3938407"
     data-sizes="auto"
     class="image-md lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="920"
	 height="518"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-12-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-12-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-12-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-12-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-12-920x518.jpg">
<meta itemprop="width" content="920">
<meta itemprop="height" content="518">	</figure>
	</div>
											</li>
									<li class="multimedia-gallery__item image-crop image-crop--">
													<div id="attachment_3938401"
     class="featured-image"
     itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
>
	<figure class="image ">
		<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-07-920x518.jpg"
     data-id="3938401"
     data-sizes="auto"
     class="image-md lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="920"
	 height="518"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-07-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-07-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-07-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-07-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-07-920x518.jpg">
<meta itemprop="width" content="920">
<meta itemprop="height" content="518">	</figure>
	</div>
											</li>
									<li class="multimedia-gallery__item image-crop image-crop--">
													<div id="attachment_3938404"
     class="featured-image"
     itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
>
	<figure class="image ">
		<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-06-920x518.jpg"
     data-id="3938404"
     data-sizes="auto"
     class="image-md lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="920"
	 height="518"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-06-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-06-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-06-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-06-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-06-920x518.jpg">
<meta itemprop="width" content="920">
<meta itemprop="height" content="518">	</figure>
	</div>
											</li>
									<li class="multimedia-gallery__item image-crop image-crop--">
													<div id="attachment_3938402"
     class="featured-image"
     itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
>
	<figure class="image ">
		<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-10-920x518.jpg"
     data-id="3938402"
     data-sizes="auto"
     class="image-md lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="920"
	 height="518"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-10-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-10-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-10-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-10-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-10-920x518.jpg">
<meta itemprop="width" content="920">
<meta itemprop="height" content="518">	</figure>
	</div>
											</li>
									<li class="multimedia-gallery__item image-crop image-crop--">
													<div id="attachment_3936500"
     class="featured-image"
     itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
>
	<figure class="image ">
		<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-920x518.jpg"
     data-id="3936500"
     data-sizes="auto"
     class="image-md lazyload blur-up"
     alt="Final Fantasy 8 Remastered"
     width="920"
	 height="518"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-1220x686.jpg 1220w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-1620x911.jpg 1620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-1920x1080.jpg 1920w,
	"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-920x518.jpg">
<meta itemprop="width" content="920">
<meta itemprop="height" content="518">	</figure>
	</div>
											</li>
									<li class="multimedia-gallery__item image-crop image-crop--">
													<div id="attachment_3938405"
     class="featured-image"
     itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
>
	<figure class="image ">
		<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-08-920x518.jpg"
     data-id="3938405"
     data-sizes="auto"
     class="image-md lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="920"
	 height="518"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-08-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-08-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-08-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-08-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-08-920x518.jpg">
<meta itemprop="width" content="920">
<meta itemprop="height" content="518">	</figure>
	</div>
											</li>
									<li class="multimedia-gallery__item image-crop image-crop--">
													<div id="attachment_3938412"
     class="featured-image"
     itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
>
	<figure class="image ">
		<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-09-920x518.jpg"
     data-id="3938412"
     data-sizes="auto"
     class="image-md lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="920"
	 height="518"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-09-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-09-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-09-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-09-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-09-920x518.jpg">
<meta itemprop="width" content="920">
<meta itemprop="height" content="518">	</figure>
	</div>
											</li>
									<li class="multimedia-gallery__item image-crop image-crop--">
													<div id="attachment_3938411"
     class="featured-image"
     itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
>
	<figure class="image ">
		<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05-920x518.jpg"
     data-id="3938411"
     data-sizes="auto"
     class="image-md lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="920"
	 height="518"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05-920x518.jpg">
<meta itemprop="width" content="920">
<meta itemprop="height" content="518">	</figure>
	</div>
											</li>
							</ul>

			<div class="multimedia-gallery__count">
				<span>1</span> of 15
			</div>

			<div class="multimedia-gallery__button multimedia-gallery__button--left btn">
				<span class="icon-arrow-left"></span>
			</div>

			<div class="multimedia-gallery__button multimedia-gallery__button--right btn">
				<span class="icon-arrow-right"></span>
			</div>
		</div>

		<div class="multimedia-gallery__thumbnails">
			<ul>
									<li class="multimedia-gallery__thumbnail multimedia-gallery__thumbnail--active" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
													<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-01-150x150.jpg"
     data-id="3938406"
     data-sizes="auto"
     class="thumbnail lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="150"
	 height="150"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-01-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-01-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-01-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-01-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-01-150x150.jpg">
<meta itemprop="width" content="150">
<meta itemprop="height" content="150">											</li>
									<li class="multimedia-gallery__thumbnail" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
													<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-150x150.jpg"
     data-id="3936497"
     data-sizes="auto"
     class="thumbnail lazyload blur-up"
     alt="Final Fantasy 8 Remastered"
     width="150"
	 height="150"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-1220x686.jpg 1220w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-1620x911.jpg 1620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-1920x1080.jpg 1920w,
	"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-150x150.jpg">
<meta itemprop="width" content="150">
<meta itemprop="height" content="150">											</li>
									<li class="multimedia-gallery__thumbnail" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
													<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-03-150x150.jpg"
     data-id="3938409"
     data-sizes="auto"
     class="thumbnail lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="150"
	 height="150"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-03-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-03-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-03-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-03-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-03-150x150.jpg">
<meta itemprop="width" content="150">
<meta itemprop="height" content="150">											</li>
									<li class="multimedia-gallery__thumbnail" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
													<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-02-150x150.jpg"
     data-id="3938408"
     data-sizes="auto"
     class="thumbnail lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="150"
	 height="150"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-02-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-02-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-02-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-02-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-02-150x150.jpg">
<meta itemprop="width" content="150">
<meta itemprop="height" content="150">											</li>
									<li class="multimedia-gallery__thumbnail" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
													<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-150x150.jpg"
     data-id="3936499"
     data-sizes="auto"
     class="thumbnail lazyload blur-up"
     alt="Final Fantasy 8 Remastered"
     width="150"
	 height="150"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-1220x686.jpg 1220w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-1620x911.jpg 1620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-1920x1080.jpg 1920w,
	"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-150x150.jpg">
<meta itemprop="width" content="150">
<meta itemprop="height" content="150">											</li>
									<li class="multimedia-gallery__thumbnail" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
													<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-04-150x150.jpg"
     data-id="3938410"
     data-sizes="auto"
     class="thumbnail lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="150"
	 height="150"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-04-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-04-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-04-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-04-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-04-150x150.jpg">
<meta itemprop="width" content="150">
<meta itemprop="height" content="150">											</li>
									<li class="multimedia-gallery__thumbnail" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
													<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_c47df5f692b0783b177fb6fe9c0cf69ac13ca056-150x150.jpg"
     data-id="3936501"
     data-sizes="auto"
     class="thumbnail lazyload blur-up"
     alt="Final Fantasy 8 Remastered"
     width="150"
	 height="150"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_c47df5f692b0783b177fb6fe9c0cf69ac13ca056-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_c47df5f692b0783b177fb6fe9c0cf69ac13ca056-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_c47df5f692b0783b177fb6fe9c0cf69ac13ca056-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_c47df5f692b0783b177fb6fe9c0cf69ac13ca056-1220x686.jpg 1220w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_c47df5f692b0783b177fb6fe9c0cf69ac13ca056-1620x911.jpg 1620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_c47df5f692b0783b177fb6fe9c0cf69ac13ca056-1920x1080.jpg 1920w,
	"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_c47df5f692b0783b177fb6fe9c0cf69ac13ca056-150x150.jpg">
<meta itemprop="width" content="150">
<meta itemprop="height" content="150">											</li>
									<li class="multimedia-gallery__thumbnail" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
													<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-12-150x150.jpg"
     data-id="3938407"
     data-sizes="auto"
     class="thumbnail lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="150"
	 height="150"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-12-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-12-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-12-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-12-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-12-150x150.jpg">
<meta itemprop="width" content="150">
<meta itemprop="height" content="150">											</li>
									<li class="multimedia-gallery__thumbnail" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
													<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-07-150x150.jpg"
     data-id="3938401"
     data-sizes="auto"
     class="thumbnail lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="150"
	 height="150"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-07-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-07-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-07-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-07-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-07-150x150.jpg">
<meta itemprop="width" content="150">
<meta itemprop="height" content="150">											</li>
									<li class="multimedia-gallery__thumbnail" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
													<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-06-150x150.jpg"
     data-id="3938404"
     data-sizes="auto"
     class="thumbnail lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="150"
	 height="150"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-06-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-06-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-06-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-06-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-06-150x150.jpg">
<meta itemprop="width" content="150">
<meta itemprop="height" content="150">											</li>
									<li class="multimedia-gallery__thumbnail" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
													<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-10-150x150.jpg"
     data-id="3938402"
     data-sizes="auto"
     class="thumbnail lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="150"
	 height="150"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-10-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-10-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-10-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-10-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-10-150x150.jpg">
<meta itemprop="width" content="150">
<meta itemprop="height" content="150">											</li>
									<li class="multimedia-gallery__thumbnail" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
													<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-150x150.jpg"
     data-id="3936500"
     data-sizes="auto"
     class="thumbnail lazyload blur-up"
     alt="Final Fantasy 8 Remastered"
     width="150"
	 height="150"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-1220x686.jpg 1220w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-1620x911.jpg 1620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-1920x1080.jpg 1920w,
	"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-150x150.jpg">
<meta itemprop="width" content="150">
<meta itemprop="height" content="150">											</li>
									<li class="multimedia-gallery__thumbnail" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
													<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-08-150x150.jpg"
     data-id="3938405"
     data-sizes="auto"
     class="thumbnail lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="150"
	 height="150"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-08-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-08-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-08-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-08-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-08-150x150.jpg">
<meta itemprop="width" content="150">
<meta itemprop="height" content="150">											</li>
									<li class="multimedia-gallery__thumbnail" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
													<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-09-150x150.jpg"
     data-id="3938412"
     data-sizes="auto"
     class="thumbnail lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="150"
	 height="150"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-09-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-09-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-09-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-09-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-09-150x150.jpg">
<meta itemprop="width" content="150">
<meta itemprop="height" content="150">											</li>
									<li class="multimedia-gallery__thumbnail" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
													<img src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05-150x150.jpg"
     data-id="3938411"
     data-sizes="auto"
     class="thumbnail lazyload blur-up"
     alt="Final Fantasy 8 Remastered on Nintendo Switch"
     width="150"
	 height="150"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05-1220x686.jpg 1220w,
			"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05-150x150.jpg">
<meta itemprop="width" content="150">
<meta itemprop="height" content="150">											</li>
							</ul>
		</div>
	</div>
	
				
				
				<div class="slot-wrapper slot-wrapper--full">
					<div id="header-1" class="ipc-advert"></div>				</div>

				<div class="post-body">

					<div class="social-share social-share--sticky">

												
																																			<ul class="pw-widget hidden-xs">
																	<li>
										<a
											href="https://www.facebook.com/sharer/sharer.php?u=https://www.trustedreviews.com/reviews/final-fantasy-8-remastered"
											target="_blank"
											 rel="noopener" 											class="share-button "
											data-url="https://www.trustedreviews.com/reviews/final-fantasy-8-remastered"
											name="Share this page on facebook"
										>
																							<svg xmlns="http://www.w3.org/2000/svg" width="13" height="25" viewBox="88.428 12.828 107.543 207.085"><path d="M158.232 219.912v-94.461h31.707l4.747-36.813h-36.454V65.134c0-10.658 2.96-17.922 18.245-17.922l19.494-.009V14.278c-3.373-.447-14.944-1.449-28.406-1.449-28.106 0-47.348 17.155-47.348 48.661v27.149H88.428v36.813h31.788v94.461l38.016-.001z" fill="#3c5a9a"/></svg>
																					</a>
									</li>
																	<li>
										<a
											href="https://twitter.com/intent/tweet?url=https://www.trustedreviews.com/reviews/final-fantasy-8-remastered&text=Final Fantasy 8 Remastered Review"
											target="_blank"
											 rel="noopener" 											class="share-button "
											data-url="https://www.trustedreviews.com/reviews/final-fantasy-8-remastered"
											name="Share this page on twitter"
										>
																							<svg xmlns="http://www.w3.org/2000/svg" width="25" height="25" viewBox="0 0 512.002 512.002" style="enable-background:new 0 0 512.002 512.002;" xml:space="preserve"><path style="fill:#73A1FB;" d="M500.398,94.784c-8.043,3.567-16.313,6.578-24.763,9.023c10.004-11.314,17.631-24.626,22.287-39.193 c1.044-3.265-0.038-6.839-2.722-8.975c-2.681-2.137-6.405-2.393-9.356-0.644c-17.945,10.643-37.305,18.292-57.605,22.764 c-20.449-19.981-48.222-31.353-76.934-31.353c-60.606,0-109.913,49.306-109.913,109.91c0,4.773,0.302,9.52,0.9,14.201 c-75.206-6.603-145.124-43.568-193.136-102.463c-1.711-2.099-4.347-3.231-7.046-3.014c-2.7,0.211-5.127,1.734-6.491,4.075 c-9.738,16.709-14.886,35.82-14.886,55.265c0,26.484,9.455,51.611,26.158,71.246c-5.079-1.759-10.007-3.957-14.711-6.568 c-2.525-1.406-5.607-1.384-8.116,0.054c-2.51,1.439-4.084,4.084-4.151,6.976c-0.012,0.487-0.012,0.974-0.012,1.468 c0,39.531,21.276,75.122,53.805,94.52c-2.795-0.279-5.587-0.684-8.362-1.214c-2.861-0.547-5.802,0.456-7.731,2.638 c-1.932,2.18-2.572,5.219-1.681,7.994c12.04,37.591,43.039,65.24,80.514,73.67c-31.082,19.468-66.626,29.665-103.939,29.665 c-7.786,0-15.616-0.457-23.279-1.364c-3.807-0.453-7.447,1.795-8.744,5.416c-1.297,3.622,0.078,7.66,3.316,9.736 c47.935,30.735,103.361,46.98,160.284,46.98c111.903,0,181.907-52.769,220.926-97.037c48.657-55.199,76.562-128.261,76.562-200.451 c0-3.016-0.046-6.061-0.139-9.097c19.197-14.463,35.724-31.967,49.173-52.085c2.043-3.055,1.822-7.094-0.545-9.906 C507.7,94.204,503.76,93.294,500.398,94.784z"/></svg>
																					</a>
									</li>
																	<li>
										<a
											href="http://pinterest.com/pin/create/button/?url=https://www.trustedreviews.com/reviews/final-fantasy-8-remastered&description=Final Fantasy 8 Remastered Review"
											target="_blank"
											 rel="noopener" 											class="share-button "
											data-url="https://www.trustedreviews.com/reviews/final-fantasy-8-remastered"
											name="Share this page on pinterest"
										>
																							<svg xmlns="http://www.w3.org/2000/svg" width="25" height="25" viewBox="0 0 512.883 512.883" style="enable-background:new 0 0 512.883 512.883;" xml:space="preserve"> <path style="fill:#CB1F24;" d="M256.441,0c-141.241,0-256,114.759-256,256c0,105.048,62.676,195.09,153.6,234.814 c-0.883-17.655,0-39.724,4.414-59.145c5.297-21.186,32.662-139.476,32.662-139.476s-7.945-16.772-7.945-40.607 c0-37.959,22.069-66.207,49.434-66.207c22.952,0,34.428,17.655,34.428,38.841c0,22.952-15.007,58.262-22.952,90.924 c-6.179,27.366,13.241,49.434,40.607,49.434c48.552,0,81.214-62.676,81.214-135.945c0-56.497-37.959-97.986-106.814-97.986 c-77.683,0-126.234,58.262-126.234,122.703c0,22.069,6.179,37.959,16.772,50.317c4.414,5.297,5.297,7.945,3.531,14.124 c-0.883,4.414-4.414,15.89-5.297,20.303c-1.766,6.179-7.062,8.828-13.241,6.179c-36.193-15.007-52.083-53.848-52.083-97.986 c0-72.386,60.91-159.779,182.731-159.779c97.986,0,162.428,70.621,162.428,146.538c0,100.634-55.614,175.669-137.71,175.669 c-27.366,0-53.848-15.007-62.676-31.779c0,0-15.007,59.145-17.655,70.621c-5.297,19.421-15.89,39.724-25.6,54.731 c22.952,7.062,47.669,10.593,72.386,10.593c141.241,0,256-114.759,256-256S397.683,0,256.441,0"/></svg>
																					</a>
									</li>
																							</ul>
																																			<ul class="pw-widget hidden-sm hidden-md hidden-lg">
																	<li>
										<a
											href="https://www.facebook.com/sharer/sharer.php?u=https://www.trustedreviews.com/reviews/final-fantasy-8-remastered"
											target="_blank"
											 rel="noopener" 											class="share-button "
											data-url="https://www.trustedreviews.com/reviews/final-fantasy-8-remastered"
											name="Share this page on facebook"
										>
																							<svg xmlns="http://www.w3.org/2000/svg" width="13" height="25" viewBox="88.428 12.828 107.543 207.085"><path d="M158.232 219.912v-94.461h31.707l4.747-36.813h-36.454V65.134c0-10.658 2.96-17.922 18.245-17.922l19.494-.009V14.278c-3.373-.447-14.944-1.449-28.406-1.449-28.106 0-47.348 17.155-47.348 48.661v27.149H88.428v36.813h31.788v94.461l38.016-.001z" fill="#3c5a9a"/></svg>
																					</a>
									</li>
																	<li>
										<a
											href="https://twitter.com/intent/tweet?url=https://www.trustedreviews.com/reviews/final-fantasy-8-remastered&text=Final Fantasy 8 Remastered Review"
											target="_blank"
											 rel="noopener" 											class="share-button "
											data-url="https://www.trustedreviews.com/reviews/final-fantasy-8-remastered"
											name="Share this page on twitter"
										>
																							<svg xmlns="http://www.w3.org/2000/svg" width="25" height="25" viewBox="0 0 512.002 512.002" style="enable-background:new 0 0 512.002 512.002;" xml:space="preserve"><path style="fill:#73A1FB;" d="M500.398,94.784c-8.043,3.567-16.313,6.578-24.763,9.023c10.004-11.314,17.631-24.626,22.287-39.193 c1.044-3.265-0.038-6.839-2.722-8.975c-2.681-2.137-6.405-2.393-9.356-0.644c-17.945,10.643-37.305,18.292-57.605,22.764 c-20.449-19.981-48.222-31.353-76.934-31.353c-60.606,0-109.913,49.306-109.913,109.91c0,4.773,0.302,9.52,0.9,14.201 c-75.206-6.603-145.124-43.568-193.136-102.463c-1.711-2.099-4.347-3.231-7.046-3.014c-2.7,0.211-5.127,1.734-6.491,4.075 c-9.738,16.709-14.886,35.82-14.886,55.265c0,26.484,9.455,51.611,26.158,71.246c-5.079-1.759-10.007-3.957-14.711-6.568 c-2.525-1.406-5.607-1.384-8.116,0.054c-2.51,1.439-4.084,4.084-4.151,6.976c-0.012,0.487-0.012,0.974-0.012,1.468 c0,39.531,21.276,75.122,53.805,94.52c-2.795-0.279-5.587-0.684-8.362-1.214c-2.861-0.547-5.802,0.456-7.731,2.638 c-1.932,2.18-2.572,5.219-1.681,7.994c12.04,37.591,43.039,65.24,80.514,73.67c-31.082,19.468-66.626,29.665-103.939,29.665 c-7.786,0-15.616-0.457-23.279-1.364c-3.807-0.453-7.447,1.795-8.744,5.416c-1.297,3.622,0.078,7.66,3.316,9.736 c47.935,30.735,103.361,46.98,160.284,46.98c111.903,0,181.907-52.769,220.926-97.037c48.657-55.199,76.562-128.261,76.562-200.451 c0-3.016-0.046-6.061-0.139-9.097c19.197-14.463,35.724-31.967,49.173-52.085c2.043-3.055,1.822-7.094-0.545-9.906 C507.7,94.204,503.76,93.294,500.398,94.784z"/></svg>
																					</a>
									</li>
																	<li>
										<a
											href="http://pinterest.com/pin/create/button/?url=https://www.trustedreviews.com/reviews/final-fantasy-8-remastered&description=Final Fantasy 8 Remastered Review"
											target="_blank"
											 rel="noopener" 											class="share-button "
											data-url="https://www.trustedreviews.com/reviews/final-fantasy-8-remastered"
											name="Share this page on pinterest"
										>
																							<svg xmlns="http://www.w3.org/2000/svg" width="25" height="25" viewBox="0 0 512.883 512.883" style="enable-background:new 0 0 512.883 512.883;" xml:space="preserve"> <path style="fill:#CB1F24;" d="M256.441,0c-141.241,0-256,114.759-256,256c0,105.048,62.676,195.09,153.6,234.814 c-0.883-17.655,0-39.724,4.414-59.145c5.297-21.186,32.662-139.476,32.662-139.476s-7.945-16.772-7.945-40.607 c0-37.959,22.069-66.207,49.434-66.207c22.952,0,34.428,17.655,34.428,38.841c0,22.952-15.007,58.262-22.952,90.924 c-6.179,27.366,13.241,49.434,40.607,49.434c48.552,0,81.214-62.676,81.214-135.945c0-56.497-37.959-97.986-106.814-97.986 c-77.683,0-126.234,58.262-126.234,122.703c0,22.069,6.179,37.959,16.772,50.317c4.414,5.297,5.297,7.945,3.531,14.124 c-0.883,4.414-4.414,15.89-5.297,20.303c-1.766,6.179-7.062,8.828-13.241,6.179c-36.193-15.007-52.083-53.848-52.083-97.986 c0-72.386,60.91-159.779,182.731-159.779c97.986,0,162.428,70.621,162.428,146.538c0,100.634-55.614,175.669-137.71,175.669 c-27.366,0-53.848-15.007-62.676-31.779c0,0-15.007,59.145-17.655,70.621c-5.297,19.421-15.89,39.724-25.6,54.731 c22.952,7.062,47.669,10.593,72.386,10.593c141.241,0,256-114.759,256-256S397.683,0,256.441,0"/></svg>
																					</a>
									</li>
																							</ul>
						
					</div>

					<div class="articleBody" itemprop=" ">
																									
						
						
							
			<div class="review-points">
								<h2>Verdict</h2>
				<p>Final Fantasy 8 Remastered is a patchy but ultimately solid port of a classic JRPG. If you haven't played it before, you’ve no excuse not to become acquainted with the world of FF8, even if the game is at times hard to look at on a 16:9 display.</p>
	
			<div class="review-points__pros">
			<h2>Pros</h2>
			<ul>
									<li><span class="icon icon-yes"></span> <span class="point">New sprites look sharp and fresh</span></li>
									<li><span class="icon icon-yes"></span> <span class="point">Speed boost lets you get your grind on</span></li>
									<li><span class="icon icon-yes"></span> <span class="point">Triple Triad is still great</span></li>
							</ul>
		</div>
	
			<div class="review-points__cons">
			<h2>Cons</h2>
			<ul>
									<li><span class="icon icon-no"></span> <span class="point">Upscaled pre-rendered environments show their age</span></li>
									<li><span class="icon icon-no"></span> <span class="point">The world map looks tired</span></li>
									<li><span class="icon icon-no"></span> <span class="point">Letterboxed 4:3 action</span></li>
							</ul>
		</div>
	</div>
	
	<div class="eagle-widget" data-uid="__fixed_top" data-limit="3"><div class="eagle-widget-content"></div></div>

	
	<div class="review-features">
		<h2>Key Specifications</h2>
		<ul>
												<li class="review-features__price">Review Price: £15.99</li>
														<li>Genre: JRPG</li>
							<li>Developer: Square Enix, Dotemu, Access Games</li>
							<li>Platforms: PS4, Xbox One, PC, Nintendo Switch (version tested)</li>
					</ul>
	</div>

	<p><span style="font-weight: 400">I’m reviewing the Nintendo Switch version – but, technically, there’s little difference between various versions of Final Fantasy 8 Remastered between platforms. Only the PC version throws in a few extra cheats, which will see you able to max out character stats and money. PC gamers need more help, I guess. </span></p>
<p><span style="font-weight: 400">New changes that come to the table on all platforms include fresh character and summon sprites, as well as improved animations. Key additions include a 3x speed boost, which sees you able to blitz through the many random encounters, and the option to turn them off entirely once you’re done with grinding. </span></p>
<p><span style="font-weight: 400">Aside from these tweaks, Final Fantasy 8 Remastered is the classic you fell in love with all those years ago. The same great Nobuo Uematsu soundtrack plonks and trills away, the Junction system offers plenty of party customisation, and the Triple Triad in-game card-trading mechanism is still plenty of fun (</span><i><span style="font-weight: 400">why</span></i><span style="font-weight: 400"> hasn’t Square Enix made an official mobile version of this?!). </span></p>
<p><span style="font-weight: 400">The story – concerning memory loss, estranged parents, vague and unrequited love triangles, and, naturally, the fate of the universe – is the same as it ever was, and the script has aged well. </span></p>
<p><strong>Related: <a href="https://www.trustedreviews.com/best/best-rpg-3523043" target="_blank" rel="noopener">Best RPGs</a> </strong></p>
<div id="attachment_3936499" style="width: 1034px" class="wp-caption alignnone"><img class="lazyload blur-up size-large wp-image-3936499" src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png" data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-1024x576.jpg" alt="Final Fantasy 8 Remastered" width="1024" height="576" data-sizes="auto" data-srcset="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-1024x576.jpg 1024w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-300x169.jpg 300w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-768x432.jpg 768w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-320x180.jpg 320w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-620x349.jpg 620w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-920x518.jpg 920w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_0c78c71085955833e2509ee729b0ba3f64e7cf01-1220x686.jpg 1220w" sizes="(max-width: 1024px) 100vw, 1024px" /><p class="wp-caption-text">Triple Triad remains an addictive distraction in the world of FF8</p></div>
<p><span style="font-weight: 400">For the most part, the changes are very welcome. The main character sprites look razor-sharp. Squall, in all his angsty glory, looks particularly good, to the point where he resembles an actual human person. In the original game, Squall’s floppy emo fringe was often indistinguishable from his facial scar, making him look more ridiculous than intended. Likewise, Zell’s tattoo now actually looks like a tattoo, as opposed to a low-resolution ampersand.   </span></p>
<p><span style="font-weight: 400"><span class="c-message__body" dir="auto">I appreciate that some people are upset about some of the character redesigns, specifically those of Rinoa and Siren, who are now rendered a little more modestly than they were in the original edition.</span> Without wanting to provoke further outrage, I’d kindly suggest that anyone likely to be offended by such sacrilege temporarily step away from the internet and think on their priorities and general worldview. </span></p>
<div id="attachment_3938411" style="width: 1034px" class="wp-caption alignnone"><img class="lazyload blur-up wp-image-3938411 size-large" src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png" data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05-1024x576.jpg" alt="Final Fantasy 8 Remastered on Nintendo Switch" width="1024" height="576" data-sizes="auto" data-srcset="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05-1024x576.jpg 1024w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05-300x169.jpg 300w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05-768x432.jpg 768w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05-320x180.jpg 320w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05-620x349.jpg 620w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05-920x518.jpg 920w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05-1220x686.jpg 1220w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/FF8-Remastered-review-05.jpg 1280w" sizes="(max-width: 1024px) 100vw, 1024px" /><p class="wp-caption-text">&#8216;Junctioning&#8217; a Guardian Force character lets you enhance party member&#8217;s baseline stats, and use certain special commands.</p></div>
<p><span style="font-weight: 400">The most valuable change to Final Fantasy 8 Remastered is the 3x speed boost function. It took me a while to fall into familiar combat patterns, but once I was good to go, the benefits this feature brings are obvious. Like a lot of JRPGs, if you put the hours in and grind up  your party members early on, later stages of the game become far easier, freeing you up to become engrossed in the narrative. </span></p>
<p><span style="font-weight: 400">Where Final Fantasy 8 Remastered falls down is where Square Enix and co-developers Dotemu and Access Games haven’t enhanced the source material (or perhaps haven’t been able to). Sprites have been given some welcome spit and polish, but the environments they inhabit have not. The original PS1 pre-rendered backgrounds have instead been upscaled to fit more modern displays. At times, this is </span><i><span style="font-weight: 400">painfully </span></i><span style="font-weight: 400">obvious. </span></p>
<p><strong>Related: <a href="https://www.trustedreviews.com/news/gaming/final-fantasy-7-remake-release-date-gameplay-2993127" target="_blank" rel="noopener">Final Fantasy 7 Remake</a></strong></p>
<div id="attachment_3936500" style="width: 1034px" class="wp-caption alignnone"><img class="lazyload blur-up wp-image-3936500 size-large" src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png" data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-1024x576.jpg" alt="Final Fantasy 8 Remastered" width="1024" height="576" data-sizes="auto" data-srcset="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-1024x576.jpg 1024w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-300x169.jpg 300w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-768x432.jpg 768w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-320x180.jpg 320w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-620x349.jpg 620w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-920x518.jpg 920w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_9d377d72e20ae1900024287ac7b253f781a12bfc-1220x686.jpg 1220w" sizes="(max-width: 1024px) 100vw, 1024px" /><p class="wp-caption-text">The characters and story have aged like a fine Californian wine, standing up among the best in the franchise<strong style="font-size: 16px"> </strong></p></div>
<p><span style="font-weight: 400">While in the original, Balamb Garden convincingly felt like a vertiginous, multi-storey facility, here the illusion doesn’t work. It’s clear that you’re pushing three-dimensional sprites around a series of two-dimensional images. Likewise, when you venture out into the open-world for the first time, and run around that rotating 3D grid, it’s a bit of a shock – and not in a way that’s entirely good. </span></p>
<p><span style="font-weight: 400">Furthermore, environments built for 4:3 displays don&#8217;t translate well to the 16:9 world. This isn&#8217;t so bad when you’re playing docked on your Switch, but slip the Joy-Cons back on the console and play Final Fantasy 8 Remastered in handheld mode, and that big ugly letterbox just leaps out at you. </span></p>
<p><span style="font-weight: 400">Granted, if the teams had endeavoured to recreate each and every background to better fit modern displays, Final Fantasy 8 Remastered would have taken far longer to produce – and would inevitably have commanded more than the £15.99 you&#8217;re currently being asked to part with. </span></p>
<p><span style="font-weight: 400">For the money, what you do get is a faithful port of a much-loved classic, one that largely stands the test of time. In lieu of Square Enix deciding to give the eighth Final Fantasy instalment the full Remake treatment (unlikely), I’ll take what I can get, kupo.  </span></p>
<p><strong>Related: <a href="https://www.trustedreviews.com/news/cyberpunk-2077-release-date-2948412" target="_blank" rel="noopener">Cyberpunk 2077</a></strong></p>
<div id="attachment_3936497" style="width: 1034px" class="wp-caption alignnone"><img class="lazyload blur-up size-large wp-image-3936497" src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png" data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-1024x576.jpg" alt="Final Fantasy 8 Remastered" width="1024" height="576" data-sizes="auto" data-srcset="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-1024x576.jpg 1024w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-300x169.jpg 300w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-768x432.jpg 768w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-320x180.jpg 320w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-620x349.jpg 620w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-920x518.jpg 920w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/09/ss_73aa26fe1e5267b3cad5e322dbaffdc9dac29acd-1220x686.jpg 1220w" sizes="(max-width: 1024px) 100vw, 1024px" /><p class="wp-caption-text">FF8 Remastered&#8217;s 4:3 aspect ratio is a little distracting, especially in the Switch&#8217;s handheld mode</p></div>
<p><span style="font-weight: 400">While I’m thinking wishfully, I guess this means that as Squall has now appeared on a Nintendo console, we’ll get to play as him again when Super Smash Bros: Turbo Mega Ultimate &#8220;This Is The Last One Now Guys, We Promise&#8221; gets released in 2028, right?</span></p>
<p><strong>Related: <a href="https://www.trustedreviews.com/reviews/super-smash-bros-ultimate">Super Smash Bros Ultimate review</a></strong></p>
<h2>Verdict</h2>
<p><span style="font-weight: 400">Final Fantasy 8 Remastered sees an old Moogle learning some new tricks. If you can look beyond the obvious imperfections, then the combat and party management systems, plus the gracefully unfolding – if at times ridiculous – story and world building, which are as strong now as they were 20 years ago, will reward patient players.</span></p>
<p><span style="font-weight: 400">If you’re looking for something to burn through while waiting for <a href="https://www.trustedreviews.com/news/final-fantasy-7-remake-release-date-gameplay-2993127">Final Fantasy 7 Remake</a>, this remaster will sate your twitching nostalgia glands.</span></p>


	
			<div class="review-score">
								<div class="review-score__overall">
					<h2 class="score-title">Trusted Score </h2>
		
		
		
		
					<div class="score-stars score-stars--large"
								>
												<span
						class="star icon-star-full "
						data-rating="20"
					></span>
																								<span
						class="star icon-star-full "
						data-rating="40"
					></span>
																								<span
						class="star icon-star-full "
						data-rating="60"
					></span>
																								<span
						class="star icon-star-full "
						data-rating="80"
					></span>
																																<span
						class="star icon-star-empty "
						data-rating="100"
					></span>
									
			</div>

		</div>
				<br>
								</div>
	
				
						<div class="post-author-card">

	    <div class="post-author-card-image author-image--mobile">
        <img
            alt="Thomas Newton"
            src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2018/09/Thomas-Newton-TR-bio-pic-150x150.jpeg"
            class="post-author--img"
            height="145"
            width="145">
    </div>
	
	<div class="post-author-card-details">
		<div class="post-author-card-top">
							<div class="post-author-card-name">
					<span itemprop="author" itemscope itemtype="http://schema.org/Person">
						<a class="url fn n" href="https://www.trustedreviews.com/author/thomasnewton" name="A post from Thomas Newton">
							<span class="author vcard" itemprop="name">Thomas Newton</span>
						</a>
					</span>
				</div>
				<ul class="post-author-card-links author-links--desktop">
                <li>
            <a rel="me noopener" href="https://twitter.com/Thomas_Newton" target="_blank" class="icon-social-twitter" name="Visit the authors Twitter">
                <span class="visuallyhidden">Contact via Twitter</span>
            </a>
        </li>
                </ul>					</div>
		
					<div class="post-author-card-job-title">
				<small id="author-job-title" itemprop="jobtitle" class="role">Computing Editor</small>
			</div>
		
		<div class="post-author-card-lower">
							<div class="post-author-card-description" itemprop="description">
											Thomas Newton has reported on UK consumer technology and telecoms for over ten years and has joined the Trusted Reviews team as Computing Editor.
Previously writing for price comparison site Recombu.c&hellip;
									</div>
			
			    <div class="post-author-card-image author-image--desktop">
        <img
            alt="Thomas Newton"
            src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2018/09/Thomas-Newton-TR-bio-pic-150x150.jpeg"
            class="post-author--img"
            height="145"
            width="145">
    </div>

		</div>

		<ul class="post-author-card-links author-links--mobile">
                <li>
            <a rel="me noopener" href="https://twitter.com/Thomas_Newton" target="_blank" class="icon-social-twitter" name="Visit the authors Twitter">
                <span class="visuallyhidden">Contact via Twitter</span>
            </a>
        </li>
                </ul>
	</div>
</div>			
	<div class="textwidget custom-html-widget"><p>Unlike other sites, we thoroughly test every product we review. We use industry standard tests in order to compare features properly. We’ll always tell you what we find. We never, ever accept money to review a product.
	Tell us what you think - send your emails to <a href="mailto:editor@trustedreviews.com">the Editor.</a></p></div></li>
<div class="eagle-widget" data-uid="__fixed_bottom" data-limit="8"><div class="eagle-widget-content"></div></div>


					</div>

						<div class="multi-pagination">
		</div>
					
											<div id="taboola-below-article-thumbnails"></div>									</div>
			</div>

			
		</div>
	</article>
			
	</div>

			<div class="parallax-wrapper parallax-wrapper--footer sticky-anchor"></div>

<footer id="footer" role="contentinfo" class="footer sticky-anchor">
	<div class="footer__row">
		<nav class="footer__col footer__col--content">
			<ul id="menu-3" class="footer-menu footer-menu--plain">
			<li id="menu-item-3927554" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3927554">
			<a href="/archive"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Content archive
				</span>
			</a>
		</li>
			<li id="menu-item-3614131" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3614131">
			<a href="/info/browse-reviews-3614164"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Find a review
				</span>
			</a>
		</li>
			<li id="menu-item-2651360" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2651360">
			<a href="/info/about-trusted-reviews-3550741"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					About TrustedReviews
				</span>
			</a>
		</li>
			<li id="menu-item-3552607" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3552607">
			<a href="/info/who-we-are-3551613"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Contact our editorial team
				</span>
			</a>
		</li>
			<li id="menu-item-3580003" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3580003">
			<a href="https://www.trustedreviews.com/info/trusted-reviews-ethics-policy-3521647"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Why we are different
				</span>
			</a>
		</li>
			<li id="menu-item-3550819" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3550819">
			<a href="https://www.ti-media.com/terms-and-conditions/#_Toc513817991"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Labelling of commercial content
				</span>
			</a>
		</li>
			<li id="menu-item-3550821" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3550821">
			<a href="https://www.ipso.co.uk/editors-code-of-practice/"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					IPSO Editors' Code of Practice
				</span>
			</a>
		</li>
			<li id="menu-item-2651363" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2651363">
			<a href="http://www.timeincuk.com/privacy/"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Privacy & cookie policy
				</span>
			</a>
		</li>
			<li id="menu-item-2651362" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2651362">
			<a href="http://www.timeincuk.com/terms-and-conditions/"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Terms & Conditions
				</span>
			</a>
		</li>
			<li id="menu-item-3550818" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3550818">
			<a href="https://www.ti-media.com/terms-and-conditions/#_Toc513817985"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Third party advertising policy
				</span>
			</a>
		</li>
			<li id="menu-item-3249531" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3249531">
			<a href="https://www.trustedreviews.com/rss-feeds"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Follow Trusted Reviews via RSS
				</span>
			</a>
		</li>
			<li id="menu-item-3550823" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3550823">
			<a href="https://comps.trustedreviews.com/?_ga=2.81825043.400893545.1535971409-812703703.1535551482"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Competitions
				</span>
			</a>
		</li>
			<li id="menu-item-2651361" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2651361">
			<a href="http://www.timeincuk.com/advertise/"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Advertise with us
				</span>
			</a>
		</li>
			<li id="menu-item-3525646" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3525646">
			<a href="#"  title="privacy-settings"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Privacy Settings
				</span>
			</a>
		</li>
			<li id="menu-item-3716366" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3716366">
			<a href="https://www.trustedreviews.com/info/trusted-reviews-ethics-policy-3521647#how-we-make-money"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					> We may get a commission when you buy via a link <
				</span>
			</a>
		</li>
	</ul>		</nav>
		<nav class="footer__col footer__col--sidebar">
			<div class="ad-logos">
	<a href="https://www.iabuk.com/goldstandard" class="footer__iab" target="_blank" rel="noopener" name="IAB Gold Standard">
		<img 
			src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png" 
			data-src="/wp-content/themes/simba-theme/assets/images/iab_logo.png" 
			class="lazyload blur-up" 
			alt="IAB Gold Standard" 
			width="100%" />
	</a>
	<a href="https://jicwebs.org/standards/brand-safety/" class="footer__jic" target="_blank" rel="noopener" name="JIC WEBS Brand Safety">
		<img 
			src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png" 
			data-src="/wp-content/themes/simba-theme/assets/images/jic_webs_logo.jpg" 
			class="lazyload blur-up" 
			alt="JIC WEBS Brand Safety" 
			width="100%" />
	</a>
</div>
			
		</nav>

		<div class="footer-legal">
			<a itemprop="url" href="" title="" name="">
			<img 
				itemprop="logo" 
				src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png" 
				data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2018/10/tr-logo-large-1.png" 
				class="lazyload blur-up footer-logo" 
				alt="" 
				data-pin-nopin="true">
		</a>
		<sub>&copy; Copyright TI Media Limited. 161 Marsh Wall, London, E14 9SJ. All rights reserved.</sub>
	<a href="https://www.ipso.co.uk/what-we-do/" class="footer__ipso" target="_blank" rel="noopener" name="Visit the IPSO website">
		<img 
			src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png" 
			data-src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/ipso-dark.png" 
			class="lazyload blur-up" 
			alt="IPSO Regulated" 
			width="100%" />
	</a>
</div>
		<ul id="menu-8" class="footer-menu footer-menu--icons">
			<li id="menu-item-2651357" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2651357">
			<a href="https://www.facebook.com/pages/TrustedReviews/38275114220?ref=ts"   target="_blank" rel="noopener" class="menu-icon-item icon-social-facebook" name="Visit our facebook page">
				<span class="menu-icon-item icon-facebook">
					Facebook
				</span>
			</a>
		</li>
			<li id="menu-item-2651356" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2651356">
			<a href="https://twitter.com/trustedreviews"   target="_blank" rel="noopener" class="menu-icon-item icon-social-twitter" name="Visit our twitter page">
				<span class="menu-icon-item icon-twitter">
					Twitter
				</span>
			</a>
		</li>
			<li id="menu-item-2651358" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2651358">
			<a href="https://www.youtube.com/user/TrustedReviews"   target="_blank" rel="noopener" class="menu-icon-item icon-social-youtube" name="Visit our youtube page">
				<span class="menu-icon-item icon-youtube">
					YouTube
				</span>
			</a>
		</li>
			<li id="menu-item-3249533" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3249533">
			<a href="https://www.trustedreviews.com/rss-feeds"   target="_blank" rel="noopener" class="menu-icon-item icon-social-rss" name="Visit our rss page">
				<span class="menu-icon-item icon-rss">
					Follow Trusted Reviews via RSS
				</span>
			</a>
		</li>
	</ul>	</div>
</footer>
				<script type="text/javascript">
			(function() {
				/* Include required screen size functions right here */
				var getDisplayWidth=function(){var e=0;if(typeof window.innerWidth!="undefined"){e=window.innerWidth}else if(typeof document.documentElement!="undefined"&&typeof document.documentElement.clientWidth!="undefined"&&document.documentElement.clientWidth!=0){e=document.documentElement.clientWidth}else{e=document.getElementsByTagName("body")[0].clientWidth}return Number(e)};
				var getWindowSize = getDisplayWidth();
				window.ipcTags = window.ipcTags || {};
				/* Pageskin targeting stuff */
				if(getWindowSize >= 1350) {
					window.ipcTags['pageskin'] = 'yes';
				} else {
					window.ipcTags['pageskin'] = 'no';
				}

				
				if(getWindowSize >= 690) {
					window.ipcTags.platform = 'desktop';
				} else {
					window.ipcTags.platform = 'mobile';
				}

				
				window.ipcTags['dfp_config']['required_tags'].push('pageskin');
			})();
		</script>
		<script type='text/javascript'>
			(function(d,w){
				var s = d.createElement('script');
				w.lazySizesConfig = {'expFactor':'1'};
				s.src = 'https://www.trustedreviews.com/wp-content/plugins/keystone-images/assets/js/sizes.js?ver=0.0.1';
				d.body.appendChild(s);
			})(document,window);
		</script><script type='text/javascript' src='https://widget.eagleapi.io/js/loader.js?ver=2.25.26'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var keystoneJWPlayerConfig = {"viewplay":"desktop","viewplay_sticky_tabswitch":"0","sticky":"1","sticky_position":"right","mute":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.trustedreviews.com/wp-content/plugins/keystone-jwplayer/assets/js/main.js?ver=1.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var keystoneTaboolaConfig = {"lazyload":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.trustedreviews.com/wp-content/plugins/keystone-taboola/assets/js/taboola.js?ver=0.0.1'></script>
<script type='text/javascript' src='https://www.trustedreviews.com/wp-content/plugins/ipc-wordpress-digital-editions/public/assets/js/public.js?ver=2.2.2'></script>
<script type='text/javascript' src='https://www.trustedreviews.com/wp-content/themes/kiara-child-theme/assets/js/dist/review.min.js?ver=1568371196'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var keystone_newsletter = {"form_url":"https:\/\/ti-media.slgnt.eu\/renderers\/xml.ashx?ID=nLUnUG6KOH7JVtNut_mqr75CzNVCbo18YbNezlFBjHW9kR%2B98Rc6r4aNyu50jiA2PGhvykw1_OhnBfMVr5&NEWSLETTER_CODE=YTR-X&BRAND_CODE=YTR&SOURCE_CODE=RRL"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.trustedreviews.com/wp-content/plugins/keystone-newsletter/widget/js/widget.js?ver=1568371196'></script>
<script type='text/javascript' src='https://www.trustedreviews.com/wp-includes/js/wp-embed.min.js?ver=NC45Ljc'></script>
		<script>
			(function(){
				var n='scr'+'ipt',p=document.getElementsByTagName(n)[0],s=document.createElement(n);
				s.async=true;
				s.src='https://ksassets.timeincuk.net/tenant/1.0.61/tenant.min.js'
				p.parentNode.insertBefore(s,p);
			})();
			var googletag = googletag || {};
			googletag.cmd = googletag.cmd || [];
			window.tenantGetterQueue = window.tenantGetterQueue || [];
			window.tenantSetterQueue = window.tenantSetterQueue || [];
		</script>
		<div id="dfpad-overlay" class="ipc-advert"></div><div id="gumgum" class="ipc-advert"></div><div id="sovrn" class="ipc-advert"></div><div id="instream" class="ipc-advert"></div>
	
</div><!-- /wrapper -->


	
	
	<script>
    	let _ks_modules = [
    		'billboard',
            'navigation',
            'objectFit',
            'sharethroughListener',
            'select2',
        ];
	</script>


	<script>

		_ks_modules.push('featuredVideo');
		_ks_modules.push('kiara');
        
	</script>



	<script>

		_ks_modules.push('reviews');
		_ks_modules.push('featuredVideo');
		_ks_modules.push('multimediaGallery');
        
	</script>



	<script>
        for (let i = 0; i < _ks_modules.length; i++) {
            let module = window[_ks_modules[i]];
            if (typeof module !== 'undefined' && typeof module.init === 'function') {
                module.init();
            }
        }
	</script>


	

<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"aaccaa7fff","applicationID":"19797352,9562757,45889822","transactionName":"YgNVYEcAXhJYBUQNXFtJdldBCF8PFhVZClRZAw==","queueTime":0,"applicationTime":1482,"atts":"TkRCFg8aTU0bBxJeSEgb","errorBeacon":"bam.nr-data.net","agent":""}</script></body>

</html>
