	<!doctype html>
<html lang="en" prefix="og: http://ogp.me/ns#" class="no-js">
<head>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0" />

    <link rel="preconnect" href="https://ksassets.timeincuk.net" crossorigin>
<link rel="preconnect" href="https://js-sec.indexww.com" crossorigin>
<link rel="preconnect" href="https://display.apester.com" crossorigin>
<link rel="preconnect" href="https://player.apester.com" crossorigin>
<link rel="preconnect" href="https://renderer.apester.com" crossorigin>
<link rel="preconnect" href="https://static.apester.com" crossorigin>
<link rel="preconnect" href="https://content.jwplatform.com" crossorigin>
<link rel="preconnect" href="https://jwpltx.com" crossorigin>
<link rel="preconnect" href="https://ssl.p.jwpcdn.com" crossorigin>
<link rel="preconnect" href="https://cdn.taboola.com" crossorigin>
<link rel="preconnect" href="https://trc.taboola.com" crossorigin>


    <title>Dell G Series 2020: Everything you need to know about the G3, G5 and G7</title>
<link rel="preload" href="https://www.trustedreviews.com/wp-content/plugins/keystone-jwplayer/assets/css/main.css" as="style" onload="this.onload=null;this.rel='stylesheet'"><style>
@font-face {
	font-family: "keystone";
	font-weight: normal;
	font-style: normal;
	font-display: fallback;
	src:	url("//www.trustedreviews.com/wp-content/themes/simba-theme/assets/fonts/standard.woff2?v=1593005666") format("woff2"),
	url("//www.trustedreviews.com/wp-content/themes/simba-theme/assets/fonts/standard.woff?v=1593005666") format("woff");
}
.icon-spinner {
	background-image: url("//www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/spinner.gif");
}

</style><link rel="stylesheet" href="https://www.trustedreviews.com/wp-content/themes/kiara-child-theme/assets/css/sites/post.min.css?v=1593005666">		<script type="text/javascript">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</script>

<!-- This site is optimized with the Yoast SEO plugin v11.2.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Dell unveiled the new Dell G7 this week. The G7 rounds off the new Dell G Series, a range of three powerful gaming laptops all seeing updates in 2020"/>
<link rel="canonical" href="https://www.trustedreviews.com/news/dell-g-series-2020-4038655" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Dell G Series 2020: Everything you need to know about the G3, G5 and G7" />
<meta property="og:description" content="Dell unveiled the new Dell G7 this week. The G7 rounds off the new Dell G Series, a range of three powerful gaming laptops all seeing updates in 2020" />
<meta property="og:url" content="https://www.trustedreviews.com/news/dell-g-series-2020-4038655" />
<meta property="og:site_name" content="Trusted Reviews" />
<meta property="article:publisher" content="https://www.facebook.com/TrustedReviews/" />
<meta property="article:section" content="Tech News" />
<meta property="article:published_time" content="2020-06-25T14:51:05+01:00" />
<meta property="og:image" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/thumbnail_image001.png" />
<meta property="og:image:secure_url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/thumbnail_image001.png" />
<meta property="og:image:width" content="866" />
<meta property="og:image:height" content="466" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Dell unveiled the new Dell G7 this week. The G7 rounds off the new Dell G Series, a range of three powerful gaming laptops all seeing updates in 2020" />
<meta name="twitter:title" content="Dell G Series 2020: Everything you need to know about the G3, G5 and G7" />
<meta name="twitter:site" content="@trustedreviews" />
<meta name="twitter:image" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/thumbnail_image001.png" />
<meta name="twitter:creator" content="@trustedreviews" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.trustedreviews.com/#organization","name":"","url":"https://www.trustedreviews.com/","sameAs":["https://www.facebook.com/TrustedReviews/","https://www.instagram.com/trustedreviews/","https://www.youtube.com/user/TrustedReviews","https://www.pinterest.co.uk/trustedreviews/","https://twitter.com/trustedreviews"]},{"@type":"WebSite","@id":"https://www.trustedreviews.com/#website","url":"https://www.trustedreviews.com/","name":"Trusted Reviews","publisher":{"@id":"https://www.trustedreviews.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.trustedreviews.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://www.trustedreviews.com/news/dell-g-series-2020-4038655#webpage","url":"https://www.trustedreviews.com/news/dell-g-series-2020-4038655","inLanguage":"en-US","name":"Dell G Series 2020: Everything you need to know about the G3, G5 and G7","isPartOf":{"@id":"https://www.trustedreviews.com/#website"},"image":{"@type":"ImageObject","@id":"https://www.trustedreviews.com/news/dell-g-series-2020-4038655#primaryimage","url":"https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/thumbnail_image001.png","width":866,"height":466},"primaryImageOfPage":{"@id":"https://www.trustedreviews.com/news/dell-g-series-2020-4038655#primaryimage"},"datePublished":"2020-06-25T14:51:05+01:00","dateModified":"2020-06-25T14:51:05+01:00","description":"Dell unveiled the new Dell G7 this week. The G7 rounds off the new Dell G Series, a range of three powerful gaming laptops all seeing updates in 2020"},{"@type":"Article","@id":"https://www.trustedreviews.com/news/dell-g-series-2020-4038655#article","isPartOf":{"@id":"https://www.trustedreviews.com/news/dell-g-series-2020-4038655#webpage"},"author":{"@id":"https://www.trustedreviews.com/author/hannahdavies#author","name":"Hannah Davies"},"publisher":{"@id":"https://www.trustedreviews.com/#organization"},"headline":"Dell G Series 2020: Everything you need to know about the G3, G5 and G7","datePublished":"2020-06-25T14:51:05+01:00","dateModified":"2020-06-25T14:51:05+01:00","commentCount":0,"mainEntityOfPage":"https://www.trustedreviews.com/news/dell-g-series-2020-4038655#webpage","image":{"@id":"https://www.trustedreviews.com/news/dell-g-series-2020-4038655#primaryimage"},"articleSection":"Tech News"},{"@type":"Person","@id":"https://www.trustedreviews.com/author/hannahdavies#author","name":"Hannah Davies","image":{"@type":"ImageObject","@id":"https://www.trustedreviews.com/#personlogo","url":"https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/08/Image-from-iOS-1-150x150.jpg","caption":"Hannah Davies"},"description":"Hannah joined Trusted Reviews as a staff writer in 2019 after graduating with a degree in English from Royal Holloway, University of London. She\u2019s also worked and studied in the US, holding positions as a video production assistant and multimedia consultant at Washington College and has built websites and written content for Hometown Multimedia in Chestertown, Maryland.","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel="alternate" type="application/rss+xml" title="Trusted Reviews &raquo; Feed" href="https://www.trustedreviews.com/feed" />
<link rel='stylesheet' id='keystone-context-widget-css-css'  href='https://www.trustedreviews.com/wp-content/plugins/keystone-context-widget/assets/css/widget.css?ver=NS4zLjI' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://www.trustedreviews.com/wp-json/' />
<link rel="alternate" type="application/json+oembed" href="https://www.trustedreviews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.trustedreviews.com%2Fnews%2Fdell-g-series-2020-4038655" />
<link rel="alternate" type="text/xml+oembed" href="https://www.trustedreviews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.trustedreviews.com%2Fnews%2Fdell-g-series-2020-4038655&#038;format=xml" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"https:\/\/www.trustedreviews.com","logo":"https:\/\/ksassets.timeincuk.net\/wp\/uploads\/sites\/54\/2019\/08\/trusted-reviews-logo-white.png"}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@context":"http:\/\/schema.org","@type":"ListItem","position":1,"item":{"@id":"https:\/\/www.trustedreviews.com","name":"Home"}},{"@context":"http:\/\/schema.org","@type":"ListItem","position":2,"item":{"@id":"https:\/\/www.trustedreviews.com\/category\/news","name":"Tech News"}}]}</script>
<script type='application/ld+json'>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</script>
<meta property="fb:pages" content="38275114220" />		<script type="text/javascript" charset="utf-8">
		(function(a,b,c,d){
		    var protocol = "https://";
		    a="assets.ti-media.net/js/e1512726446_2a23693/min/gtm/utils-min.js";
		    b=document;c='script';d=b.createElement(c);d.src=protocol+a;d.async=true;d.type='text/java'+c;
		    a=b.getElementsByTagName(c)[0];a.parentNode.insertBefore(d,a);
		 })();
		</script>
	      <!-- Google Tag Manager -->
      <script>(function ( w, d, s, l, i ) {
          w[ l ] = w[ l ] || [];
          w[ l ].push({
            'gtm.start' :
              new Date().getTime(), event : 'gtm.js'
          });
          var f = d.getElementsByTagName(s)[ 0 ],
            j = d.createElement(s), dl = l != 'dataLayer' ? '&l=' + l : '';
          j.async = true;
          j.src =
            'https://www.googletagmanager.com/gtm.js?id=' + i + dl;
          f.parentNode.insertBefore(j, f);
        })(window, document, 'script', 'dataLayer','GTM-PHQNFGV');</script>
      <!-- End Google Tag Manager -->
            <meta name="onesignal" content="wordpress-plugin"/>
        <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script>    <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://www.trustedreviews.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '644e5c59-323a-453b-bfbe-430ae58ed2b8';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['disable'] = true;
oneSignal_options['path'] = "https://www.trustedreviews.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.32551e0e-3454-416e-9258-23f2fe99c3c8";
oneSignal_options['promptOptions'] = { };
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>

<link rel="amphtml" href="https://www.trustedreviews.com/news/dell-g-series-2020-4038655/amp"><link rel="amphtml" href="https://www.trustedreviews.com/news/dell-g-series-2020-4038655/amp"><link rel="icon" href="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/cropped-trusted-reviews-icon-3-32x32.png" sizes="32x32" />
<link rel="icon" href="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/cropped-trusted-reviews-icon-3-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/cropped-trusted-reviews-icon-3-180x180.png" />
<meta name="msapplication-TileImage" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/cropped-trusted-reviews-icon-3-270x270.png" />
		<style type="text/css" id="wp-custom-css">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</style>
		    			</head>

<body class="post-template-default single single-post postid-4038655 single-format-standard has-adverts y2020 m06 d25 h15 dell-g-series-2020 standard slim-header">

<div class="parallax-wrapper parallax-wrapper--header"></div>

      <!-- Google Tag Manager (noscript) -->
      <noscript>
        <iframe
            src="https://www.googletagmanager.com/ns.html?id=GTM-PHQNFGV"
            height="0" width="0"
            style="display:none;visibility:hidden"></iframe>
      </noscript>
      <!-- End Google Tag Manager (noscript) -->
      
<div id="wrapper" class="hfeed">

	    
			<header id="header" role="banner" class="header s-container has-single-tier">

	<div class="header__inner">

		
						
<div class="logo header-slot header-slot-">
    <a href="/" title="Trusted Reviews" name="Trusted Reviews">
    	<span class="hide">Trusted Reviews</span>
	<picture>
		<source media="(min-width: 728px)" srcset="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/08/trusted-reviews-logo-white.png" >
		<source media="(max-width: 727px)" srcset="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/08/trusted-reviews-logo-white.png" >
		<img src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/08/trusted-reviews-logo-white.png" alt="hero profile" aria-hidden="true" data-pin-nopin="true">
	</picture>
    </a>
</div>

		
	</div>

		<nav>
	<ul class="navigation hide-overflow-items" data-nav="closed">
					<li class="has-subnav">
				<a href="https://www.trustedreviews.com/" class= " "   title="Home Page"   name="HOME">
									HOME
								</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="/category/news"     name="News">News</a>
															</li>
													<li >
								<a href="/category/opinion"     name="Opinions">Opinions</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/category/how-to"     name="How to">How to</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/samsung-galaxy"     name="Samsung Galaxy">Samsung Galaxy</a>
															</li>
											</ul>
							</li>
					<li class="has-subnav">
				<a href="/reviews" class= " "    name="Reviews">
									Reviews
								</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="/reviews/tvs-audio"     name="TV and Audio Reviews">TV and Audio Reviews</a>
															</li>
													<li >
								<a href="/reviews/digital-cameras"     name="Camera Reviews">Camera Reviews</a>
															</li>
													<li >
								<a href="/reviews/computing"     name="Computing Reviews">Computing Reviews</a>
															</li>
													<li >
								<a href="/reviews/mobile"     name="Mobile Reviews">Mobile Reviews</a>
															</li>
													<li >
								<a href="/reviews/home-appliances"     name="Home Appliance Reviews">Home Appliance Reviews</a>
															</li>
													<li >
								<a href="/reviews/gaming"     name="Gaming Reviews">Gaming Reviews</a>
															</li>
											</ul>
							</li>
					<li >
				<a href="/category/best" class= " "    name="Best Lists">
									Best Lists
								</a>
							</li>
					<li >
				<a href="https://www.trustedreviews.com/mobile" class= " "    name="Phones">
									Phones
								</a>
							</li>
					<li >
				<a href="https://www.trustedreviews.com/computing" class= " "    name="Computing">
									Computing
								</a>
							</li>
					<li >
				<a href="https://www.trustedreviews.com/laptop" class= " "    name="Laptops">
									Laptops
								</a>
							</li>
					<li >
				<a href="https://www.trustedreviews.com/home-appliances" class= " "    name="Home Tech">
									Home Tech
								</a>
							</li>
					<li >
				<a href="https://www.trustedreviews.com/televisions" class= " "    name="TV">
									TV
								</a>
							</li>
					<li >
				<a href="https://www.trustedreviews.com/audio" class= " "    name="Audio">
									Audio
								</a>
							</li>
					<li >
				<a href="https://www.trustedreviews.com/gaming" class= " "    name="Games">
									Games
								</a>
							</li>
					<li >
				<a href="/category/deals" class= " "    name="Deals">
									Deals
								</a>
							</li>
					<li >
				<a href="https://www.trustedreviews.com/cameras" class= " "    name="Cameras">
									Cameras
								</a>
							</li>
					<li >
				<a href="https://www.trustedreviews.com/info/about-us-2-3982927" class= " "    name="About Us">
									About Us
								</a>
							</li>
					<li >
				<a href="https://discountcodes.trustedreviews.com" class= " "    name="Discount Codes">
									Discount Codes
								</a>
							</li>
		
		
		
		<li class="menu-more has-subnav">
			<a href="javascript:void(0)" name="See more menu items">More <span class="icon-plus"></span></a>
			<ul></ul>
		</li>
	</ul>

	<a href="javascript:void(0)" class="search-site icon-search" name="Search the site"><span class="hide">Search</span></a>

	<a href="#" class="menu-icon-link hidden-md hidden-lg" name="Toggle the site menu">
		<span class="menu-toggle icon-menu"><span class="hide">Menu</span></span>
	</a>

	<form role="search" method="get" class="search-form form-inline s-container" action="/">
		<div class="input-group">
			<input type="search" value="" name="s" class="input-sm search-field form-control" placeholder="Search">
							<button type="submit" class="btn btn--sm" name="search">Search</button>
						<div class="message-wrapper">
				<label for="s" class="message message--type">Type to search</label>
				<label for="s" class="message message--search hide">Press enter or click on the search icon</label>
			</div>
		</div>
	</form>
</nav>

</header>	


									<div class="trending">
	<div class="trending__inner">
		<div class="trending-list__outer">
			<ul class="trending-list__inner">
				<li>Trending:</li>
									<li><a href="https://www.trustedreviews.com/working-from-home-complete-tech-guide"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3641029"     name="Working from home">Working from home</a></li>
									<li><a href="https://www.trustedreviews.com/reviews/samsung-galaxy-s20"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3969484"     name="Galaxy S20 review">Galaxy S20 review</a></li>
									<li><a href="/news/xbox-series-x-release-date-news-specs-price-3981014"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3922840"     name="Xbox Series X">Xbox Series X</a></li>
									<li><a href="https://www.trustedreviews.com/reviews/iphone-11"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3931060"     name="iPhone 11 review">iPhone 11 review</a></li>
									<li><a href="https://www.trustedreviews.com/news/huawei-p40-vs-p40-pro-whats-the-difference-4019268"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3628349"     name="Huawei P40 vs P40 Pro">Huawei P40 vs P40 Pro</a></li>
									<li><a href="https://www.trustedreviews.com/best/best-iphone-3501342"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3628352"     name="Best iPhone">Best iPhone</a></li>
									<li><a href="https://www.trustedreviews.com/best/best-free-vpn-3692123"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3936304"     name="Best free VPN">Best free VPN</a></li>
							</ul>
		</div>
		<div class="trending__fade trending__fade--before"></div>
		<div class="trending__fade trending__fade--after"></div>
	</div>
</div>				
	<div id="content" role="main" class="container-fluid" >
		
	<style>

		.has-adverts {
			margin-top: 0px !important;
		}

	</style>

	

					<nav class="breadcrumb s-container" role="navigation">
    <div class="s-container__inner">
        <ul>
                            <li>
                                            <a href="https://www.trustedreviews.com" name="Home">Home</a>
                                    </li>

                            <li>
                                            <a href="https://www.trustedreviews.com/category/news" name="Tech News">Tech News</a>
                                    </li>

                            <li>
                                            Dell G Series 2020: Everything you need to know about the G3, G5 and G7
                                    </li>

                    </ul>
    </div>
</nav>	
		<article class="post-4038655 post type-post status-publish format-standard has-post-thumbnail hentry category-news brands-dell product_type-computing product_type-laptops product_type-pc-computing publication_name-trusted-reviews" role="article"
	>
					<section id="custom_html-18" class="widget_text  s-container sticky-anchor widget_custom_html"><div class="textwidget custom-html-widget"><p style="text-align:center;max-width:100%;" data-nosnippet>Trusted Reviews may earn an affiliate commission when you purchase through links on our site. <a href="https://www.trustedreviews.com/info/trusted-reviews-ethics-policy-3521647#how-we-make-money">Learn More</a></p></div></section>
		
		<div class="post-main">

							<header class="post-header post-header--article">
					<h1 class="title-primary">
													Dell G Series 2020: Everything you need to know about the G3, G5 and G7
											</h1>

																
											<div class="post-author">
    <small class="post-author-info">
                    
            <span>
                <a class="post-author__name url fn n" href="https://www.trustedreviews.com/author/hannahdavies" name="A post from Hannah Davies">
                    <span class="author vcard">Hannah Davies</span>
                </a>
                                <span class="vertical-bar">&vert;</span>
            </span>

        
        
                            <span>
                                <time datetime="2020-06-25T15:51:05+01:00">June 25, 2020 3:51 pm BST</time>
            </span>
            </small>
</div>					
					
						<div class="social-share">

														
																																								<ul class="pw-widget hidden-xs">
																			<li>
											<a
												href="https://www.facebook.com/sharer/sharer.php?u=https://www.trustedreviews.com/news/dell-g-series-2020-4038655"
												target="_blank"
												 rel="noopener" 												class="share-button "
												data-url="https://www.trustedreviews.com/news/dell-g-series-2020-4038655"
												name="Share this page on facebook"
											>
																									<svg xmlns="http://www.w3.org/2000/svg" width="13" height="25" viewBox="88.428 12.828 107.543 207.085"><path d="M158.232 219.912v-94.461h31.707l4.747-36.813h-36.454V65.134c0-10.658 2.96-17.922 18.245-17.922l19.494-.009V14.278c-3.373-.447-14.944-1.449-28.406-1.449-28.106 0-47.348 17.155-47.348 48.661v27.149H88.428v36.813h31.788v94.461l38.016-.001z" fill="#3c5a9a"/></svg>
																							</a>
										</li>
																			<li>
											<a
												href="https://twitter.com/intent/tweet?url=https://www.trustedreviews.com/news/dell-g-series-2020-4038655&text=Dell G Series 2020: Everything you need to know about the G3, G5 and G7"
												target="_blank"
												 rel="noopener" 												class="share-button "
												data-url="https://www.trustedreviews.com/news/dell-g-series-2020-4038655"
												name="Share this page on twitter"
											>
																									<svg xmlns="http://www.w3.org/2000/svg" width="25" height="25" viewBox="0 0 512.002 512.002" style="enable-background:new 0 0 512.002 512.002;" xml:space="preserve"><path style="fill:#73A1FB;" d="M500.398,94.784c-8.043,3.567-16.313,6.578-24.763,9.023c10.004-11.314,17.631-24.626,22.287-39.193 c1.044-3.265-0.038-6.839-2.722-8.975c-2.681-2.137-6.405-2.393-9.356-0.644c-17.945,10.643-37.305,18.292-57.605,22.764 c-20.449-19.981-48.222-31.353-76.934-31.353c-60.606,0-109.913,49.306-109.913,109.91c0,4.773,0.302,9.52,0.9,14.201 c-75.206-6.603-145.124-43.568-193.136-102.463c-1.711-2.099-4.347-3.231-7.046-3.014c-2.7,0.211-5.127,1.734-6.491,4.075 c-9.738,16.709-14.886,35.82-14.886,55.265c0,26.484,9.455,51.611,26.158,71.246c-5.079-1.759-10.007-3.957-14.711-6.568 c-2.525-1.406-5.607-1.384-8.116,0.054c-2.51,1.439-4.084,4.084-4.151,6.976c-0.012,0.487-0.012,0.974-0.012,1.468 c0,39.531,21.276,75.122,53.805,94.52c-2.795-0.279-5.587-0.684-8.362-1.214c-2.861-0.547-5.802,0.456-7.731,2.638 c-1.932,2.18-2.572,5.219-1.681,7.994c12.04,37.591,43.039,65.24,80.514,73.67c-31.082,19.468-66.626,29.665-103.939,29.665 c-7.786,0-15.616-0.457-23.279-1.364c-3.807-0.453-7.447,1.795-8.744,5.416c-1.297,3.622,0.078,7.66,3.316,9.736 c47.935,30.735,103.361,46.98,160.284,46.98c111.903,0,181.907-52.769,220.926-97.037c48.657-55.199,76.562-128.261,76.562-200.451 c0-3.016-0.046-6.061-0.139-9.097c19.197-14.463,35.724-31.967,49.173-52.085c2.043-3.055,1.822-7.094-0.545-9.906 C507.7,94.204,503.76,93.294,500.398,94.784z"/></svg>
																							</a>
										</li>
																			<li>
											<a
												href="https://pinterest.com/pin/create/button/?url=https://www.trustedreviews.com/news/dell-g-series-2020-4038655&description=Dell G Series 2020: Everything you need to know about the G3, G5 and G7"
												target="_blank"
												 rel="noopener" 												class="share-button "
												data-url="https://www.trustedreviews.com/news/dell-g-series-2020-4038655"
												name="Share this page on pinterest"
											>
																									<svg xmlns="http://www.w3.org/2000/svg" width="25" height="25" viewBox="0 0 512.883 512.883" style="enable-background:new 0 0 512.883 512.883;" xml:space="preserve"> <path style="fill:#CB1F24;" d="M256.441,0c-141.241,0-256,114.759-256,256c0,105.048,62.676,195.09,153.6,234.814 c-0.883-17.655,0-39.724,4.414-59.145c5.297-21.186,32.662-139.476,32.662-139.476s-7.945-16.772-7.945-40.607 c0-37.959,22.069-66.207,49.434-66.207c22.952,0,34.428,17.655,34.428,38.841c0,22.952-15.007,58.262-22.952,90.924 c-6.179,27.366,13.241,49.434,40.607,49.434c48.552,0,81.214-62.676,81.214-135.945c0-56.497-37.959-97.986-106.814-97.986 c-77.683,0-126.234,58.262-126.234,122.703c0,22.069,6.179,37.959,16.772,50.317c4.414,5.297,5.297,7.945,3.531,14.124 c-0.883,4.414-4.414,15.89-5.297,20.303c-1.766,6.179-7.062,8.828-13.241,6.179c-36.193-15.007-52.083-53.848-52.083-97.986 c0-72.386,60.91-159.779,182.731-159.779c97.986,0,162.428,70.621,162.428,146.538c0,100.634-55.614,175.669-137.71,175.669 c-27.366,0-53.848-15.007-62.676-31.779c0,0-15.007,59.145-17.655,70.621c-5.297,19.421-15.89,39.724-25.6,54.731 c22.952,7.062,47.669,10.593,72.386,10.593c141.241,0,256-114.759,256-256S397.683,0,256.441,0"/></svg>
																							</a>
										</li>
																										</ul>
																																								<ul class="pw-widget hidden-sm hidden-md hidden-lg">
																			<li>
											<a
												href="https://www.facebook.com/sharer/sharer.php?u=https://www.trustedreviews.com/news/dell-g-series-2020-4038655"
												target="_blank"
												 rel="noopener" 												class="share-button "
												data-url="https://www.trustedreviews.com/news/dell-g-series-2020-4038655"
												name="Share this page on facebook"
											>
																									<svg xmlns="http://www.w3.org/2000/svg" width="13" height="25" viewBox="88.428 12.828 107.543 207.085"><path d="M158.232 219.912v-94.461h31.707l4.747-36.813h-36.454V65.134c0-10.658 2.96-17.922 18.245-17.922l19.494-.009V14.278c-3.373-.447-14.944-1.449-28.406-1.449-28.106 0-47.348 17.155-47.348 48.661v27.149H88.428v36.813h31.788v94.461l38.016-.001z" fill="#3c5a9a"/></svg>
																							</a>
										</li>
																			<li>
											<a
												href="https://twitter.com/intent/tweet?url=https://www.trustedreviews.com/news/dell-g-series-2020-4038655&text=Dell G Series 2020: Everything you need to know about the G3, G5 and G7"
												target="_blank"
												 rel="noopener" 												class="share-button "
												data-url="https://www.trustedreviews.com/news/dell-g-series-2020-4038655"
												name="Share this page on twitter"
											>
																									<svg xmlns="http://www.w3.org/2000/svg" width="25" height="25" viewBox="0 0 512.002 512.002" style="enable-background:new 0 0 512.002 512.002;" xml:space="preserve"><path style="fill:#73A1FB;" d="M500.398,94.784c-8.043,3.567-16.313,6.578-24.763,9.023c10.004-11.314,17.631-24.626,22.287-39.193 c1.044-3.265-0.038-6.839-2.722-8.975c-2.681-2.137-6.405-2.393-9.356-0.644c-17.945,10.643-37.305,18.292-57.605,22.764 c-20.449-19.981-48.222-31.353-76.934-31.353c-60.606,0-109.913,49.306-109.913,109.91c0,4.773,0.302,9.52,0.9,14.201 c-75.206-6.603-145.124-43.568-193.136-102.463c-1.711-2.099-4.347-3.231-7.046-3.014c-2.7,0.211-5.127,1.734-6.491,4.075 c-9.738,16.709-14.886,35.82-14.886,55.265c0,26.484,9.455,51.611,26.158,71.246c-5.079-1.759-10.007-3.957-14.711-6.568 c-2.525-1.406-5.607-1.384-8.116,0.054c-2.51,1.439-4.084,4.084-4.151,6.976c-0.012,0.487-0.012,0.974-0.012,1.468 c0,39.531,21.276,75.122,53.805,94.52c-2.795-0.279-5.587-0.684-8.362-1.214c-2.861-0.547-5.802,0.456-7.731,2.638 c-1.932,2.18-2.572,5.219-1.681,7.994c12.04,37.591,43.039,65.24,80.514,73.67c-31.082,19.468-66.626,29.665-103.939,29.665 c-7.786,0-15.616-0.457-23.279-1.364c-3.807-0.453-7.447,1.795-8.744,5.416c-1.297,3.622,0.078,7.66,3.316,9.736 c47.935,30.735,103.361,46.98,160.284,46.98c111.903,0,181.907-52.769,220.926-97.037c48.657-55.199,76.562-128.261,76.562-200.451 c0-3.016-0.046-6.061-0.139-9.097c19.197-14.463,35.724-31.967,49.173-52.085c2.043-3.055,1.822-7.094-0.545-9.906 C507.7,94.204,503.76,93.294,500.398,94.784z"/></svg>
																							</a>
										</li>
																			<li>
											<a
												href="https://pinterest.com/pin/create/button/?url=https://www.trustedreviews.com/news/dell-g-series-2020-4038655&description=Dell G Series 2020: Everything you need to know about the G3, G5 and G7"
												target="_blank"
												 rel="noopener" 												class="share-button "
												data-url="https://www.trustedreviews.com/news/dell-g-series-2020-4038655"
												name="Share this page on pinterest"
											>
																									<svg xmlns="http://www.w3.org/2000/svg" width="25" height="25" viewBox="0 0 512.883 512.883" style="enable-background:new 0 0 512.883 512.883;" xml:space="preserve"> <path style="fill:#CB1F24;" d="M256.441,0c-141.241,0-256,114.759-256,256c0,105.048,62.676,195.09,153.6,234.814 c-0.883-17.655,0-39.724,4.414-59.145c5.297-21.186,32.662-139.476,32.662-139.476s-7.945-16.772-7.945-40.607 c0-37.959,22.069-66.207,49.434-66.207c22.952,0,34.428,17.655,34.428,38.841c0,22.952-15.007,58.262-22.952,90.924 c-6.179,27.366,13.241,49.434,40.607,49.434c48.552,0,81.214-62.676,81.214-135.945c0-56.497-37.959-97.986-106.814-97.986 c-77.683,0-126.234,58.262-126.234,122.703c0,22.069,6.179,37.959,16.772,50.317c4.414,5.297,5.297,7.945,3.531,14.124 c-0.883,4.414-4.414,15.89-5.297,20.303c-1.766,6.179-7.062,8.828-13.241,6.179c-36.193-15.007-52.083-53.848-52.083-97.986 c0-72.386,60.91-159.779,182.731-159.779c97.986,0,162.428,70.621,162.428,146.538c0,100.634-55.614,175.669-137.71,175.669 c-27.366,0-53.848-15.007-62.676-31.779c0,0-15.007,59.145-17.655,70.621c-5.297,19.421-15.89,39.724-25.6,54.731 c22.952,7.062,47.669,10.593,72.386,10.593c141.241,0,256-114.759,256-256S397.683,0,256.441,0"/></svg>
																							</a>
										</li>
																										</ul>
							
						</div>

					
									</header>
			
			
			<div class="post-main__inner">

				
				                    							<div class="featured-media ggnoads">
		<div id="attachment_4038677"
     class="featured-image">
	<figure class="image ">
		<img
          src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/thumbnail_image001.png"
     id="4038677"
     class=""
     alt=""
     width=""
	 height=""
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/thumbnail_image001-320x172.png 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/thumbnail_image001-620x334.png 620w,
					"/>	</figure>
	</div>
	</div>
									
				
				<div class="slot-wrapper slot-wrapper--full">
					<div id="header-1" class="ipc-advert"></div>				</div>

				<div class="post-body">

					<div class="social-share social-share--sticky">

												
																																			<ul class="pw-widget hidden-xs">
																	<li>
										<a
											href="https://www.facebook.com/sharer/sharer.php?u=https://www.trustedreviews.com/news/dell-g-series-2020-4038655"
											target="_blank"
											 rel="noopener" 											class="share-button "
											data-url="https://www.trustedreviews.com/news/dell-g-series-2020-4038655"
											name="Share this page on facebook"
										>
																							<svg xmlns="http://www.w3.org/2000/svg" width="13" height="25" viewBox="88.428 12.828 107.543 207.085"><path d="M158.232 219.912v-94.461h31.707l4.747-36.813h-36.454V65.134c0-10.658 2.96-17.922 18.245-17.922l19.494-.009V14.278c-3.373-.447-14.944-1.449-28.406-1.449-28.106 0-47.348 17.155-47.348 48.661v27.149H88.428v36.813h31.788v94.461l38.016-.001z" fill="#3c5a9a"/></svg>
																					</a>
									</li>
																	<li>
										<a
											href="https://twitter.com/intent/tweet?url=https://www.trustedreviews.com/news/dell-g-series-2020-4038655&text=Dell G Series 2020: Everything you need to know about the G3, G5 and G7"
											target="_blank"
											 rel="noopener" 											class="share-button "
											data-url="https://www.trustedreviews.com/news/dell-g-series-2020-4038655"
											name="Share this page on twitter"
										>
																							<svg xmlns="http://www.w3.org/2000/svg" width="25" height="25" viewBox="0 0 512.002 512.002" style="enable-background:new 0 0 512.002 512.002;" xml:space="preserve"><path style="fill:#73A1FB;" d="M500.398,94.784c-8.043,3.567-16.313,6.578-24.763,9.023c10.004-11.314,17.631-24.626,22.287-39.193 c1.044-3.265-0.038-6.839-2.722-8.975c-2.681-2.137-6.405-2.393-9.356-0.644c-17.945,10.643-37.305,18.292-57.605,22.764 c-20.449-19.981-48.222-31.353-76.934-31.353c-60.606,0-109.913,49.306-109.913,109.91c0,4.773,0.302,9.52,0.9,14.201 c-75.206-6.603-145.124-43.568-193.136-102.463c-1.711-2.099-4.347-3.231-7.046-3.014c-2.7,0.211-5.127,1.734-6.491,4.075 c-9.738,16.709-14.886,35.82-14.886,55.265c0,26.484,9.455,51.611,26.158,71.246c-5.079-1.759-10.007-3.957-14.711-6.568 c-2.525-1.406-5.607-1.384-8.116,0.054c-2.51,1.439-4.084,4.084-4.151,6.976c-0.012,0.487-0.012,0.974-0.012,1.468 c0,39.531,21.276,75.122,53.805,94.52c-2.795-0.279-5.587-0.684-8.362-1.214c-2.861-0.547-5.802,0.456-7.731,2.638 c-1.932,2.18-2.572,5.219-1.681,7.994c12.04,37.591,43.039,65.24,80.514,73.67c-31.082,19.468-66.626,29.665-103.939,29.665 c-7.786,0-15.616-0.457-23.279-1.364c-3.807-0.453-7.447,1.795-8.744,5.416c-1.297,3.622,0.078,7.66,3.316,9.736 c47.935,30.735,103.361,46.98,160.284,46.98c111.903,0,181.907-52.769,220.926-97.037c48.657-55.199,76.562-128.261,76.562-200.451 c0-3.016-0.046-6.061-0.139-9.097c19.197-14.463,35.724-31.967,49.173-52.085c2.043-3.055,1.822-7.094-0.545-9.906 C507.7,94.204,503.76,93.294,500.398,94.784z"/></svg>
																					</a>
									</li>
																	<li>
										<a
											href="https://pinterest.com/pin/create/button/?url=https://www.trustedreviews.com/news/dell-g-series-2020-4038655&description=Dell G Series 2020: Everything you need to know about the G3, G5 and G7"
											target="_blank"
											 rel="noopener" 											class="share-button "
											data-url="https://www.trustedreviews.com/news/dell-g-series-2020-4038655"
											name="Share this page on pinterest"
										>
																							<svg xmlns="http://www.w3.org/2000/svg" width="25" height="25" viewBox="0 0 512.883 512.883" style="enable-background:new 0 0 512.883 512.883;" xml:space="preserve"> <path style="fill:#CB1F24;" d="M256.441,0c-141.241,0-256,114.759-256,256c0,105.048,62.676,195.09,153.6,234.814 c-0.883-17.655,0-39.724,4.414-59.145c5.297-21.186,32.662-139.476,32.662-139.476s-7.945-16.772-7.945-40.607 c0-37.959,22.069-66.207,49.434-66.207c22.952,0,34.428,17.655,34.428,38.841c0,22.952-15.007,58.262-22.952,90.924 c-6.179,27.366,13.241,49.434,40.607,49.434c48.552,0,81.214-62.676,81.214-135.945c0-56.497-37.959-97.986-106.814-97.986 c-77.683,0-126.234,58.262-126.234,122.703c0,22.069,6.179,37.959,16.772,50.317c4.414,5.297,5.297,7.945,3.531,14.124 c-0.883,4.414-4.414,15.89-5.297,20.303c-1.766,6.179-7.062,8.828-13.241,6.179c-36.193-15.007-52.083-53.848-52.083-97.986 c0-72.386,60.91-159.779,182.731-159.779c97.986,0,162.428,70.621,162.428,146.538c0,100.634-55.614,175.669-137.71,175.669 c-27.366,0-53.848-15.007-62.676-31.779c0,0-15.007,59.145-17.655,70.621c-5.297,19.421-15.89,39.724-25.6,54.731 c22.952,7.062,47.669,10.593,72.386,10.593c141.241,0,256-114.759,256-256S397.683,0,256.441,0"/></svg>
																					</a>
									</li>
																							</ul>
																																			<ul class="pw-widget hidden-sm hidden-md hidden-lg">
																	<li>
										<a
											href="https://www.facebook.com/sharer/sharer.php?u=https://www.trustedreviews.com/news/dell-g-series-2020-4038655"
											target="_blank"
											 rel="noopener" 											class="share-button "
											data-url="https://www.trustedreviews.com/news/dell-g-series-2020-4038655"
											name="Share this page on facebook"
										>
																							<svg xmlns="http://www.w3.org/2000/svg" width="13" height="25" viewBox="88.428 12.828 107.543 207.085"><path d="M158.232 219.912v-94.461h31.707l4.747-36.813h-36.454V65.134c0-10.658 2.96-17.922 18.245-17.922l19.494-.009V14.278c-3.373-.447-14.944-1.449-28.406-1.449-28.106 0-47.348 17.155-47.348 48.661v27.149H88.428v36.813h31.788v94.461l38.016-.001z" fill="#3c5a9a"/></svg>
																					</a>
									</li>
																	<li>
										<a
											href="https://twitter.com/intent/tweet?url=https://www.trustedreviews.com/news/dell-g-series-2020-4038655&text=Dell G Series 2020: Everything you need to know about the G3, G5 and G7"
											target="_blank"
											 rel="noopener" 											class="share-button "
											data-url="https://www.trustedreviews.com/news/dell-g-series-2020-4038655"
											name="Share this page on twitter"
										>
																							<svg xmlns="http://www.w3.org/2000/svg" width="25" height="25" viewBox="0 0 512.002 512.002" style="enable-background:new 0 0 512.002 512.002;" xml:space="preserve"><path style="fill:#73A1FB;" d="M500.398,94.784c-8.043,3.567-16.313,6.578-24.763,9.023c10.004-11.314,17.631-24.626,22.287-39.193 c1.044-3.265-0.038-6.839-2.722-8.975c-2.681-2.137-6.405-2.393-9.356-0.644c-17.945,10.643-37.305,18.292-57.605,22.764 c-20.449-19.981-48.222-31.353-76.934-31.353c-60.606,0-109.913,49.306-109.913,109.91c0,4.773,0.302,9.52,0.9,14.201 c-75.206-6.603-145.124-43.568-193.136-102.463c-1.711-2.099-4.347-3.231-7.046-3.014c-2.7,0.211-5.127,1.734-6.491,4.075 c-9.738,16.709-14.886,35.82-14.886,55.265c0,26.484,9.455,51.611,26.158,71.246c-5.079-1.759-10.007-3.957-14.711-6.568 c-2.525-1.406-5.607-1.384-8.116,0.054c-2.51,1.439-4.084,4.084-4.151,6.976c-0.012,0.487-0.012,0.974-0.012,1.468 c0,39.531,21.276,75.122,53.805,94.52c-2.795-0.279-5.587-0.684-8.362-1.214c-2.861-0.547-5.802,0.456-7.731,2.638 c-1.932,2.18-2.572,5.219-1.681,7.994c12.04,37.591,43.039,65.24,80.514,73.67c-31.082,19.468-66.626,29.665-103.939,29.665 c-7.786,0-15.616-0.457-23.279-1.364c-3.807-0.453-7.447,1.795-8.744,5.416c-1.297,3.622,0.078,7.66,3.316,9.736 c47.935,30.735,103.361,46.98,160.284,46.98c111.903,0,181.907-52.769,220.926-97.037c48.657-55.199,76.562-128.261,76.562-200.451 c0-3.016-0.046-6.061-0.139-9.097c19.197-14.463,35.724-31.967,49.173-52.085c2.043-3.055,1.822-7.094-0.545-9.906 C507.7,94.204,503.76,93.294,500.398,94.784z"/></svg>
																					</a>
									</li>
																	<li>
										<a
											href="https://pinterest.com/pin/create/button/?url=https://www.trustedreviews.com/news/dell-g-series-2020-4038655&description=Dell G Series 2020: Everything you need to know about the G3, G5 and G7"
											target="_blank"
											 rel="noopener" 											class="share-button "
											data-url="https://www.trustedreviews.com/news/dell-g-series-2020-4038655"
											name="Share this page on pinterest"
										>
																							<svg xmlns="http://www.w3.org/2000/svg" width="25" height="25" viewBox="0 0 512.883 512.883" style="enable-background:new 0 0 512.883 512.883;" xml:space="preserve"> <path style="fill:#CB1F24;" d="M256.441,0c-141.241,0-256,114.759-256,256c0,105.048,62.676,195.09,153.6,234.814 c-0.883-17.655,0-39.724,4.414-59.145c5.297-21.186,32.662-139.476,32.662-139.476s-7.945-16.772-7.945-40.607 c0-37.959,22.069-66.207,49.434-66.207c22.952,0,34.428,17.655,34.428,38.841c0,22.952-15.007,58.262-22.952,90.924 c-6.179,27.366,13.241,49.434,40.607,49.434c48.552,0,81.214-62.676,81.214-135.945c0-56.497-37.959-97.986-106.814-97.986 c-77.683,0-126.234,58.262-126.234,122.703c0,22.069,6.179,37.959,16.772,50.317c4.414,5.297,5.297,7.945,3.531,14.124 c-0.883,4.414-4.414,15.89-5.297,20.303c-1.766,6.179-7.062,8.828-13.241,6.179c-36.193-15.007-52.083-53.848-52.083-97.986 c0-72.386,60.91-159.779,182.731-159.779c97.986,0,162.428,70.621,162.428,146.538c0,100.634-55.614,175.669-137.71,175.669 c-27.366,0-53.848-15.007-62.676-31.779c0,0-15.007,59.145-17.655,70.621c-5.297,19.421-15.89,39.724-25.6,54.731 c22.952,7.062,47.669,10.593,72.386,10.593c141.241,0,256-114.759,256-256S397.683,0,256.441,0"/></svg>
																					</a>
									</li>
																							</ul>
						
					</div>

					<div class="articleBody">
																									
																			
																																		
													<p><strong>Dell unveiled the new Dell G7 this week. The G7 rounds off the new Dell G Series, a range of three powerful gaming laptops all seeing updates in the first half of 2020. </strong></p>
<p>The G Series is Dell&#8217;s most affordable line of gaming laptops and includes the Dell G3, the Dell G5 and the Dell G7 laptops.</p>
<p>Read on for all you need to know about Dell&#8217;s latest gaming range, including price, specs and release dates.</p>
<p><strong>Related: <a href="https://www.trustedreviews.com/best/best-gaming-laptop-3439021" target="_blank" rel="noopener noreferrer">Best gaming laptop</a></strong></p>
<p><img class="lazyload blur-up alignnone wp-image-4038679 size-full" src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png" data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/laptop_g_series_g3_15_3500_nontouch_notebook_pdp_for_work_mod_4.jpg" alt="" width="965" height="600" data-sizes="auto" data-srcset="https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/laptop_g_series_g3_15_3500_nontouch_notebook_pdp_for_work_mod_4.jpg 965w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/laptop_g_series_g3_15_3500_nontouch_notebook_pdp_for_work_mod_4-300x187.jpg 300w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/laptop_g_series_g3_15_3500_nontouch_notebook_pdp_for_work_mod_4-768x478.jpg 768w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/laptop_g_series_g3_15_3500_nontouch_notebook_pdp_for_work_mod_4-320x199.jpg 320w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/laptop_g_series_g3_15_3500_nontouch_notebook_pdp_for_work_mod_4-620x385.jpg 620w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/laptop_g_series_g3_15_3500_nontouch_notebook_pdp_for_work_mod_4-920x572.jpg 920w" sizes="(max-width: 965px) 100vw, 965px" /></p>
<h2>Dell G3 (2020)</h2>
<p>The Dell G3 is the most affordable laptop of the three G Series laptops and it&#8217;s undergone a handful of upgrades from its last iteration.</p>
<p>The 15-inch laptop is powered by Intel&#8217;s 10th Gen H-Series processors (up to i7) <span style="font-weight: 400">and Nvidia GeForce graphics (up to RTX 2060). It&#8217;s packed with up to 16GB RAM and features an optional 144Hz display surrounded by a slim bezel. </span></p>
<p>The G3 also features a &#8216;Game Shift&#8217; key for instantly activating dynamic performance mode and turning the dual-fan cooling system up during heavy action scenes, and comes with the Alienware Command Center installed so you can customise the optional 4-zone RBG lighting on the keyboard.</p>
<p>The Dell G3 is available in Eclipse black and Alpine white and is available to buy now with prices starting at £799.</p>
<p><strong>Related: <a href="https://www.trustedreviews.com/best/best-dell-laptops-3987884" target="_blank" rel="noopener noreferrer">Best Dell Laptop </a></strong></p>
<p><img class="lazyload blur-up alignnone wp-image-4038678 size-full" src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png" data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/laptops-dell-g-series-g5-15-nt-pdp-mod-3.jpg" alt="" width="965" height="570" data-sizes="auto" data-srcset="https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/laptops-dell-g-series-g5-15-nt-pdp-mod-3.jpg 965w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/laptops-dell-g-series-g5-15-nt-pdp-mod-3-300x177.jpg 300w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/laptops-dell-g-series-g5-15-nt-pdp-mod-3-768x454.jpg 768w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/laptops-dell-g-series-g5-15-nt-pdp-mod-3-320x189.jpg 320w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/laptops-dell-g-series-g5-15-nt-pdp-mod-3-620x366.jpg 620w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/laptops-dell-g-series-g5-15-nt-pdp-mod-3-920x543.jpg 920w" sizes="(max-width: 965px) 100vw, 965px" /></p>
<h2>Dell G5 (2020)</h2>
<p>The Dell G5 is the middle sibling in the G Series.</p>
<p>The 15-inch gaming laptop features 16GB of memory and a Full HD display with narrow bezels and the option of a 144Hz or 240Hz panel.</p>
<p>The G5 is powered by 10th Gen Intel Core CPUs (up to i7), alongside a choice of the Nvidia GeForce GTX 1660Ti GPU or the RTX 2070 with Max-Q, with the latter capable of ray tracing, DLSS and AI-enhanced graphics rendering.</p>
<p>The G5 also features Killer Gigabit Ethernet for reduced lag, the &#8216;Game Shift&#8217; key to trigger dynamic performance mode and turn up the fan when needed, customisable WASD and chassis lights, and Nahimic 3D Audio.</p>
<p>The Dell G5 is available to purchase now with prices starting at £989.</p>
<p><strong>Related: <a href="https://www.trustedreviews.com/news/best-laptops-3431966" target="_blank" rel="noopener noreferrer">Best laptop</a></strong></p>
<p><img class="lazyload blur-up alignnone wp-image-4038677 size-full" src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png" data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/thumbnail_image001.png" alt="" width="866" height="466" data-sizes="auto" data-srcset="https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/thumbnail_image001.png 866w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/thumbnail_image001-300x161.png 300w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/thumbnail_image001-768x413.png 768w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/thumbnail_image001-320x172.png 320w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2020/06/thumbnail_image001-620x334.png 620w" sizes="(max-width: 866px) 100vw, 866px" /></p>
<h2>Dell G7 (2020)</h2>
<p>Dell has redesigned the G7 for 2020. Among the new updates from its predecessor are a slimmer design, more powerful performance and a customisable chassis light.</p>
<p>The laptop <span style="font-weight: 400">– which is available in 15-inch and 17-inch variations – </span>has a new hinge design, along with a black anodised, all-metal chassis, allowing the laptop to drop 4mm to 20.5mm at the hinge. The bezels around the display have also shaved some weight, going from 9.9mm to 6.5mm on the G7 15 and 8.16mm on the G7 17.</p>
<p>The G7 is powered by the 10th Gen Intel Core CPUs (up to i9) and Nvidia GeForce graphic cards (up to Nvidia GeForce RTX 2070 with Max-Q Design on the G7 15, and Nvidia GeForce RTX 2070 Super on the G7 17).</p>
<p>Like the rest of the series, this laptop is packed with gaming features, including a precision glass trackpad, customisable chassis light and a 4-zone RGB keyboard. There&#8217;s also the &#8216;Game Shift&#8217; macro key to modulate the fan, along with Nahimic 3D Audio for 360⁰ audio, along with VoiceBoost and Sound Tracker radar.</p>
<p>Both the G7 15 and the G7 17 will be available to buy in July, with the 15-inch version available on July 17 and a specific date for the 17-inch version yet to be announced. UK pricing for both G7 models is yet to be confirmed.</p>


															<div class="post-author-card">

	    <div class="post-author-card-image author-image--mobile">
        <img
            alt="Hannah Davies"
            src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/08/Image-from-iOS-1-150x150.jpg"
            class="post-author--img"
            height="145"
            width="145">
    </div>
	
	<div class="post-author-card-details">
		<div class="post-author-card-top">
							<div class="post-author-card-name">
					<span itemprop="author">
						<a class="url fn n" href="https://www.trustedreviews.com/author/hannahdavies" name="A post from Hannah Davies">
							<span class="author vcard">Hannah Davies</span>
						</a>
					</span>
				</div>
				<ul class="post-author-card-links author-links--desktop">
                    </ul>					</div>
		
					<div class="post-author-card-job-title">
				<small id="author-job-title" class="role">Staff Writer</small>
			</div>
		
		<div class="post-author-card-lower">
							<div class="post-author-card-description">
											Hannah joined Trusted Reviews as a staff writer in 2019 after graduating with a degree in English from Royal Holloway, University of London. She’s also worked and studied in the US, holding positions &hellip;
									</div>
			
			    <div class="post-author-card-image author-image--desktop">
        <img
            alt="Hannah Davies"
            src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/08/Image-from-iOS-1-150x150.jpg"
            class="post-author--img"
            height="145"
            width="145">
    </div>

		</div>

		<ul class="post-author-card-links author-links--mobile">
                    </ul>
	</div>
</div>							
															<section id="custom_html-6" class="widget_text  s-container sticky-anchor hide-widget-title widget_custom_html"><div class="textwidget custom-html-widget"><p>Unlike other sites, we thoroughly review everything we recommend, using industry standard tests to evaluate products. We’ll always tell you what we find. We may get a commission if you buy via our price links.
Tell us what you think – <a href="https://www.trustedreviews.com/opinion/friday-emails-3714925">email the Editor</a></p>
</div></section>
													
					</div>

																
					
											<div id="taboola-below-article-thumbnails"></div>									</div>
			</div>

			
		</div>
	</article>
			
	</div>

			<div class="parallax-wrapper parallax-wrapper--footer sticky-anchor"></div>

<footer id="footer" role="contentinfo" class="footer sticky-anchor">
	<div class="footer__row">
		<nav class="footer__col footer__col--content">
			<ul id="menu-3" class="footer-menu footer-menu--plain">
			<li id="menu-item-3927554" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3927554">
			<a href="/archive"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Content archive
				</span>
			</a>
		</li>
			<li id="menu-item-2651360" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2651360">
			<a href="/info/about-us-2-3982927"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					About us / contact us
				</span>
			</a>
		</li>
			<li id="menu-item-3580003" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3580003">
			<a href="https://www.trustedreviews.com/info/trusted-reviews-ethics-policy-3521647"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Editorial independence
				</span>
			</a>
		</li>
			<li id="menu-item-3550819" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3550819">
			<a href="https://www.ti-media.com/terms-and-conditions/#_Toc513817991"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Labelling of commercial content
				</span>
			</a>
		</li>
			<li id="menu-item-3550821" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3550821">
			<a href="https://www.ipso.co.uk/editors-code-of-practice/"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					IPSO Editors' Code of Practice
				</span>
			</a>
		</li>
			<li id="menu-item-2651363" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2651363">
			<a href="http://www.timeincuk.com/privacy/"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Privacy & cookie policy
				</span>
			</a>
		</li>
			<li id="menu-item-2651362" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2651362">
			<a href="http://www.timeincuk.com/terms-and-conditions/"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Terms & Conditions
				</span>
			</a>
		</li>
			<li id="menu-item-3550818" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3550818">
			<a href="https://www.ti-media.com/terms-and-conditions/#_Toc513817985"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Third party advertising policy
				</span>
			</a>
		</li>
			<li id="menu-item-3249531" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3249531">
			<a href="https://www.trustedreviews.com/rss-feeds"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Follow Trusted Reviews via RSS
				</span>
			</a>
		</li>
			<li id="menu-item-3550823" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3550823">
			<a href="https://comps.trustedreviews.com/?_ga=2.81825043.400893545.1535971409-812703703.1535551482"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Competitions
				</span>
			</a>
		</li>
			<li id="menu-item-2651361" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2651361">
			<a href="http://www.timeincuk.com/advertise/"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Advertise with us
				</span>
			</a>
		</li>
			<li id="menu-item-3525646" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3525646">
			<a href="#"  title="privacy-settings"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon" name="Visit our no-icon page">
				<span class="menu-icon-item icon-no-icon">
					Privacy Settings
				</span>
			</a>
		</li>
	</ul>		</nav>
		<nav class="footer__col footer__col--sidebar">
			<div class="ad-logos">
	<a href="https://www.iabuk.com/goldstandard" class="footer__iab" target="_blank" rel="noopener" name="IAB Gold Standard">
		<img 
			src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png" 
			data-src="/wp-content/themes/simba-theme/assets/images/iab_logo.png" 
			class="lazyload blur-up" 
			alt="IAB Gold Standard" 
			width="100%" />
	</a>
	<a href="https://jicwebs.org/standards/brand-safety/" class="footer__jic" target="_blank" rel="noopener" name="JIC WEBS Brand Safety">
		<img 
			src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png" 
			data-src="/wp-content/themes/simba-theme/assets/images/jic_webs_logo.jpg" 
			class="lazyload blur-up" 
			alt="JIC WEBS Brand Safety" 
			width="100%" />
	</a>
</div>
			
		</nav>

		<div class="footer-legal">
			<a itemprop="url" href="" title="" name="">
			<img 
				itemprop="logo" 
				src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png" 
				data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2018/10/tr-logo-large-1.png" 
				class="lazyload blur-up footer-logo" 
				alt="" 
				data-pin-nopin="true">
		</a>
		<sub>&copy; Copyright TI Media Limited. 161 Marsh Wall, London, E14 9SJ. All rights reserved.</sub>
	<a href="https://www.ipso.co.uk/what-we-do/" class="footer__ipso" target="_blank" rel="noopener" name="Visit the IPSO website">
		<img 
			src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/placeholder.png" 
			data-src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/ipso-dark.png" 
			class="lazyload blur-up" 
			alt="IPSO Regulated" 
			width="100%" />
	</a>
</div>
		<ul id="menu-8" class="footer-menu footer-menu--icons">
			<li id="menu-item-2651357" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2651357">
			<a href="https://www.facebook.com/pages/TrustedReviews/38275114220?ref=ts"   target="_blank" rel="noopener" class="menu-icon-item icon-social-facebook" name="Visit our facebook page">
				<span class="menu-icon-item icon-facebook">
					Facebook
				</span>
			</a>
		</li>
			<li id="menu-item-2651356" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2651356">
			<a href="https://twitter.com/trustedreviews"   target="_blank" rel="noopener" class="menu-icon-item icon-social-twitter" name="Visit our twitter page">
				<span class="menu-icon-item icon-twitter">
					Twitter
				</span>
			</a>
		</li>
			<li id="menu-item-2651358" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2651358">
			<a href="https://www.youtube.com/user/TrustedReviews"   target="_blank" rel="noopener" class="menu-icon-item icon-social-youtube" name="Visit our youtube page">
				<span class="menu-icon-item icon-youtube">
					YouTube
				</span>
			</a>
		</li>
			<li id="menu-item-3249533" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3249533">
			<a href="https://www.trustedreviews.com/rss-feeds"   target="_blank" rel="noopener" class="menu-icon-item icon-social-rss" name="Visit our rss page">
				<span class="menu-icon-item icon-rss">
					Follow Trusted Reviews via RSS
				</span>
			</a>
		</li>
	</ul>	</div>
</footer>
				<script type="text/javascript">
			(function() {
				/* Include required screen size functions right here */
				var getDisplayWidth=function(){var e=0;if(typeof window.innerWidth!="undefined"){e=window.innerWidth}else if(typeof document.documentElement!="undefined"&&typeof document.documentElement.clientWidth!="undefined"&&document.documentElement.clientWidth!=0){e=document.documentElement.clientWidth}else{e=document.getElementsByTagName("body")[0].clientWidth}return Number(e)};
				var getWindowSize = getDisplayWidth();
				window.ipcTags = window.ipcTags || {};
				/* Pageskin targeting stuff */
				if(getWindowSize >= 1350) {
					window.ipcTags['pageskin'] = 'yes';
				} else {
					window.ipcTags['pageskin'] = 'no';
				}

				
				if(getWindowSize >= 690) {
					window.ipcTags.platform = 'desktop';
				} else {
					window.ipcTags.platform = 'mobile';
				}

				
				window.ipcTags['dfp_config']['required_tags'].push('pageskin');
			})();
		</script>
		<script type='text/javascript'>
			(function(d,w){
				var s = d.createElement('script');
				w.lazySizesConfig = {'expFactor':'1'};
				s.src = 'https://www.trustedreviews.com/wp-content/plugins/keystone-images/assets/js/sizes.js?ver=0.0.1';
				d.body.appendChild(s);
			})(document,window);
		</script><script type='text/javascript' src='https://www.trustedreviews.com/wp-content/plugins/keystone-apester/dist/js/apester.min.js?ver=1.1.14'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var keystoneJWPlayerConfig = {"viewplay":"desktop","viewplay_sticky_tabswitch":"0","sticky":"1","sticky_position":"right","mute":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.trustedreviews.com/wp-content/plugins/keystone-jwplayer/assets/js/main.js?ver=1.0.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var keystoneTaboolaConfig = {"lazyload":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.trustedreviews.com/wp-content/plugins/keystone-taboola/assets/js/taboola.js?ver=0.0.1'></script>
<script type='text/javascript' src='https://www.trustedreviews.com/wp-content/themes/kiara-child-theme/dist/js/main.min.js?ver=1593005666'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var keystone_newsletter = {"form_url":"https:\/\/ti-media.slgnt.eu\/renderers\/xml.ashx?ID=nLUnUG6KOH7JVtNut_mqr75CzNVCbo18YbNezlFBjHW9kR%2B98Rc6r4aNyu50jiA2PGhvykw1_OhnBfMVr5&NEWSLETTER_CODE=YTR-X&BRAND_CODE=YTR&SOURCE_CODE=RRL"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.trustedreviews.com/wp-content/plugins/keystone-newsletter/widget/../dist/js/newsletter.min.js?ver=1593005665'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var frontEndAjax = {"ajaxurl":"https:\/\/www.trustedreviews.com\/wp-admin\/admin-ajax.php","nonce":"0a52ed4ba7"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.trustedreviews.com/wp-content/plugins/keystone-newsletter/widget/../dist/js/recaptcha.min.js?ver=1593005665'></script>
<script type='text/javascript' src='https://www.trustedreviews.com/wp-includes/js/wp-embed.min.js?ver=NS4zLjI'></script>
		<script>
			(function(){
				var n='scr'+'ipt',p=document.getElementsByTagName(n)[0],s=document.createElement(n);
				s.async=true;
				s.src='https://ksassets.timeincuk.net/tenant/1.0.74/tenant.min.js'
				p.parentNode.insertBefore(s,p);
			})();
			var googletag = googletag || {};
			googletag.cmd = googletag.cmd || [];
			window.tenantGetterQueue = window.tenantGetterQueue || [];
			window.tenantSetterQueue = window.tenantSetterQueue || [];
		</script>
		<div id="dfpad-overlay" class="ipc-advert"></div><div id="gumgum" class="ipc-advert"></div><div id="sovrn" class="ipc-advert"></div><div id="instream" class="ipc-advert"></div>
	
</div><!-- /wrapper -->

	NAV BUG FIX<div class="textwidget custom-html-widget"><script>
	setTimeout(function(){
		navigation.resizeNav();
	},2000);
</script></div>

</body>

</html>
