	<!doctype html>
<html lang="en-US" prefix="og: http://ogp.me/ns#" class="no-js">
<head>
    <meta charset="UTF-8" /><script type="text/javascript">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</script>
    <meta name="viewport" content="width=device-width, initial-scale=1.0" />

    <link rel="preconnect" href="https://ksassets.timeincuk.net" crossorigin>
<link rel="preconnect" href="https://keyassets-p2.timeincuk.net" crossorigin>
<link rel="preconnect" href="https://assets.ti-media.net/" crossorigin>
<link rel="preconnect" href="https://adservice.google.co.uk" crossorigin>
<link rel="preconnect" href="https://googleads.g.doubleclick.net" crossorigin>
<link rel="preconnect" href="https://www.google-analytics.com" crossorigin>
<link rel="preconnect" href="https://adservice.google.com" crossorigin>
<link rel="preconnect" href="https://tpc.googlesyndication.com" crossorigin>
<link rel="preconnect" href="https://www.googleadservices.com" crossorigin>
<link rel="preconnect" href="https://googletagservices.com" crossorigin>
<link rel="preconnect" href="https://securepubads.g.doubleclick.net" crossorigin>
<link rel="preconnect" href="https://widget.eagleapi.io" crossorigin>
<link rel="preconnect" href="https://mobiles.eagleapi.io" crossorigin>
<link rel="preconnect" href="https://fashion-widget.eagleapi.io" crossorigin>
<link rel="preconnect" href="https://public.eagleapi.io" crossorigin>
<link rel="preconnect" href="https://content.jwplatform.com" crossorigin>
<link rel="preconnect" href="https://jwpltx.com" crossorigin>
<link rel="preconnect" href="https://ssl.p.jwpcdn.com" crossorigin>
<link rel="preconnect" href="https://cdn.taboola.com" crossorigin>
<link rel="preconnect" href="https://trc.taboola.com" crossorigin>


    		<!-- TI performance tracking -->
		<script>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</script>
		<!-- End TI performance tracking --><title>Acer ConceptD range explained: Prices, release dates, features</title>
<style>
@font-face {
	font-family: "keystone";
	font-weight: normal;
	font-style: normal;
	font-display: fallback;
	src:	url("//www.trustedreviews.com/wp-content/themes/simba-theme/assets/fonts/standard.woff2?v=1554811304") format("woff2"),
	url("//www.trustedreviews.com/wp-content/themes/simba-theme/assets/fonts/standard.woff?v=1554811304") format("woff");
}
.icon-spinner {
	background-image: url("//www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/spinner.gif");
}

</style>		<script type="text/javascript">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</script>
<meta name="description" content="The Acer ConceptD range is a new family of computers aimed solely at creatives, with flippable laptop screens and a wooden-finish desktop"/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="https://www.trustedreviews.com/news/acer-conceptd-price-release-date-3694273" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Acer ConceptD range explained: Prices, release dates, features" />
<meta property="og:description" content="The Acer ConceptD range is a new family of computers aimed solely at creatives, with flippable laptop screens and a wooden-finish desktop" />
<meta property="og:url" content="https://www.trustedreviews.com/news/acer-conceptd-price-release-date-3694273" />
<meta property="og:site_name" content="Trusted Reviews" />
<meta property="article:publisher" content="https://www.facebook.com/TrustedReviews/" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2019-04-11T20:26:09+01:00" />
<meta property="article:modified_time" content="2019-04-11T20:36:54+01:00" />
<meta property="og:updated_time" content="2019-04-11T20:36:54+01:00" />
<meta property="og:image" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD_Family_01-e1555010159153.jpg" />
<meta property="og:image:width" content="4800" />
<meta property="og:image:height" content="3204" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The Acer ConceptD range is a new family of computers aimed solely at creatives, with flippable laptop screens and a wooden-finish desktop" />
<meta name="twitter:title" content="Acer ConceptD range explained: Prices, release dates, features" />
<meta name="twitter:site" content="@trustedreviews" />
<meta name="twitter:image" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD_Family_01-e1555010159153.jpg" />
<meta name="twitter:creator" content="@RyanAJ13" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//widget.eagleapi.io' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Trusted Reviews &raquo; Feed" href="https://www.trustedreviews.com/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.trustedreviews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=NC45Ljc"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='ks-jwplayer-css-css'  href='https://www.trustedreviews.com/wp-content/plugins/keystone-jwplayer/assets/css/main.css?ver=1.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='keystone-premium-css'  href='https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/css/sites/54.min.css?ver=1554811304' type='text/css' media='all' />
<script type='text/javascript' src='https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/js/jquery-3.3.1.min.js?ver=3.3.1'></script>
<link rel='https://api.w.org/' href='https://www.trustedreviews.com/wp-json/' />
<link rel='shortlink' href='https://www.trustedreviews.com/?p=3694273' />
<link rel="alternate" type="application/json+oembed" href="https://www.trustedreviews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.trustedreviews.com%2Fnews%2Facer-conceptd-price-release-date-3694273" />
<link rel="alternate" type="text/xml+oembed" href="https://www.trustedreviews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.trustedreviews.com%2Fnews%2Facer-conceptd-price-release-date-3694273&#038;format=xml" />
<meta name="eagle_website" content="trusted-reviews">
<meta name="eagle_env" content="production">
<meta name="eagle_version" content="2.25.26">
<meta name="eagle_uid" content="post-3694273">
<meta name="eagle_category" content="laptops">
<meta name="eagle_model" content="">
<meta name="eagle_brand" content="Acer">
<meta name="eagle_price" content="{&quot;GBP&quot;:&quot;&quot;}">
<meta name="eagle_page_type" content="post">
<meta name="eagle_content_id" content="3694273">
<meta name="eagle_page_date" content="1555014369">
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"NewsArticle","headline":"Acer ConceptD range explained: Prices, release dates, features","url":"https:\/\/www.trustedreviews.com\/news\/acer-conceptd-price-release-date-3694273","thumbnailUrl":"https:\/\/ksassets.timeincuk.net\/wp\/uploads\/sites\/54\/2019\/04\/ConceptD_Family_01-e1555010159153.jpg","image":"https:\/\/ksassets.timeincuk.net\/wp\/uploads\/sites\/54\/2019\/04\/ConceptD_Family_01-e1555010159153.jpg","dateCreated":"2019-04-11T20:26:09+00:00","datePublished":"2019-04-11T20:26:09+00:00","dateModified":"2019-04-11T20:36:54+00:00","articleSection":"News","creator":{"@type":"Person","name":"Ryan Jones"},"author":{"@type":"Person","name":"Ryan Jones"},"publisher":{"@type":"Organization","name":"Trusted Reviews","logo":{"@type":"http:\/\/schema.org\/ImageObject","url":"https:\/\/ksassets.timeincuk.net\/wp\/uploads\/sites\/54\/2017\/07\/trusted-reviews-logo-stacked-google.png"}},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/www.trustedreviews.com\/news\/acer-conceptd-price-release-date-3694273"},"keywords":["News","Acer","Computing","Desktop PC","Laptop"]}</script>
<meta property="fb:pages" content="38275114220" />		<script type="text/javascript" charset="utf-8">
		(function(a,b,c,d){
		    var protocol = "https://";
		    a="assets.ti-media.net/js/e1512726446_2a23693/min/gtm/utils-min.js";
		    b=document;c='script';d=b.createElement(c);d.src=protocol+a;d.async=true;d.type='text/java'+c;
		    a=b.getElementsByTagName(c)[0];a.parentNode.insertBefore(d,a);
		 })();
		</script>
	      <!-- Google Tag Manager -->
      <script>(function ( w, d, s, l, i ) {
          w[ l ] = w[ l ] || [];
          w[ l ].push({
            'gtm.start' :
              new Date().getTime(), event : 'gtm.js'
          });
          var f = d.getElementsByTagName(s)[ 0 ],
            j = d.createElement(s), dl = l != 'dataLayer' ? '&l=' + l : '';
          j.async = true;
          j.src =
            'https://www.googletagmanager.com/gtm.js?id=' + i + dl;
          f.parentNode.insertBefore(j, f);
        })(window, document, 'script', 'dataLayer','GTM-PHQNFGV');</script>
      <!-- End Google Tag Manager -->
      <link rel="amphtml" href="https://www.trustedreviews.com/news/acer-conceptd-price-release-date-3694273/amp"><link rel="icon" href="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/cropped-trusted-reviews-icon-3-32x32.png" sizes="32x32" />
<link rel="icon" href="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/cropped-trusted-reviews-icon-3-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/cropped-trusted-reviews-icon-3-180x180.png" />
<meta name="msapplication-TileImage" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/cropped-trusted-reviews-icon-3-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			p.sub-heading {
	margin-bottom: 1.3em;
	margin-top: -0.5em;
}

@media (min-width: 45.5em) {
	.single-sidebar:not(.single-sidebar--pqw) .ad-sticky:nth-last-child(1){
		height: 1200px;
	}

	.keystone-premium-skin.archive .single-sidebar .ad-sticky,
	.keystone-premium-inskin.archive .single-sidebar .ad-sticky,
	.keystone-premium-sizmek.archive .single-sidebar .ad-sticky{
		height: 900px !important;
	}
	
	.roundup__score {
		float: left;
	}
}

.ad-container {
	pointer-events: unset;
}

@media (max-width: 45.49em) {
	#post-inline-1 {
		display: none !important;
	}
}		</style>
	    			</head>

<body class="post-template-default single single-post postid-3694273 single-format-standard has-adverts y2019 m04 d11 h20 acer-conceptd-price-release-date standard slim-header">

<div class="header-advert-wrapper">
	<aside class="row advert header-advert sticky-anchor is-absolute">
		<div class="section-content">
			<div id="header-1" class="ipc-advert"></div>		</div>
	</aside>
</div>

<div class="parallax-wrapper parallax-wrapper--header"></div>

      <!-- Google Tag Manager (noscript) -->
      <noscript>
        <iframe
            src="https://www.googletagmanager.com/ns.html?id=GTM-PHQNFGV"
            height="0" width="0"
            style="display:none;visibility:hidden"></iframe>
      </noscript>
      <!-- End Google Tag Manager (noscript) -->
      
<div id="wrapper" class="hfeed">

			<header id="header" role="banner" class="header s-container has-single-tier">

	<div class="header__inner">

					<div itemscope itemtype="http://schema.org/Organization" class="logo header-slot header-slot-">
    <a itemprop="url" href="/" title="Trusted Reviews">
    	<span class="hide">Link to home</span>
		<picture>
			<source media="(min-width: 728px)" srcset="https://ksassets.timeincuk.net/wp/uploads/sites/54/2018/10/tr-logo-large-1.png" >
			<source media="(max-width: 727px)" srcset="https://ksassets.timeincuk.net/wp/uploads/sites/54/2018/10/tr-logo-small.png" >
	  		<img src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2018/10/tr-logo-large-1.png" alt="hero profile" itemprop="logo" aria-hidden="true" data-pin-nopin="true">
		</picture>
    </a>
</div>		
	</div>

		<nav>
	<ul class="navigation hide-overflow-items" data-nav="closed">
					<li class="has-subnav">
				<a href="https://www.trustedreviews.com/"    title="Home Page"  >Home</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="/reviews"    >All Reviews</a>
															</li>
													<li >
								<a href="/category/news"    >All News</a>
															</li>
													<li >
								<a href="/guide"    >All Buying Guides</a>
															</li>
													<li >
								<a href="/category/opinion"    >All Opinions</a>
															</li>
													<li >
								<a href="/category/deals"    >All Deals</a>
															</li>
													<li >
								<a href="/latest-articles"    >100 Latest Articles</a>
															</li>
													<li >
								<a href="http://comps.trustedreviews.com"    >Win</a>
															</li>
											</ul>
							</li>
					<li class="has-subnav">
				<a href="/reviews"    >Reviews</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="/reviews/tvs-audio"    >TV and Audio Reviews</a>
															</li>
													<li >
								<a href="/reviews/digital-cameras"    >Camera Reviews</a>
															</li>
													<li >
								<a href="/reviews/computing"    >Computing Reviews</a>
															</li>
													<li >
								<a href="/reviews/mobile"    >Mobile Reviews</a>
															</li>
													<li >
								<a href="/reviews/home-appliances"    >Home Appliance Reviews</a>
															</li>
													<li >
								<a href="/reviews/gaming"    >Gaming Reviews</a>
															</li>
											</ul>
							</li>
					<li class="has-subnav">
				<a href="https://www.trustedreviews.com/tvs-audio"    >TV / Audio</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="https://www.trustedreviews.com/type/blu-ray-players"    >Blu-ray Player</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/dvrs-and-media-players"    >DVRs and Media Player</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/gadgets"    >Gadgets</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/headphones"    >Headphones</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/hi-fi-wireless-audio"    >Hi-Fi and Wireless Audio</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/portable-audio"    >Portable Audio</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/projectors"    >Projector</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/sound-bars"    >Sound Bar</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/surround-sound-systems"    >Surround Sound System</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/tvs"    >TV</a>
															</li>
											</ul>
							</li>
					<li class="has-subnav">
				<a href="https://www.trustedreviews.com/cameras"    >Cameras</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="https://www.trustedreviews.com/type/camcorders"    >Camcorder</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/camera-accessories"    >Camera Accessory</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/camera-lenses"    >Camera Lens</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/digital-cameras"    >Camera</a>
															</li>
											</ul>
							</li>
					<li class="has-subnav">
				<a href="https://www.trustedreviews.com/computing"    >Computing</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="https://www.trustedreviews.com/type/desktop-pcs"    >Desktop PC</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/internet"    >Internet, VPNs and Web Software</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/laptops"    >Laptop</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/monitors"    >Monitor</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/pc-components"    >PC Component</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/peripherals"    >Peripheral</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/printers"    >Printer</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/routers-networking"    >Routers and Networking</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/software"    >Software</a>
															</li>
											</ul>
							</li>
					<li class="has-subnav">
				<a href="https://www.trustedreviews.com/mobile"    >Mobile</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="https://www.trustedreviews.com/type/gps-sat-nav"    >GPS and Sat Nav</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/mobile-apps"    >Mobile App</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/mobile-phone-accessories"    >Mobile Phone Accessory</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/mobile-phones"    >Mobile Phone</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/tablets"    >Tablet</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/wearables-fitness"    >Wearables and Fitness</a>
															</li>
											</ul>
							</li>
					<li class="has-subnav">
				<a href="https://www.trustedreviews.com/home-appliances"    >Home Tech</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="https://www.trustedreviews.com/type/blender"    >Blender</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/coffee-machines"    >Coffee Machine</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/cooker"    >Cooker</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/dishwashers"    >Dishwasher</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/fans"    >Fan</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/freezers"    >Freezer</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/fridges"    >Fridge</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/fridge-freezers"    >Fridge Freezer</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/garden-tools"    >Garden Tool</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/iron"    >Iron</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/kettles"    >Kettle</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/kitchen-gadgets"    >Kitchen Gadget</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/microwave"    >Microwave</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/mixers"    >Mixer</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/ovens"    >Oven</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/personal-care"    >Personal Care</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/smart-home"    >Smart Home</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/steam-cleaners"    >Steam Cleaner</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/toasters"    >Toaster</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/tumble-dryers"    >Tumble Dryer</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/vacuum-cleaners"    >Vacuum Cleaner</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/washer-dryers"    >Washer Dryer</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/washing-machines"    >Washing Machine</a>
															</li>
											</ul>
							</li>
					<li class="has-subnav">
				<a href="https://www.trustedreviews.com/gaming"    >Games</a>
									<span class="submenu-toggle icon-arrow-down"></span>
					<ul class="navigation-secondary">
													<li >
								<a href="https://www.trustedreviews.com/type/games"    >Video Game</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/games-accessories"    >Video Game Accessory</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/nintendo"    >Nintendo</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/pc"    >PC Gaming</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/playstation"    >PlayStation</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/toys"    >Toy</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/vr"    >VR</a>
															</li>
													<li >
								<a href="https://www.trustedreviews.com/type/xbox"    >Xbox</a>
															</li>
											</ul>
							</li>
					<li >
				<a href="https://www.trustedreviews.com/category/best"    >The Best List</a>
							</li>
					<li >
				<a href="https://discountcodes.trustedreviews.com"    >Discount Codes</a>
							</li>
		
		
					<li class="has-subnav header-slot-right nav-follow">
				<span class="submenu-toggle icon-arrow-down"></span>
				<a href="javascript:void(0);">Follow</a>
				<ul class="nav-social">
											<li><a href="https://www.facebook.com/pages/TrustedReviews/38275114220?ref=ts" target="_blank" rel="noopener">Facebook</a></li>
											<li><a href="https://twitter.com/trustedreviews" target="_blank" rel="noopener">Twitter</a></li>
											<li><a href="https://www.youtube.com/user/TrustedReviews" target="_blank" rel="noopener">YouTube</a></li>
											<li><a href="https://www.trustedreviews.com/rss-feeds" target="_blank" rel="noopener">Follow Trusted Reviews via RSS</a></li>
									</ul>
			</li>
		
		<li class="menu-more has-subnav">
			<a href="javascript:void(0)">More <span class="icon-plus"></span></a>
			<ul></ul>
		</li>
	</ul>

	<a href="javascript:void(0)" class="search-site icon-search"><span class="hide">Search</span></a>

	<a href="#" class="menu-icon-link hidden-md hidden-lg">
		<span class="menu-toggle icon-menu"><span class="hide">Menu</span></span>
	</a>

	<form role="search" method="get" class="search-form form-inline s-container" action="/">
		<div class="input-group">
			<label for="s" class="">Search</label>
			<input type="search" value="" name="s" class="input-sm search-field form-control" placeholder="Search">
							<button type="submit" class="btn btn--sm" name="search">Search</button>
						<div class="message-wrapper">
				<div class="message message--type">Type to search</div>
				<div class="message message--search hide">Press enter or click on the search icon</div>
			</div>
		</div>
	</form>
</nav>

</header>	
	<div id="content" role="main" class="container-fluid" >
								<div class="trending">
	<div class="s-container trending__inner">
		<div class="s-container__inner">
			<div class="trending__title">Trending:</div>
				<div class="trending-list__outer">
					<ul class="trending-list__inner">
													<li><a href="https://www.trustedreviews.com/reviews/galaxy-s10-2"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3641029"    >Galaxy S10</a></li>
													<li><a href="https://www.trustedreviews.com/reviews/huawei-mate-x"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3628349"    >Huawei Mate X</a></li>
													<li><a href="https://www.trustedreviews.com/reviews/honor-10-lite"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3628351"    >Honor 10 Lite</a></li>
													<li><a href="https://www.trustedreviews.com/reviews/moto-g7"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3628352"    >Moto G7</a></li>
													<li><a href="https://www.trustedreviews.com/reviews/huawei-p30"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3630715"    >Huawei P30</a></li>
													<li><a href="https://www.trustedreviews.com/best/best-smartphone-3431175"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3630717"    >Best Phones 2019</a></li>
													<li><a href="https://www.trustedreviews.com/reviews/iphone-xr"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3628346"    >iPhone XR review</a></li>
													<li><a href="https://www.trustedreviews.com/reviews/sony-xperia-10"  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3657253"    >Xperia 10</a></li>
											</ul>
			</div>
			<div class="trending__fade trending__fade--before"></div>
			<div class="trending__fade trending__fade--after"></div>
		</div>
	</div>
</div>		
			
				<article
			class="post-3694273 post type-post status-publish format-standard has-post-thumbnail hentry category-news brands-acer product_type-computing product_type-desktop-pcs product_type-laptops publication_name-trusted-reviews"
			role="article"
			itemprop=""
			itemscope itemtype="http://schema.org/Article"
	>
					<meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.trustedreviews.com/news/acer-conceptd-price-release-date-3694273" content="" />
			<div itemprop="publisher" itemscope itemtype="http://schema.org/Organization">
	<meta itemprop="name" content="Trusted Reviews" />
	<div itemprop="logo" itemscope itemtype="http://schema.org/ImageObject">
		<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2018/10/tr-logo-large-1.png" />
	</div>
</div>		
							
					<nav class="breadcrumb s-container"  role="navigation">
	<div class="s-container__inner">
		<ul xmlns:v="http://rdf.data-vocabulary.org/#">
							<li typeof="v:Breadcrumb">
					<a href="https://www.trustedreviews.com" rel="v:url" property="v:title">Home</a>
				</li>
							<li typeof="v:Breadcrumb">
					<a href="https://www.trustedreviews.com/category/news" rel="v:url" property="v:title">News</a>
				</li>
					</ul>
	</div>
</nav>		
					
		
		<div class="post-main">

							<header class="post-header post-header--article">
					<h1 class="title-primary" itemprop="headline">
													Acer ConceptD range explained: Prices, release dates, features
											</h1>

																
											<div class="post-author">
			<img
			alt="Ryan Jones"
			src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2018/09/IMG_5384-150x150.jpg"
			class="post-author--img"
			height="145"
			width="145">
		<small class="post-author-info">
					<span>
							</span>
			<span itemprop="author" itemscope itemtype="http://schema.org/Person">
				<a class="post-author__name url fn n" href="https://www.trustedreviews.com/author/ryanjones">
					<span class="author vcard" itemprop="name">Ryan Jones</span>
			    </a>
			</span>
		
		<span>
			<time datetime="2019-04-11T20:36:54+00:00">April 11, 2019 8:36 pm GMT+0000</time>
			<meta itemprop="datePublished" content="2019-04-11T20:26:09+00:00"/>			<meta itemprop="dateModified" content="2019-04-11T20:36:54+00:00"/>		</span>
	</small>
</div>					
											<div class="social-share">
										<ul class="pw-widget hidden-xs">
							<li>
					<a
							href="https://www.facebook.com/sharer/sharer.php?u=https://www.trustedreviews.com/news/acer-conceptd-price-release-date-3694273"
							target="_blank"
							 rel="noopener" 							class="share-button pw-button-facebook icon-social-facebook "
							data-url="https://www.trustedreviews.com/news/acer-conceptd-price-release-date-3694273"
					></a>
				</li>
							<li>
					<a
							href="https://twitter.com/intent/tweet?url=https://www.trustedreviews.com/news/acer-conceptd-price-release-date-3694273&text=Acer ConceptD range explained: Prices, release dates, features"
							target="_blank"
							 rel="noopener" 							class="share-button pw-button-twitter icon-social-twitter "
							data-url="https://www.trustedreviews.com/news/acer-conceptd-price-release-date-3694273"
					></a>
				</li>
							<li>
					<a
							href="http://pinterest.com/pin/create/button/?url=https://www.trustedreviews.com/news/acer-conceptd-price-release-date-3694273&description=Acer ConceptD range explained: Prices, release dates, features"
							target="_blank"
							 rel="noopener" 							class="share-button pw-button-pinterest icon-social-pinterest "
							data-url="https://www.trustedreviews.com/news/acer-conceptd-price-release-date-3694273"
					></a>
				</li>
								</ul>
										<ul class="pw-widget hidden-sm hidden-md hidden-lg">
							<li>
					<a
							href="https://www.facebook.com/sharer/sharer.php?u=https://www.trustedreviews.com/news/acer-conceptd-price-release-date-3694273"
							target="_blank"
							 rel="noopener" 							class="share-button pw-button-facebook icon-social-facebook "
							data-url="https://www.trustedreviews.com/news/acer-conceptd-price-release-date-3694273"
					></a>
				</li>
							<li>
					<a
							href="https://twitter.com/intent/tweet?url=https://www.trustedreviews.com/news/acer-conceptd-price-release-date-3694273&text=Acer ConceptD range explained: Prices, release dates, features"
							target="_blank"
							 rel="noopener" 							class="share-button pw-button-twitter icon-social-twitter "
							data-url="https://www.trustedreviews.com/news/acer-conceptd-price-release-date-3694273"
					></a>
				</li>
							<li>
					<a
							href="http://pinterest.com/pin/create/button/?url=https://www.trustedreviews.com/news/acer-conceptd-price-release-date-3694273&description=Acer ConceptD range explained: Prices, release dates, features"
							target="_blank"
							 rel="noopener" 							class="share-button pw-button-pinterest icon-social-pinterest "
							data-url="https://www.trustedreviews.com/news/acer-conceptd-price-release-date-3694273"
					></a>
				</li>
								</ul>
	</div>
					
					
											<div class="post__award">
	
	
	</div>									</header>
			
			
			<div class="post-main__inner">

				
				                    							<div class="featured-media">
		<div id="attachment_3694301"
     class="featured-image"
     itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
>
	<figure class="image">
		<img src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/trusted-reviews-placeholder-3.svg"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD_Family_01-e1555010159153-920x614.jpg"
     data-id="3694301"
     data-sizes="auto"
     class=" lazyload blur-up"
     alt="Acer ConceptD"
     width="920"
	 height="614"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD_Family_01-e1555010159153-320x214.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD_Family_01-e1555010159153-620x414.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD_Family_01-e1555010159153-920x614.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD_Family_01-e1555010159153-1220x814.jpg 1220w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD_Family_01-e1555010159153-1620x1081.jpg 1620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD_Family_01-e1555010159153-1920x1282.jpg 1920w,
	"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD_Family_01-e1555010159153-920x614.jpg">
<meta itemprop="width" content="920">
<meta itemprop="height" content="614">			</figure>
</div>
	</div>
									
				
				<div class="post-body">

					<div class="articleBody" itemprop="articleBody">
																			
																			
																																		
													<p><strong>Acer has revealed an all-new brand called Acer ConceptD, which will offer up a lineup of premium devices aimed specifically at creatives. </strong></p>
<p><span style="font-weight: 400">From a quirky laptop design with a flippable screen to a heavyweight desktop boasting a ridiculous amount of power, Acer’s new innovative lineup of computers look seriously tasty. </span></p>
<p><div class="ad-container ad-container--mobile"><div id="post-inline-1" class="ipc-advert"></div></div></p>
<p><span style="font-weight: 400">We’ve rounded up all of the upcoming Acer ConceptD devices here so you can have a good gander at every single one. Check back at Trusted Reviews for the impending hands-on articles too. </span></p>
<p><strong>Related: <a href="https://www.trustedreviews.com/news/acer-2019-showcase-livestream-3694192">Acer 2019 showcase</a></strong></p>
<p><img class="lazyload blur-up alignnone wp-image-3694277 size-large" src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/trusted-reviews-placeholder-3.svg" data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-9-1-e1555009118894-1024x683.jpg" alt="Acer ConceptD 9" width="1024" height="683" data-sizes="auto" data-srcset="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-9-1-e1555009118894-1024x683.jpg 1024w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-9-1-e1555009118894-300x200.jpg 300w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-9-1-e1555009118894-768x513.jpg 768w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-9-1-e1555009118894-320x214.jpg 320w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-9-1-e1555009118894-620x414.jpg 620w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-9-1-e1555009118894-920x614.jpg 920w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-9-1-e1555009118894-1220x814.jpg 1220w"  /></p>
<h2><b>Acer ConceptD 9</b></h2>
<p><span style="font-weight: 400">Acer’s most eye catching new designer laptop is no doubt the ConceptD 9. With a flippable screen, you can position the display in whatever position you fancy as you sketch and scribble on the panel with the bundled Wacom EMR stylus, which magnetically clips onto the device. </span></p>
<p><span style="font-weight: 400">It may look artsy, but this device promises serious punch, with a 9th Gen Intel Core i9 mobile processor and <a href="https://www.trustedreviews.com/reviews/nvidia-rtx-2080">Nvidia RTX 2080</a> graphics card. With such specs, the Acer ConceptD 9 should easily sail through multimedia tasks like 3D rendering and video editing. </span></p>
<p><div class="ad-container ad-container--mobile"><div id="post-inline-2" class="ipc-advert"></div></div><section id="embed_code-2" class="hidden-md hidden-lg s-container sticky-anchor widget_embed_code premium_inline_2"><section class="s-container listing--single listing--single-sharethrough image-aspect-landscape default sharethrough-ad sharethrough-ad-hidden">
  <div class="s-container__inner">
    <ul>
      <li id="native-content-mobile" class="listing-item">
      </li>
    </ul>
  </div>
</section></section></p>
<p><span style="font-weight: 400">Acer made a big deal of its screen too, aside from its flippable design. The 17.3-inch Ultra HD screen covers 100% of the Adobe RGB color and impressive Delta E &lt;1 color accuracy. This is one the best colour accuracy figures we’ve seen from creative notebooks, supposedly thumping even the <a href="https://www.trustedreviews.com/reviews/macbook-pro-13-inch">Apple MacBook Pro 2018</a>. </span></p>
<p><span style="font-weight: 400">The Acer ConceptD 9 will be available from </span><span style="font-weight: 400">€</span><span style="font-weight: 400">4999 in Europe in August. There’s sadly no word on UK pricing yet, but Americans will be able to bag one in June for $4999.</span></p>
<p><strong>Related: <a href="https://www.trustedreviews.com/news/acer-predator-helios-700-3694247">Acer Predator Helios 700</a></strong></p>
<p><img class="lazyload blur-up alignnone wp-image-3694283 size-large" src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/trusted-reviews-placeholder-3.svg" data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-7-6-e1555009191199-1024x683.jpg" alt="Acer ConceptD 7" width="1024" height="683" data-sizes="auto" data-srcset="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-7-6-e1555009191199-1024x683.jpg 1024w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-7-6-e1555009191199-300x200.jpg 300w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-7-6-e1555009191199-768x513.jpg 768w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-7-6-e1555009191199-320x214.jpg 320w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-7-6-e1555009191199-620x414.jpg 620w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-7-6-e1555009191199-920x614.jpg 920w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-7-6-e1555009191199-1220x814.jpg 1220w"  /></p>
<h2><b>Acer ConceptD 7</b></h2>
<p><span style="font-weight: 400">The Acer ConceptD 7 may lack the flippable screen seen with ConceptD 9, but it’s still looks a very impressive notebook with a 9th Generation Intel Core i7 processor and Nvidia RTX graphics card – with the option of RTX 2080 with Max-Q design or <a href="https://www.trustedreviews.com/reviews/nvidia-rtx-2060">RTX 2060</a>. These flashy components should mean the ConceptD 7 should easily provide a big enough performance to satisfy even the most demanding creatives. </span></p>
<div class="ad-container ad-container--mobile"><div id="post-inline-3" class="ipc-advert"></div></div>
<p><span style="font-weight: 400">The 15.6-inch Ultra HD IPS display looks equally as impressive, also boasting a 100% Adobe RGB color gamut coverage for a massive range of eye-popping colours. The colour accuracy of Delta E &lt;2 may not be as impressive as what’s found with the ConceptD 9, but it still looks to be among the best with creative notebooks. </span></p>
<p><span style="font-weight: 400">The ConceptD 7 may just look like a typical notebook, but its design is nothing to sniff at. It’s incredibly thin despite its meaty components at just 17.9mm. It’s also relatively light, weighing in at 2.1kg which is far lighter than most laptops rocking such high-end specs. This laptop is also spoiled for ports, with Thunderbolt 3 and Mini DisplayPorts so you connect up to three external displays. </span></p>
<p><span style="font-weight: 400">Launching in Europe in July, the </span><span style="font-weight: 400">ConceptD 7 will cost €2299 – UK prices are yet to be announced. The ConceptD 7 will arrive in North America in April with a a starting $2299 price.</span></p>
<p><strong>Related: <a href="https://www.trustedreviews.com/best/best-laptops-3431966">Best Laptops 2019</a></strong></p>
<div class="ad-container ad-container--mobile"><div id="post-inline-4" class="ipc-advert"></div></div>
<p><img class="lazyload blur-up alignnone wp-image-3694285 size-large" src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/trusted-reviews-placeholder-3.svg" data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD-5_CN515-51_05-e1555009343361-1024x683.jpg" alt="Acer ConceptD 5" width="1024" height="683" data-sizes="auto" data-srcset="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD-5_CN515-51_05-e1555009343361-1024x683.jpg 1024w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD-5_CN515-51_05-e1555009343361-300x200.jpg 300w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD-5_CN515-51_05-e1555009343361-768x512.jpg 768w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD-5_CN515-51_05-e1555009343361-320x213.jpg 320w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD-5_CN515-51_05-e1555009343361-620x413.jpg 620w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD-5_CN515-51_05-e1555009343361-920x613.jpg 920w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD-5_CN515-51_05-e1555009343361-1220x813.jpg 1220w"  /></p>
<h2><b>Acer ConceptD 5</b></h2>
<p><span style="font-weight: 400">The most affordable of Acer’s new creative-focussed notebooks, the Acer ConceptD 5 still offers fantastic specs with 8th Generation Intel Core i7-8705G and i5-8305G processor options. The AMD Radeon RX Vega M GL makes up the GPU option, which should be powerful enough to prop up design and multimedia work. 16GB of RAM further ensures a slick performance, while 1TB of SSD storage means you’ll have plenty of space for all your artwork. </span></p>
<p><span style="font-weight: 400">Even with the lower price, the ConceptD 5 still boasts a 15.6-inch 4K IPS display with an ultra-thin bezel. A 100% Adobe RGB color gamut and Delta E &lt;2 colour accuracy mean that colours should look very distinct on screen, while also accurately presenting images how they look in reality. </span></p>
<p><span style="font-weight: 400">Weighing in at 1.5kg, this is an incredibly lightweight designer laptop. It’s really thin too, measuring just 16.9mm. The metal chassis and magnesium-aluminium alloy lid should also contribute to a premium feel. Ports are plentiful again, with USB Type-C Gen 1 and DisplayPort featuring on the sides. There’s even an fingerprint reader for tight security. </span></p>
<div class="ad-container ad-container--mobile"><div id="post-inline-5" class="ipc-advert"></div></div>
<p><span style="font-weight: 400">The ConceptD 5 will be available from July in Europe, retailing at </span><span style="font-weight: 400">€1699. Acer has not yet provided UK prices, but we’ll update the article once we hear more. For North America, the ConceptD 5 will be on shelves in April with a starting price of $1699.</span></p>
<p><img class="lazyload blur-up alignnone wp-image-3694292 size-large" src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/trusted-reviews-placeholder-3.svg" data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD-900-5-731x1024.png" alt="ConceptD 900" width="731" height="1024" data-sizes="auto" data-srcset="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD-900-5-731x1024.png 731w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD-900-5-214x300.png 214w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD-900-5-768x1075.png 768w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD-900-5-229x320.png 229w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD-900-5-443x620.png 443w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD-900-5-657x920.png 657w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD-900-5-871x1220.png 871w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD-900-5-1157x1620.png 1157w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/ConceptD-900-5.png 1200w"  /></p>
<h2><b>ConceptD 900</b></h2>
<p><span style="font-weight: 400">Looking for a super-strong desktop computer instead of a laptop has that has the equivalent strength of an Infinity Gauntlet-wielding Thanos? Then the Acer ConceptD 900 should tickle your fancy, rocking jaw-droppingly powerful components such as the dual Intel Xeon Gold 6148 processors which have a whopping 40 cores and 80 threads. </span></p>
<p><span style="font-weight: 400">The Nvida Quadro RTX 6000 stands in as the super-charged graphics card. With such specs, this desktop should be suitable for filmmakers, animators and AI developers. If you’re looking for something for Photoshop and the like, this machine is no question overkill. </span></p>
<p><span style="font-weight: 400">Don’t worry about this meathead overheating, as the ConceptD 900 has six cooling fans to maximise airflow. It’s also a rather suave-looking system with a matte-black metal chassis and an amber LED light on the power button. </span></p>
<p><span style="font-weight: 400">Got cash to splash and fancy buying this computer? In Europe, it will cost you an eye watering </span><span style="font-weight: 400">€</span><span style="font-weight: 400">17,999 from June. There’s no word on UK pricing just yet. In America, the price will start at $19,999 once available in May.</span></p>
<p><strong>Related: <a href="https://www.trustedreviews.com/best/best-intel-processor-3517396">Best Intel processor</a></strong></p>
<p><img class="lazyload blur-up alignnone wp-image-3694299 size-large" src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/trusted-reviews-placeholder-3.svg" data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-500-3-1024x819.jpg" alt="" width="1024" height="819" data-sizes="auto" data-srcset="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-500-3-1024x819.jpg 1024w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-500-3-300x240.jpg 300w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-500-3-768x614.jpg 768w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-500-3-320x256.jpg 320w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-500-3-620x496.jpg 620w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-500-3-920x736.jpg 920w, https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Acer-ConceptD-500-3-1220x976.jpg 1220w"  /></p>
<h2><b>Acer ConceptD 500</b></h2>
<p><span style="font-weight: 400">If the previous desktop is too expensive for you (which is almost definitely the case) the Acer ConceptD 500 is a significantly more affordable alternative. It’s still powerful enough for filmmakers, animators, product designers though, with a 9th Gen <a href="https://www.trustedreviews.com/reviews/intel-core-i9-9900k">Intel Core i9-9900K</a> processor and Nvidia Quadro RTX 4000 GPUs allowing support for four 5K displays simultaneously.</span></p>
<p><span style="font-weight: 400">If you fancy more power, there are four DIMM slots for up to 64GB 2666 MHz DDR4 memory. The PCIe M.2 NVMe SSD meanwhile also helps to cope with heavy workloads. Three cooling fans are tasked with the job with preventing the machine from combusting, yet remain relatively quiet at 40 decibels. </span></p>
<p><span style="font-weight: 400">It’s not just the specs that makes this desktop ‘designer’. The top of the computer features a wooden finish that’s clearly angling for the cover of a fashion magazine. This wooden panel even allows for wireless charging with Qi-compatible devices, making it the perfect companion for the <a href="https://www.trustedreviews.com/reviews/galaxy-s10-2">Samsung Galaxy S10</a>. </span></p>
<div class="injection"><section id="keystone-voep-widget-3" class=" s-container sticky-anchor hide-widget-title keystone-voep-widget premium_inline_before_last_p post-promo">
<div class="jwplayer-container jwplayer-margin-bottom">
<div class="jwplayer-wrapper">
<div class="jwplayer-minimize-close">
				<svg xmlns="http://www.w3.org/2000/svg" class="jw-svg-icon jw-svg-icon-close" viewBox="0 0 240 240" focusable="false">
					<path d="M134.8,120l48.6-48.6c2-1.9,2.1-5.2,0.2-7.2c0,0-0.1-0.1-0.2-0.2l-7.4-7.4c-1.9-2-5.2-2.1-7.2-0.2c0,0-0.1,0.1-0.2,0.2L120,105.2L71.4,56.6c-1.9-2-5.2-2.1-7.2-0.2c0,0-0.1,0.1-0.2,0.2L56.6,64c-2,1.9-2.1,5.2-0.2,7.2c0,0,0.1,0.1,0.2,0.2l48.6,48.7l-48.6,48.6c-2,1.9-2.1,5.2-0.2,7.2c0,0,0.1,0.1,0.2,0.2l7.4,7.4c1.9,2,5.2,2.1,7.2,0.2c0,0,0.1-0.1,0.2-0.2l48.7-48.6l48.6,48.6c1.9,2,5.2,2.1,7.2,0.2c0,0,0.1-0.1,0.2-0.2l7.4-7.4c2-1.9,2.1-5.2,0.2-7.2c0,0-0.1-0.1-0.2-0.2L134.8,120z"></path>
				</svg>
			</div>
<div
				data-player="Bm0Kebr4"
				data-key="6ufwitXs"
				data-loaded="false"
				class="jwplayer"
				id="jwplayer_6ufwitXs_Bm0Kebr4_91_div">
			</div>
</p></div>
</p></div>
</section></div>
<p><span style="font-weight: 400">The ConceptD 500 has a starting price of </span><span style="font-weight: 400">€2799 once it arrives in Europe in July. Acer are yet to reveal UK pricing, but we’ll update this article once we coax it out of them. We do know it will cost $1699 over in North America though once it launches in June. </span></p>
<p><strong>What do you think of Acer&#8217;s new lineup of ConceptD computers? Let us know @TrustedReviews on Twitter</strong></p>


															
																		</div>

					
																
											<div id="taboola-below-article-thumbnails"></div>									</div>
			</div>

							<div id="single-sidebar" class="single-sidebar single-sidebar--article">

	
	
		
		
		
		
	
	<div class="ad-container ad-sticky">
		
		<div id="post-side-1" class="ipc-advert"></div>		
	</div>

	<section id="keystone-query-widget-id-31" class="palette-a listing--single listing--single-b s-container image-aspect-square visible-md hidden-xs hidden-sm default keystone-query-widget premium_sidebar_1"><h2 class="widgettitle heading"><span>New reviews</span></h2><div class="sections"><div class="s-container__inner">
	<ul
		class="listing-items"
				data-post-count="4"
	>
					
			<li class="listing-item">
	 <a class="entry" href="https://www.trustedreviews.com/reviews/oculus-rift-s" title="Hands on: Oculus Rift S"> 		<article class="listing-entry">
																		<div class="entry-media">
					<div class="entry-media-inner entry-image image-crop">
						<div id="attachment_3693694"
     class="featured-image"
     itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
>
	<figure class="image-crop">
		<img src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/trusted-reviews-placeholder-3.svg"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Oculus-Rift-S-1-620x349.png"
     data-id="3693694"
     data-sizes="auto"
     class="image-sm lazyload blur-up"
     alt=""
     width="620"
	 height="349"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Oculus-Rift-S-1-320x180.png 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Oculus-Rift-S-1-620x349.png 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Oculus-Rift-S-1-920x518.png 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Oculus-Rift-S-1-1220x686.png 1220w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Oculus-Rift-S-1-1620x911.png 1620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Oculus-Rift-S-1-1920x1080.png 1920w,
	"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/Oculus-Rift-S-1-620x349.png">
<meta itemprop="width" content="620">
<meta itemprop="height" content="349">			</figure>
</div>
					</div>
				</div>
			
									
			<div class="entry-content">
									
													<h3><span>Hands on: Oculus Rift S</span></h3>
																										
					
																</div>
		</article>
	 </a> </li>
			
			
					
			<li class="listing-item">
	 <a class="entry" href="https://www.trustedreviews.com/reviews/panasonic-tz95" title="Panasonic TZ95"> 		<article class="listing-entry">
																		<div class="entry-media">
					<div class="entry-media-inner entry-image image-crop">
						<div id="attachment_3686852"
     class="featured-image"
     itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
>
	<figure class="image-crop">
		<img src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/trusted-reviews-placeholder-3.svg"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/03/panasonic_tz95_product_22-620x413.jpg"
     data-id="3686852"
     data-sizes="auto"
     class="image-sm lazyload blur-up"
     alt="Panasonic TZ95"
     width="620"
	 height="413"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/03/panasonic_tz95_product_22-320x213.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/03/panasonic_tz95_product_22-620x413.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/03/panasonic_tz95_product_22-920x613.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/03/panasonic_tz95_product_22-1220x813.jpg 1220w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/03/panasonic_tz95_product_22-1620x1080.jpg 1620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/03/panasonic_tz95_product_22-1920x1280.jpg 1920w,
	"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/03/panasonic_tz95_product_22-620x413.jpg">
<meta itemprop="width" content="620">
<meta itemprop="height" content="413">			</figure>
</div>
					</div>
				</div>
			
									
			<div class="entry-content">
									
													<h3><span>Panasonic TZ95</span></h3>
																										
					
																</div>
		</article>
	 </a> </li>
							<li id="native-content-desktop" class="listing-item sharethrough-ad sharethrough-ad-hidden ipc-advert"></li>			
			
					
			<li class="listing-item">
	 <a class="entry" href="https://www.trustedreviews.com/reviews/marshall-stanmore-ii-bluetooth" title="Marshall Stanmore II Bluetooth"> 		<article class="listing-entry">
																		<div class="entry-media">
					<div class="entry-media-inner entry-image image-crop">
						<div id="attachment_3649706"
     class="featured-image"
     itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
>
	<figure class="image-crop">
		<img src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/trusted-reviews-placeholder-3.svg"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/01/stanmore-main-620x349.jpg"
     data-id="3649706"
     data-sizes="auto"
     class="image-sm lazyload blur-up"
     alt="Marshall Stanmore II Bluetooth"
     width="620"
	 height="349"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/01/stanmore-main-320x180.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/01/stanmore-main-620x349.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/01/stanmore-main-920x518.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/01/stanmore-main-1220x686.jpg 1220w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/01/stanmore-main-1620x911.jpg 1620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/01/stanmore-main-1920x1080.jpg 1920w,
	"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/01/stanmore-main-620x349.jpg">
<meta itemprop="width" content="620">
<meta itemprop="height" content="349">			</figure>
</div>
					</div>
				</div>
			
									
			<div class="entry-content">
									
													<h3><span>Marshall Stanmore II Bluetooth</span></h3>
																										
					
																</div>
		</article>
	 </a> </li>
			
			
					
			<li class="listing-item">
	 <a class="entry" href="https://www.trustedreviews.com/reviews/samsung-galaxy-a70" title="Samsung Galaxy A70"> 		<article class="listing-entry">
																		<div class="entry-media">
					<div class="entry-media-inner entry-image image-crop">
						<div id="attachment_3693639"
     class="featured-image"
     itemprop="image" itemscope itemtype="https://schema.org/ImageObject"
>
	<figure class="image-crop">
		<img src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/trusted-reviews-placeholder-3.svg"
     data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/DSCF4823-620x413.jpg"
     data-id="3693639"
     data-sizes="auto"
     class="image-sm lazyload blur-up"
     alt="Samsung Galaxy A70"
     width="620"
	 height="413"
	 data-srcset="
			https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/DSCF4823-320x213.jpg 320w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/DSCF4823-620x413.jpg 620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/DSCF4823-920x613.jpg 920w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/DSCF4823-1220x813.jpg 1220w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/DSCF4823-1620x1080.jpg 1620w,
				https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/DSCF4823-1920x1280.jpg 1920w,
	"/>
<meta itemprop="url" content="https://ksassets.timeincuk.net/wp/uploads/sites/54/2019/04/DSCF4823-620x413.jpg">
<meta itemprop="width" content="620">
<meta itemprop="height" content="413">			</figure>
</div>
					</div>
				</div>
			
									
			<div class="entry-content">
									
													<h3><span>Samsung Galaxy A70</span></h3>
																										
					
																</div>
		</article>
	 </a> </li>
			
			
			</ul>
</div></div></section>


	
		<div class="ad-container ad-sticky">
		
			<div id="post-side-2" class="ipc-advert"></div>			
		</div>

		
	
	
		<div class="ad-container ad-sticky">
			
			<div id="post-side-3" class="ipc-advert"></div>			
		</div>
	

	
		<div class="ad-container ad-sticky">
		
			<div id="post-side-4" class="ipc-advert"></div>			
		</div>
	
	
		<div class="ad-container ad-sticky">

			<div id="post-side-5" class="ipc-advert"></div>			
		</div>
	</div>			
		</div>
	</article>
			
	</div>

			<div class="parallax-wrapper parallax-wrapper--footer sticky-anchor"></div>

<footer id="footer" role="contentinfo" class="footer sticky-anchor">
	<div class="footer__row">
		<nav class="footer__col footer__col--content">
			<ul id="menu-3" class="footer-menu footer-menu--plain">
			<li id="menu-item-3614131" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3614131">
			<a href="/info/browse-reviews-3614164"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon">
				<span class="menu-icon-item icon-no-icon">
					Find a review
				</span>
			</a>
		</li>
			<li id="menu-item-2651360" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2651360">
			<a href="/info/about-trusted-reviews-3550741"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon">
				<span class="menu-icon-item icon-no-icon">
					About TrustedReviews
				</span>
			</a>
		</li>
			<li id="menu-item-3552607" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3552607">
			<a href="/info/who-we-are-3551613"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon">
				<span class="menu-icon-item icon-no-icon">
					Contact our editorial team
				</span>
			</a>
		</li>
			<li id="menu-item-3580003" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3580003">
			<a href="https://www.trustedreviews.com/info/trusted-reviews-ethics-policy-3521647"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon">
				<span class="menu-icon-item icon-no-icon">
					Editorial ethics and how we test
				</span>
			</a>
		</li>
			<li id="menu-item-3550819" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3550819">
			<a href="https://www.ti-media.com/terms-and-conditions/#_Toc513817991"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon">
				<span class="menu-icon-item icon-no-icon">
					Labelling of commercial content
				</span>
			</a>
		</li>
			<li id="menu-item-3550821" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3550821">
			<a href="https://www.ipso.co.uk/editors-code-of-practice/"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon">
				<span class="menu-icon-item icon-no-icon">
					IPSO Editors' Code of Practice
				</span>
			</a>
		</li>
			<li id="menu-item-2651363" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2651363">
			<a href="http://www.timeincuk.com/privacy/"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon">
				<span class="menu-icon-item icon-no-icon">
					Privacy & cookie policy
				</span>
			</a>
		</li>
			<li id="menu-item-2651362" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2651362">
			<a href="http://www.timeincuk.com/terms-and-conditions/"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon">
				<span class="menu-icon-item icon-no-icon">
					Terms & Conditions
				</span>
			</a>
		</li>
			<li id="menu-item-3550818" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3550818">
			<a href="https://www.ti-media.com/terms-and-conditions/#_Toc513817985"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon">
				<span class="menu-icon-item icon-no-icon">
					Third party advertising policy
				</span>
			</a>
		</li>
			<li id="menu-item-3249531" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3249531">
			<a href="https://www.trustedreviews.com/rss-feeds"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon">
				<span class="menu-icon-item icon-no-icon">
					Follow Trusted Reviews via RSS
				</span>
			</a>
		</li>
			<li id="menu-item-3497726" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3497726">
			<a href="https://discountcodes.trustedreviews.com/"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon">
				<span class="menu-icon-item icon-no-icon">
					Discount Codes
				</span>
			</a>
		</li>
			<li id="menu-item-3550823" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3550823">
			<a href="https://comps.trustedreviews.com/?_ga=2.81825043.400893545.1535971409-812703703.1535551482"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon">
				<span class="menu-icon-item icon-no-icon">
					Competitions
				</span>
			</a>
		</li>
			<li id="menu-item-2651361" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2651361">
			<a href="http://www.timeincuk.com/advertise/"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon">
				<span class="menu-icon-item icon-no-icon">
					Advertise with us
				</span>
			</a>
		</li>
			<li id="menu-item-3525646" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3525646">
			<a href="#"  title="privacy-settings"   target="_blank" rel="noopener" class="menu-icon-item icon-social-no-icon">
				<span class="menu-icon-item icon-no-icon">
					Privacy Settings
				</span>
			</a>
		</li>
	</ul>		</nav>
		<nav class="footer__col footer__col--sidebar">
			<ul id="menu-8" class="footer-menu footer-menu--icons">
			<li id="menu-item-2651357" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2651357">
			<a href="https://www.facebook.com/pages/TrustedReviews/38275114220?ref=ts"   target="_blank" rel="noopener" class="menu-icon-item icon-social-facebook">
				<span class="menu-icon-item icon-facebook">
					Facebook
				</span>
			</a>
		</li>
			<li id="menu-item-2651356" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2651356">
			<a href="https://twitter.com/trustedreviews"   target="_blank" rel="noopener" class="menu-icon-item icon-social-twitter">
				<span class="menu-icon-item icon-twitter">
					Twitter
				</span>
			</a>
		</li>
			<li id="menu-item-2651358" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2651358">
			<a href="https://www.youtube.com/user/TrustedReviews"   target="_blank" rel="noopener" class="menu-icon-item icon-social-youtube">
				<span class="menu-icon-item icon-youtube">
					YouTube
				</span>
			</a>
		</li>
			<li id="menu-item-3249533" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3249533">
			<a href="https://www.trustedreviews.com/rss-feeds"   target="_blank" rel="noopener" class="menu-icon-item icon-social-rss">
				<span class="menu-icon-item icon-rss">
					Follow Trusted Reviews via RSS
				</span>
			</a>
		</li>
	</ul>		</nav>

		<div class="footer-legal">
			<a itemprop="url" href="" title="">
			<img 
				itemprop="logo" 
				src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/trusted-reviews-placeholder-3.svg" 
				data-src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/trusted-reviews-footer.svg" 
				class="lazyload blur-up footer-logo" 
				alt="" 
				data-pin-nopin="true">
		</a>
		<sub>&copy; Copyright TI Media Limited. All rights reserved.</sub>
	<a href="https://www.ipso.co.uk/" class="footer__ipso" target="_blank" rel="noopener">
		<img 
			src="https://ksassets.timeincuk.net/wp/uploads/sites/54/2017/07/trusted-reviews-placeholder-3.svg" 
			data-src="https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/images/ipso-dark.png" 
			class="lazyload blur-up" 
			alt="IPSO Regulated" 
			width="100%" />
	</a>
</div>
	</div>
</footer>
				<script type="text/javascript">
			(function() {
				/* Include required screen size functions right here */
				var getDisplayWidth=function(){var e=0;if(typeof window.innerWidth!="undefined"){e=window.innerWidth}else if(typeof document.documentElement!="undefined"&&typeof document.documentElement.clientWidth!="undefined"&&document.documentElement.clientWidth!=0){e=document.documentElement.clientWidth}else{e=document.getElementsByTagName("body")[0].clientWidth}return Number(e)};
				var getWindowSize = getDisplayWidth();
				window.ipcTags = window.ipcTags || {};
				/* Pageskin targeting stuff */
				if(getWindowSize >= 1350) {
					window.ipcTags['pageskin'] = 'yes';
				} else {
					window.ipcTags['pageskin'] = 'no';
				}

				
				if(getWindowSize >= 690) {
					window.ipcTags.platform = 'desktop';
				} else {
					window.ipcTags.platform = 'mobile';
				}

				
				window.ipcTags['dfp_config']['required_tags'].push('pageskin');
			})();
		</script>
		<script type='text/javascript'>
			(function(d,w){
				var s = d.createElement('script');
				w.lazySizesConfig = {'expFactor':'1'};
				s.src = 'https://www.trustedreviews.com/wp-content/plugins/keystone-images/assets/js/sizes.js?ver=0.0.1';
				d.body.appendChild(s);
			})(document,window);
		</script><script type='text/javascript' src='https://widget.eagleapi.io/js/loader.js?ver=2.25.26'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var keystoneJWPlayerConfig = {"viewplay":"desktop","viewplay_sticky_tabswitch":"0","sticky":"1","sticky_position":"right","mute":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.trustedreviews.com/wp-content/plugins/keystone-jwplayer/assets/js/main.js?ver=1.0.16'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var keystoneTaboolaConfig = {"lazyload":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.trustedreviews.com/wp-content/plugins/keystone-taboola/assets/js/taboola.js?ver=0.0.1'></script>
<script type='text/javascript' src='https://www.trustedreviews.com/wp-content/plugins/ipc-wordpress-digital-editions/public/assets/js/public.js?ver=2.2.2'></script>
<script type='text/javascript' src='https://www.trustedreviews.com/wp-content/themes/simba-theme/assets/js/scripts.min.js?ver=1554811304'></script>
<script type='text/javascript' src='https://www.trustedreviews.com/wp-content/plugins/keystone-newsletter/widget/js/widget.js?ver=1.1.3'></script>
<script type='text/javascript' src='https://www.trustedreviews.com/wp-includes/js/wp-embed.min.js?ver=NC45Ljc'></script>
		<script>
			(function(){
				var n='scr'+'ipt',p=document.getElementsByTagName(n)[0],s=document.createElement(n);
				s.async=true;
				s.src='https://ksassets.timeincuk.net/tenant/1.0.42/tenant.min.js'
				p.parentNode.insertBefore(s,p);
			})();
			var googletag = googletag || {};
			googletag.cmd = googletag.cmd || [];
			window.tenantGetterQueue = window.tenantGetterQueue || [];
			window.tenantSetterQueue = window.tenantSetterQueue || [];
		</script>
		<div id="dfpad-overlay" class="ipc-advert"></div><div id="gumgum" class="ipc-advert"></div><div id="sovrn" class="ipc-advert"></div><div id="instream" class="ipc-advert"></div>
	
</div><!-- /wrapper -->


	<script>
    	let _ks_modules = [
            'baseFunctions',
            'headerJS',
            'stickyBlocks',
            'objectFit',
            'featuredVideo',
            'sharethroughListener',
            'stickyNav',
            'multimediaGallery',
            'pqwAds',
            'userRating',
            'select2',
        ];
	</script>


	<script>
        for (let i = 0; i < _ks_modules.length; i++) {
            let module = window[_ks_modules[i]];
            if (typeof module !== 'undefined' && typeof module.init === 'function') {
                module.init();
            }
        }
	</script>


	

<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"aaccaa7fff","applicationID":"19797352,9562757,45889822","transactionName":"YgNVYEcAXhJYBUQNXFtJdldBCF8PFhVZClRZAw==","queueTime":0,"applicationTime":906,"atts":"TkRCFg8aTU0bBxJeSEgb","errorBeacon":"bam.nr-data.net","agent":""}</script></body>

</html>
