NetGear RangeMax NEXT DG834N pictures

1 of 8 pictures

Hover to zoom

NetGear RangeMax NEXT DG834N
NetGear RangeMax NEXT DG834N

8 Pictures - NetGear RangeMax NEXT DG834N

Enlarge
  • NetGear RangeMax NEXT DG834N
  • NetGear RangeMax NEXT DG834N
  • NetGear RangeMax NEXT DG834N
  • NetGear RangeMax NEXT DG834N
  • NetGear RangeMax NEXT DG834N
  • NetGear RangeMax NEXT DG834N
  • NetGear RangeMax NEXT DG834N
  • RangeMax DG834N Wireless Router (4 LAN, 1 WAN)

Alan Cox

December 31, 2008, 3:36 pm

My experience with this item is, unfortunatly not good. I purchased it to replace an existing Netgear DG834G which had always performed well with no problems and this was one of the reasons that I upgraded it. About 4 months after I purchased it I switched it off because I was going on holiday and when I returned I could not get rid of the "red light" and consequetly I had no Internet connection so I had to go and purchase a Belkin Router as a spare as I had given my old Router to a friend. After protracted correspondence with the Support Desk I finally got it working again but was afraid to switch it off because of this problem - however it did happen again a couple of times but after getting the spare Belkin out I managed to get up and running. Recently it has suffered from the same problem nearly every day and the Support Desk finally admitted that it was a "hardware problem". A search of the Internet revealed that quite a number of other people had experienced the same problem and in many cases Netgear changed the Router or the cost was refunded. One person reported that the Customer Service Manager in Ireland had admitted that there was a problem with this model so I contacted Netgear again and sent them this information - they replied indicating that the Router that I had purchased had been previously registered some 6 months before I purchased it and as it was now out of warranty there was nothing that they could. I would add that I purchased it as a new item at a local Computer Fair and even if it had been registered some 6 months previously the problem was reported to them well within the 12 month period.


However, they still refused to do anything about it and they now deny that there is any problem with this item - obviously we have all been imagining the problem and the customer is obviously not always right in Netgear's eyes. Guess which equipment I will be recommending in future?

amster

March 23, 2009, 6:29 pm

I cannot recommend this router to anyone. It's been nothing but a pain since I've had it. Sometimes, I lose internet connectivity to both wired and wireless clients, and as there is no switch on this router, I have to unplug it from the power source manually. However, and here's an inherent problem with these routers - when you unplug them from the power source, and plug the power back in straight after - the lights on the router go red, and it refuses to boot. The only solution is to leave it unplugged for 10 minutes! This is a well known problem unfortunately, and NetGear have done nothing to resolve it for the many users experiencing these issues - I guess maybe because - it's a hardware issue. The only advice I got from netgear support, was to return the item - which I duly did.

comments powered by Disqus