Summary

Our Score

7/10

Review Price free/subscription

D-Link jumped on the draft-802.11n merry-go-round a few months ago with its RangeBooster N650 router which offers a good range of features but ultimately failed to impress in the wireless performance stakes. The DSL-2740B represents its next stab at the high-speed networking market and adds an integrated ADSL 2/2+ modem and a few extra features to the mix.

Along with the draft-n wireless access point and ADSL modem, the router has a quartet of switched Fast Ethernet ports but the USB port that had everyone baffled as to its use on the N650 has been removed. With regard to the manufacturer’s claimed speeds for draft-n wireless products it is worth reiterating the points we made with the N650. Speeds for draft-n wireless are touted to be in the region of 300Mbps. We already know from extensive testing that this is utter baloney but, even if it weren’t, unless you have Gigabit Ethernet ports on the router it’s impossible to achieve speeds higher than 100Mbps between WLAN and LAN systems.



Back to the router and under the bonnet you’ll find a good range of security features which include an SPI firewall that can be customised with your own filtering rules and some useful parental controls. Wireless security looks good as well with 64/128-bit WEP plus WPA and WPA2 encryption, MAC address filtering and, for larger companies, 802.1x authentication via a RADIUS server.

We found installation easy enough as the CD-ROM based installation wizard searches for the router, checks to see if an ADSL connection is up and then asks for your ISP details. An entry was provided for BT Broadband so we just added our account details and we were up, up and away in a matter of minutes. The routine also runs through wireless access setup but does give you the option of leaving it unsecured.

From here on things didn’t go so smoothly as although we had Internet access we were unable to logon to the web management interface. The only way round this was to reset the unit back to its factory defaults and reinstall it again after which the problem disappeared. We were also very surprised to find that the SPI firewall and intrusion detection functions were switched off by default. Certainly, the former must be enabled without any delays otherwise you’ll have no protection at all.

Next page
comments powered by Disqus