Summary

Our Score

8/10

User Score

Review Price free/subscription

:

In much the same way that Canon's G-series has for many years set the benchmark for high-end compacts, the S-series has, since its introduction in 2004, set the standard for super-zoom bridge cameras. The last model in the series was the S5 IS, launched in 2007, which featured a 12x zoom optically stabilised lens, 8.0 megapixel CCD sensor and VGA 30fps video recording with stereo audio.

Canon has now merged the S series with its new SX line, and the S5 has been replaced by two models; the £400 CMOS-sensored SX1 IS, which I will be reviewing next week, and today's review camera, the 10-megapixel, 20x zoom SX10 IS.

At £280 the SX10 is quite expensive, but then so are a lot of its competitors, cameras such as the much-commented-upon Panasonic FZ28 (£243), the Olympus SP-570 UZ (£245) and new SP-590 UZ (review coming soon) and the Nikon P80 (£250). However even by these standards the SX10 IS is a bit pricey.

Externally the SX10 IS looks very similar to its predecessor. It is a large camera even by super-zoom standards, only a little smaller than a compact DSLR. In fact it's almost exactly the same size as the Panasonic Lumix G1 that I reviewed last week. At 560g it's also quite heavy. A substantial portion of that is accounted for by the weight of the big zoom lens and the four AA batteries that power it, but it also reflects the camera's robust build quality.

The lens is impressive though. It's quite a wide, squat shape, but extends just over 5cm at full zoom. The top of the lens barrel is marked with the equivalent 35mm focal length settings, from 28mm to 560mm, but this is largely cosmetic since the lines don't actually match the selected focal length with any real accuracy.

The camera's SLR-like shape provides excellent handling, and the large handgrip is very secure and comfortable to hold. The shaped and textured thumbgrip area on the back also ensures a firm grip, although I did that the position and sensitivity of the D-pad control on the rear of the camera to be a frequent problem. On several occasions I accidentally switched the camera into manual focus mode or changed the ISO setting by jogging the D-pad with my thumb while shooting, but then maybe that's just me being a clumsy twit.

Next page
comments powered by Disqus